Komunikat o błędzie w różnych miejscach w programie Microsoft Dynamics SL: "System wiadomości 5045"


Objawy


Należy wziąć pod uwagę następujące scenariusze w różnych miejscach w programie Microsoft Dynamics SL.
  • Spróbuj zalogować się do systemu Microsoft Dynamics SL. Zobacz przyczyny 1, 2 lub 3.
  • Lub wykonać każdą czynność, którą tworzy dziennik zdarzeń Microsoft Dynamics SL. Zobacz wszystkie przyczyny.
  • Można też kliknąć Start w oknie Bazy danych fizycznych sprawdzania integralności (95.500.00) . Zobacz przyczyny 5.
W tych scenariuszach pojawić następujący komunikat o błędzie:

Komunikat systemowy 5045 - błąd pliku podczas otwierania pliku stanu procesu

Przyczyna


Przyczyna 1:

Identyfikator użytkownika systemu Windows ma niewystarczające uprawnienia do działania. Patrz Rozwiązanie 1.

Przyczyny 2:

Dysk logiczny mapowane do instalacji systemu Microsoft Dynamics SL jest niepoprawna. Patrz Rozwiązanie 2.

Przyczyny 3:

Plik Solomon.ini na komputerze, stacji roboczej jest uszkodzony. Patrz Rozwiązanie 3.

Przyczyna 4:

Pliki dziennika zdarzeń są uszkodzone. Patrz Rozwiązanie 4.

Przyczyny 5:

Tabela PSTATUS jest uszkodzona. Patrz Rozwiązanie 5.

Rozwiązanie


Rezolucja 1:

Dla użytkowników systemu Microsoft Dynamics SL, należy przypisać odpowiednie uprawnienia.
  1. Skontaktuj się z administratorem sieci, aby sprawdzić, czy identyfikator użytkownika systemu Windows ma wystarczające uprawnienia.
  2. Upewnij się, że wszyscy użytkownicy Microsoft Dynamics SL mają pełną kontrolę nad katalogu, w którym zainstalowano program Microsoft Dynamics SL. Domyślna lokalizacja instalacji jest następująca:
    • Microsoft Dynamics SL 7.0 i nowszych wersjach: litera_dysku: \Program Files\Microsoft Dynamics\SL\Applications
    • Microsoft Dynamics SL 6.5 i wcześniejszych wersji: litera_dysku: \Program Files\Solomon\

Rezolucja 2:

Udostępnianie i mapowania dysku do poprawnie. Domyślną lokalizacją instalacji systemu Microsoft Dynamics SL jest w następujący sposób:
  • Microsoft Dynamics SL 7.0 i nowszych wersjach: litera_dysku: \Program Files\Microsoft Dynamics\SL\Applications
  • Microsoft Dynamics SL 6.5 i wcześniejszych wersji: litera_dysku: \Program Files\Solomon
W takim przypadku powinny być mapowane dyski ze stacji roboczej komputerów do katalogu głównego woluminu lub do jednego z następujących miejsc, w zależności od wersji:
  • Microsoft Dynamics SL 7.0 i nowszych wersjach: litera_dysku: \Program Files\Microsoft Dynamics SL\
  • Microsoft Dynamics SL 6.5 i wcześniejszych wersji: litera_dysku: \Program Files\
Oznacza to, że albo katalogu głównego woluminu lub jednej z lokalizacji omówione wcześniej ma być udostępniany. Z komputerów stacji roboczej właściwości ikony programu głównego powinna być:
  • Microsoft Dynamics SL 7.0 i nowszych wersjach: litera_dysku: \SL\Applications\MSDynamicsSL.exe lub DriveLetter:\Applications\MSDynamicsSL.exe
  • Microsoft Dynamics SL 6.5 lub wcześniejszych wersji: litera_dysku: \Program Files\Solomon\Parent.exe lub DriveLetter:\Solomon\Parent.exe
Uwaga Właściwości ikony nie powinien być jednym z następujących lokalizacji (które oznacza główny mapy):
  • Microsoft Dynamics SL 7.0 i nowszych wersjach: litera_dysku: \MSDynamicsSL.exe
  • Microsoft Dynamics SL 6.5 i wcześniejszych wersji: litera_dysku: \Parent.exe
Właściwości ikony nie powinien być jednym z następujących lokalizacji (które oznacza ścieżkę UNC):
  • Microsoft Dynamics SL 7.0 i nowszych wersjach: \nazwa_serwera\Nazwa udziału\Applications\MSDynamicsSL.exe
  • Microsoft Dynamics SL 6.5 i starsze wersje: \nazwa_serwera\Nazwa udziału\Solomon\Parent.exe
Ścieżki UNC nie są obsługiwane w ramach systemu Microsoft Dynamics SL lub Microsoft Business Solutions — Wyspy Salomona.

Rozwiązanie 3:

Zmień nazwę wszystkich Solomon.ini plików na komputerze, stacji roboczej, na Solomon.old. Aby uzyskać więcej informacji o zmianie nazwy pliku Solomon.ini, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

Gdzie można znaleźć pliku Solomon.ini w programie Microsoft Dynamics SL Rozwiązywanie problemów z 2005087


Rozwiązanie 4:

Usuń wszystkie pliki dziennika zdarzeń w następujących lokalizacjach:
  • Microsoft Dynamics SL 7.0 i nowszych wersjach: litera_dysku: \Program Files\Microsoft Dynamics\SL\Applications\Eventlog\
  • Microsoft Dynamics SL 6.5 i wcześniejszych wersji: litera_dysku: \Program Files\Solomon\Eventlog\

Rozwiązanie 5:

Usuwanie uszkodzonych rekordów w tabeli PSTATUS.

Uwaga Przed wykonaniem instrukcji z tego artykułu, upewnij się, że masz pełną kopię zapasową bazy danych, które można przywrócić w przypadku pojawienia się problemu.
Za pomocą programu SQL Server Management Studio lub SQL Query Analyzer, uruchom następującą instrukcję bazy danych aplikacji Microsoft Dynamics SL lub Microsoft Business Solutions — Wyspy Salomona bazy danych aplikacji:
Delete from PSTATUS