Rozmiar pliku skoroszytu programu Excel nieoczekiwanie może zwiększyć wykładniczo

Dotyczy: Microsoft Office Excel 2007Microsoft Office Excel 2003

Objawy


Rozmiar pliku skoroszytu programu Microsoft Excel nieoczekiwanie może zwiększyć wykładniczo. Dodatkowo Jeśli wszyscy użytkownicy udostępnionego skoroszytu Zapisz i zamknij skoroszyt, skoroszyt może nie zmniejszyć rozmiar pliku tak, jak powinien.

Uwaga Pliki programu Excel 2007 są oparte na połączeniu XML i kompresji, typy plików są zwykle mniejsze niż starsze typy plików XLS. Jednak ten problem może wystąpić w dowolnej wersji programu Excel, które są wymienione w sekcji "Informacje zawarte w tym artykule dotyczą".

Przyczyna


Ten problem może wystąpić, jeśli nieoczekiwane zamknięcie programu Excel. W takim przypadku użytkownicy mogą nie poprawnie odłączone od udostępnionego skoroszytu.

Rozwiązanie


Aby rozwiązać ten problem, odłączyć wszystkich użytkowników, którzy obecnie nie używasz skoroszytu, Zapisz skoroszyt, a następnie zamknij skoroszyt.

Ważne: Sprawdź u użytkowników, których chcesz odłączyć, że rzeczywiocie już nie pracują w skoroszycie. Jeśli rozłączysz aktywnego użytkownika niezapisaną pracę tego użytkownika zostaną utracone.

Aby rozłączać użytkowników, którzy obecnie nie używasz skoroszytu, wykonaj następujące kroki, odpowiednie dla używanej wersji programu Excel, które są uruchomione.

Program Excel 2007

  1. Otworzyć udostępniony skoroszyt w programie Excel 2007.
  2. Kliknij kartę Przegląd .
  3. W grupie zmiany kliknij przycisk Udostępnij skoroszyt.
  4. Na karcie Edycja kliknij nazwę każdego użytkownika, którego chcesz odłączyć, a następnie kliknij przycisk Usuń użytkownika po każdej nazwie.

Program Microsoft Office Excel 2003 i starszych wersjach programu Excel

  1. W menu Narzędzia kliknij polecenie Udostępnij skoroszyt, a następnie kliknij kartę Edycja .
  2. W polu Użytkownicy posiadający obecnie otwarty ten skoroszyt przejrzeć listę użytkowników.
  3. Kliknij nazwę każdego użytkownika, którego chcesz odłączyć, a następnie kliknij przycisk Usuń użytkownika.

Więcej informacji


Problem opisany w tym artykule może wystąpić niezależnie od tego, czy została użyta opcja nie przechowuj historii zmian w programie Excel. Program Excel przechowuje informacje o wszelkie zmiany, które są wymagane do synchronizacji między użytkownikami skoroszytu. Program Excel przechowuje te zmiany w pamięci, dopóki nie zapiszesz skoroszytu. Podczas zapisywania skoroszytu programu Excel zapisuje te zmiany na dysku twardym.

W każdym przypadku, gdy nieoczekiwane zamknięcie programu Excel ghost nazwy użytkowników mogą pozostać w udostępnionym skoroszycie. Skoroszyt do śledzenia wersji udostępnionego skoroszytu, do którego użytkownik był ostatnio synchronizowany. Skoroszyt jest to tak, że zmiany wprowadzone po synchronizacji nie zostaną usunięte.



Aby uniknąć problemu opisanego w tym artykule, należy użyć następujących zalecanych rozwiązań:
  • Należy często zapisywać. Im dłuższy interwał między operacji zapisywania, tym więcej pamięci, który jest używany przez przechowywane rekordów zmian, które nie zostały zapisane do pliku.
  • Upewnij się, że każdy użytkownik zamyka skoroszyt udostępniony codziennie. Ta procedura uniemożliwia ghost nazw użytkowników. Ponadto ta procedura umożliwia zmienianie rekordów, które znajdują się w pamięci zostaną usunięte.
  • Okresowo Znajdź i Usuń wszystkie nazwy użytkownika ghost, które są pozostawione w skoroszycie. Następnie zapisz i zamknij skoroszyt.