Komunikat o błędzie podczas uruchamiania raportu niestandardowego programu Crystal Reports w Microsoft Dynamics SL: "Błąd aparatu wydruku Crystal: nie można odnaleźć tabeli 709"


Objawy


Rozważ następujący scenariusz:
  • Używasz Microsoft Dynamics SL 7.0 lub Microsoft Dynamics SL 2011.
  • Użyj niestandardowych raportów Crystal Reports.
  • Możesz zalogować się przy użyciu uwierzytelniania systemu Windows.
W tym scenariuszu pojawić następujący komunikat o błędzie:
Aplikację pomocniczą raportów Crystal IV Salomona
Dostać kwerendy SQL nie powiodło się raport: C:\Program Files\Microsoft Dynamics SL\Usr_Rpts\03730DET. RPT.
Błąd aparatu wydruku Crystal: 709 - błąd w pliku C:\Program Files\Microsoft Dynamics SL\Usr_Rpts\03730DET. RPT:

Nie można odnaleźć tabeli.

Przyczyna


Przyczyny 1

Ten błąd występuje, ponieważ są spełnione następujące warunki:
  • Raport programu Crystal Reports używa niestandardowych tabel lub widoków niestandardowych.
  • Użytkownik E7F575915A2E4897A517779C0DD7CE Microsoft SQL Server lub rola aplikacji MSDSL programu SQL Server nie ma wymaganych uprawnień do niestandardowej tabeli lub widoku niestandardowego. Patrz Rozwiązanie 1 w sekcji "Rozwiązanie".

Przyczyny 2

Połączenie Open Database Connectivity (ODBC) jest nieprawidłowo skonfigurowana do korzystania z uwierzytelniania systemu Windows zamiast uwierzytelniania programu SQL Server. Przy pierwszym uruchomieniu raportu programu Crystal Reports na nowej stacji roboczej, połączenie ODBC jest tworzony dla bazy danych systemu Microsoft Dynamics SL i baza danych aplikacji Microsoft Dynamics SL. To połączenie należy skonfigurować do korzystania z uwierzytelniania programu SQL Server, nawet jeśli używasz uwierzytelniania systemu Windows do logowania się do systemu Microsoft Dynamics SL. Patrz Rozwiązanie 2 w sekcji "Rozwiązanie".

Rozwiązanie


Rezolucja 1

Przypisz odpowiednie prawa do niestandardowej tabeli lub widoku niestandardowego. Aby to zrobić, wykonaj następujące kroki:
  1. Uruchom program Microsoft SQL Server Management Studio.
  2. Rozwiń węzeł bazy danych, rozwiń bazę danych Dynamics SL, a następnie rozwiń tabel lub widoków.
  3. Zlokalizuj na liście niestandardowej tabeli lub widoku niestandardowego.
  4. Kliknij prawym przyciskiem myszy niestandardowej tabeli lub widoku niestandardowego. Następnie wybierz Właściwości.
  5. W okienku Wybierz stronę kliknij przycisk uprawnienia.
  6. Kliknij przycisk Dodaj, wpisz MSDSL, a następnie kliknij przycisk OK.
  7. Wybierz uprawnieniekliknij, aby zaznaczyć pole wyboru Udziel .
  8. Kliknij przycisk Dodaj.
  9. Kliknij przycisk Przeglądaj. Kliknij, aby zaznaczyć pole wyboru obok użytkownika E7F575915A2E4897A517779C0DD7CE .
  10. Kliknij dwa razy przycisk OK .
  11. Uprawnienie Kontrolakliknij, aby zaznaczyć pole wyboru Udziel .

Rezolucja 2

Aby rozwiązać ten problem, Usuń połączenia ODBC, a Niech Microsoft Dynamics SL ponownie utworzyć połączenia. Aby to zrobić, wykonaj następujące kroki:
  1. Kliknij przycisk Start, kliknij przycisk Ustawienia, a następnie kliknij polecenie Panel sterowania.
  2. Kliknij ikonę Narzędzia administracyjne.
  3. Kliknij przycisk źródła danych (ODBC).
  4. Na karcie DSN użytkownika Usuń wszystkie wpisy do bazy danych systemu Microsoft Dynamics SL i bazy danych aplikacji Microsoft Dynamics SL.
  5. Na karcie Systemowe DSN Usuń wszystkie wpisy do bazy danych systemu Microsoft Dynamics SL i bazy danych aplikacji Microsoft Dynamics SL.
  6. Ponownie zalogować się do systemu Microsoft Dynamics SL, a następnie spróbuj ponownie użyć raportu. Pozycje DSN użytkownika powinny być ponownie utworzony automatycznie.