Komunikat o błędzie podczas próby zainstalowania, uaktualnienia lub skonfigurować klienta Microsoft Dynamics CRM dla programu Outlook na komputerze

Dotyczy: Dynamics CRM 4.0Dynamics CRM 4.0

Objawy


Podczas instalowania lub uaktualniania klienta Microsoft Dynamics CRM dla programu Microsoft Office Outlook na komputerze, pojawi się następujący komunikat o błędzie:
Działanie Microsoft.Crm.Config.Client.InstallAbpAction nie powiodło się.

Odmowa dostępu. (Wyjątek od HRESULT: 0x80070005 (E_ACCESSDENIED))
Ponadto zostanie wyświetlony jeden z następujących komunikatów o błędach.
Komunikat o błędzie 1
Po zainstalowaniu klienta Microsoft Dynamics CRM 4.0 dla programu Outlook na komputerze, pojawi się następujący komunikat o błędzie w dzienniku konfiguracji:
12:58:46 | Błąd | Wyjątek konfiguracji. System.Exception: Działanie Microsoft.Crm.Config.Client.InstallAbpAction nie powiodło się. --->
System.UnauthorizedAccessException: Odmowa dostępu. (Wyjątek od HRESULT: 0x80070005 (E_ACCESSDENIED))

w System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal (Int32 errorCode, właściwość errorInfo IntPtr)

w Microsoft.Crm.Config.Client.InstallAbpAction.Do (IDictionary parametry)

w Microsoft.Crm.Setup.Common.Action.ExecuteAction (działania działania, parametry IDictionary, Boolean Cofnij)

---Koniec śledzenia wewnętrznego stosu wyjątków---

w Microsoft.Crm.Setup.Common.Action.ExecuteAction (działania działania, parametry IDictionary, Boolean Cofnij)

w Microsoft.Crm.Setup.Common.Installer.Install (IDictionary stateSaver)

w Microsoft.Crm.Setup.Common.ComposedInstaller.InternalInstall (IDictionary stateSaver)

w Microsoft.Crm.Setup.Common.ComposedInstaller.Install (IDictionary stateSaver)

w Microsoft.Crm.Config.Client.ClientConfig.Install (IDictionary dane)

o Microsoft.Crm.Config.Client.ClientConfig.Run() 12:58:46 | Verbose | Konfiguracja nie powiodła się 12:58:46 | Informacje | Nie udało się pomyślnie skonfigurować programu Microsoft Dynamics CRM dla programu Outlook:



Działanie Microsoft.Crm.Config.Client.InstallAbpAction nie powiodło się.

Odmowa dostępu. (Wyjątek od HRESULT: 0x80070005 (E_ACCESSDENIED))
Komunikat o błędzie nr 2
Podczas uaktualniania klienta Microsoft Dynamics CRM 3.0 dla programu Outlook na komputerze, pojawi się następujący komunikat o błędzie w dzienniku instalacji:
UpgradeDatabase.Action

UpgradeDatabase.Started

Wyszukiwanie plików bazy danych

Przenoszenie plików bazy danych

Akcje gotowego bazy danych

Przypisywanie uprawnień do S-1-5-21-682003330-616249376-1801674531-1112

C:\Program Files\Microsoft CRM\sql\v3_msde_mscrm.mdf

w System.Security.AccessControl.NativeObjectSecurity.CreateInternal (ResourceType resourceType, isContainer typu Boolean, ciąg nazwy, uchwyt SafeHandle, AccessControlSections includeSections, createByName typu Boolean, ExceptionFromErrorCode exceptionFromErrorCode, exceptionContext obiektu)

w System.Security.AccessControl.FileSystemSecurity... Konstruktor (Boolean isContainer, nazwa ciągu, AccessControlSections includeSections, isDirectory typu Boolean)

w System.Security.AccessControl.FileSecurity... Konstruktor (ciąg nazwy pliku, AccessControlSections includeSections)

w System.IO.FileInfo.GetAccessControl() w Microsoft.Crm.Setup.Client.DatabaseInstaller.Upgrade (sesja sesji)

w Microsoft.Crm.Setup.Client.ClientSetup.UpgradeDatabase (sesja sesji)

Akcja zakończona 10:33:09: InstallFinalize. Wartość zwrócona 3.
Podczas próby skonfigurowania wersji programu Outlook w trybie Offline klienta programu Microsoft Dynamics CRM 4.0 konsekwentnie pojawi się następujący błąd w okno modalne Ponów próbę lub anulować :
Działanie Microsoft.Crm.Config.Client.InstallPstAction nie powiodło się. LaunchOutlookInstallerProcess nie powiodło się.

Przyczyna


Ten problem może wystąpić, jeśli plik danych programu Microsoft Dynamics CRM nie został całkowicie usunięty i nie zostały całkowicie usunięte kontakty (ABP) dostawcy książki adresowej programu Microsoft Dynamics CRM.

Rozwiązanie


Rezolucja 1

Aby rozwiązać ten problem, użyj jednej z następujących metod, a następnie spróbuj zainstalować lub uaktualnić klienta Microsoft Dynamics CRM dla programu Outlook na komputerze.

Metoda 1: Jeśli masz Microsoft Office Outlook 2007 zainstalowany

  1. Uruchom program Outlook 2007.
  2. W menu Narzędzia kliknij przycisk Ustawienia kont.
  3. Kliknij kartę Pliki danych .
  4. Kliknij pozycję Microsoft CRM, a następnie kliknij przycisk Usuń.
  5. Kliknij kartę Książki adresowe .
  6. Kliknij przycisk Książka adresowa programu Microsoft CRM, a następnie kliknij przycisk Usuń.
  7. Zamknij program Outlook 2007.

Metoda 2: Jeśli masz Microsoft Office Outlook 2003 zainstalowany

  1. Zakończ działanie programu Outlook 2003.
  2. Kliknij przycisk Start, kliknij polecenie Panel sterowania, kliknij Aplet Konta użytkowników, a następnie kliknij poczty.
  3. W oknie dialogowym Ustawienia poczty kliknij przycisk Pliki danych.
  4. Kliknij Programu Microsoft CRM, kliknij przycisk Usuń, a następnie kliknij przycisk Zamknij.
  5. W oknie dialogowym Ustawienia poczty kliknij przycisk Konta E-mail.
  6. Kliknij opcję Wyświetl lub zmień istniejące katalogi lub książki adresowe, a następnie kliknij przycisk Dalej.
  7. Kliknij przycisk Książka adresowa programu Microsoft CRM, a następnie kliknij przycisk Usuń.
  8. Kliknij przycisk Zamknij , aby zamknąć okno dialogowe Ustawienia poczty .

Rezolucja 2

Wykonaj następujące kroki:
  1. Uruchom program Outlook.
  2. W menu Narzędzia kliknij polecenie Opcje.
  3. Na karcie Ustawienia poczty kliknij przycisk Konta E-mail.
  4. Na karcie Pliki danych wybierz Program Microsoft CRM-nie jest dostępna, a następnie kliknij przycisk Usuń.