Jesteś obecnie w trybie offline. Czekamy na ponowne połączenie z Internetem.

XL: Jak utworzyć wykres krzywej dzwonowej

Streszczenie
Krzywa dzwonowa jest wykresem rozkładu normalnego danego zbioru danych. W tym artykule jest opisany sposób tworzenia wykresu krzywej dzwonowej w programie Microsoft Excel.
Więcej informacji
W poniższym przykładzie możesz utworzyć krzywą dzwonową dla danych wygenerowanych przez program Excel za pomocą narzędzia Generowanie liczb losowych w dodatku Analysis ToolPak. Po wygenerowaniu zbioru liczb losowych przez program Microsoft Excel możesz utworzyć histogram za pomocą tych liczb losowych i narzędzia Histogram z dodatku Analysis ToolPak. Na podstawie histogramu możesz utworzyć wykres reprezentujący krzywą dzwonową.

Aby utworzyć przykładową krzywą dzwonową, wykonaj następujące kroki:
  1. Uruchom program Excel.
  2. W nowym arkuszu wpisz następujące nagłówki kolumn:
       A1:Oryginalne  B1:Średnia  C1:Zbiór  D1:Losowe  E1:Histogram  G1:Histogram					
  3. W tym samym arkuszu wpisz następujące dane:
       A2: 23        B2:   A3: 25        B3: ODCH.STANDARDOWE   A4: 12        B4:   A5: 24   A6: 27   A7: 57   A8: 45   A9: 19					
  4. W tym samym arkuszu wpisz następujące formuły:
       B2:  =ŚREDNIA(A2:A9)   B3:   B4:  =ODCH.STANDARDOWE(A2:A9)						
    Te formuły wygenerują odpowiednio wartość średnią i odchylenie standardowe dla oryginalnych danych.
  5. Wprowadź następujące formuły, aby wygenerować binarny zakres histogramu:
       C2: =$B$2-3*$B4						
    Ta formuła generuje dolną granicę zakresu binarnego. Ta liczba reprezentuje trzy odchylenia standardowe mniejsze od wartości średniej.
       C3: =C2+$B$4						
    Ta formuła dodaje jedno odchylenie standardowe do liczby obliczonej w komórce powyżej.
  6. Wybierz komórkę C3, chwyć uchwyt wypełniania, a następnie wypełnij formułą komórki od C3 do C8.
  7. Aby wygenerować dane losowe, które utworzą podstawę krzywej dzwonowej, wykonaj następujące kroki:
    1. W menu Narzędzia kliknij polecenie Analiza danych.
    2. W polu Narzędzia analizy kliknij polecenie Generowanie liczb pseudolosowych, a następnie kliknij przycisk OK.
    3. W polu Liczba zmiennych wpisz 1.
    4. W polu Liczba wartości wpisz 2000.

      UWAGA: Zmiana tej liczby spowoduje zwiększenie lub zmniejszenie dokładności krzywej dzwonowej.
    5. W polu Rozkład wybierz opcję Normalny.
    6. W okienku Parametry wpisz liczbę obliczoną w komórce B2 (w tym przykładzie 29) w pole Średnia.
    7. W polu Odchylenie standardowe wpisz liczbę obliczoną w komórce B4 (14,68722).
    8. Pole Rozrzut należy pozostawić puste.
    9. W okienku Opcje wyjścia kliknij opcję Zakres wyjściowy.
    10. W polu Zakres wyjściowy wpisz D2.

      Zostanie wygenerowanych 2000 liczb losowych zgodnych z rozkładem normalnym.
    11. Kliknij przycisk OK.
  8. Aby utworzyć histogram dla danych losowych, wykonaj następujące kroki:
    1. W menu Narzędzia kliknij polecenie Analiza danych.
    2. W polu Narzędzia analizy kliknij polecenie Histogram, a następnie kliknij przycisk OK.
    3. W okienku Wejściew polu Zakres komórek wpisz D2:D2001.
    4. W polu Zakres zbioru wpisz C2:C8.
    5. W okienku Opcje wyjścia kliknij opcję Zakres wyjściowy.
    6. W polu Zakres wyjściowy wpisz E2.
    7. Kliknij przycisk OK.
  9. Aby utworzyć histogram dla danych oryginalnych, wykonaj następujące kroki:
    1. W menu Narzędzia kliknij polecenie Analiza danych.
    2. Kliknij polecenie Histogram, a następnie kliknij przycisk OK.
    3. W polu Zakres wejściowy wpisz A2:A9.
    4. W polu Zakres pojemnika wpisz C2:C8.
    5. W okienku Opcje wyjścia kliknij opcję Zakres wyjściowy.
    6. W polu Zakres wyjściowy wpisz G2.
    7. Kliknij przycisk OK.
  10. Utwórz etykiety legendy na wykresie, wpisując następujące wartości:
       E14: =G1&"-"&G2   E15: =E1&"-"&F2   E16: =G1&"-"&H2					
  11. W arkuszu wybierz zakres komórek E2:H10.
  12. W menu Wstaw kliknij polecenie Wykres.
  13. W obszarze Typ wykresu kliknij pozycję XY (Punktowy).
  14. W obszarze Podtyp wykresu kliknij prawy wykres w środkowym wierszu.

    UWAGA: Pod tymi 5 podtypami znajduje się opis, który mówi „Wykres punktowy z punktami danych połączonymi wygładzonymi liniami bez znaczników danych”.
  15. Kliknij przycisk Dalej.
  16. Kliknij kartę Serie.
  17. W polu Nazwa usuń odwołanie do komórki, a następnie wybierz komórkę E15.
  18. W polu Wartości X usuń odwołanie do zakresu, a następnie wybierz zakres E3:E10.
  19. W polu Wartości Y usuń odwołanie do zakresu, a następnie wybierz zakres F3:F10.
  20. Kliknij przycisk Dodaj, aby dodać kolejną serię.
  21. Kliknij pole Nazwa, a następnie wybierz komórkę E14.
  22. Kliknij pole Wartości X, a następnie wybierz zakres E3:E10.
  23. W polu Wartości Y usuń znajdującą się tam wartość, a następnie wybierz zakres G3:G10.
  24. Kliknij przycisk Dodaj, aby dodać kolejną serię.
  25. Kliknij pole Nazwa, a następnie wybierz komórkę E16.
  26. Kliknij pole Wartości X, a następnie wybierz zakres E3:E10.
  27. W polu Wartości Y usuń znajdującą się tam wartość, a następnie wybierz zakres H3:H10.
  28. Kliknij przycisk Zakończ.

    Na wykresie będą się znajdowały dwie krzywe serii i płaska seria wzdłuż osi x.
  29. Kliknij dwukrotnie drugą serię; w legendzie powinna się ona nazywać „— Pojemnik”.
  30. W oknie dialogowym Formatuj serie danych kliknij kartę .
  31. Kliknij opcję Oś pomocnicza, a następnie kliknij przycisk OK.
Teraz masz wykres porównujący dany zbiór danych z krzywą dzwonową.
Materiały referencyjne
Aby uzyskać więcej informacji o tworzeniu wykresów, kliknij polecenie Microsoft Excel — Pomoc w menu Pomoc, wpisz tekst tworzenie wykresu w Asystencie pakietu Office lub Kreatorze odpowiedzi i kliknij przycisk Wyszukaj w celu wyświetlenia tematu.
XL2000 XL97
Właściwości

Identyfikator artykułu: 213930 — ostatni przegląd: 03/31/2006 15:34:13 — zmiana: 2.1

Microsoft Excel 2000 Standard Edition, Microsoft Excel 97 Standard Edition

  • kbhowto KB213930
Opinia
[0].appendChild(m);