Komunikat o błędzie "Authorization_RequestDenied" podczas próby zmiany hasła, jeśli wykres API

WAŻNE: Ten artykuł został przetłumaczony przy użyciu oprogramowania firmy Microsoft do tłumaczenia maszynowego i może być poprawiony przy użyciu technologii Community Translation Framework (CTF). Firma Microsoft udostępnia artykuły tłumaczone maszynowo, poprawione przez społeczność, a także tłumaczone przez tłumaczy profesjonalnych, aby zapewnić dostęp do wszystkich artykułów w bazie wiedzy w wielu językach. Artykuły tłumaczone maszynowo i poprawione mogą zawierać błędy pisowni, składniowe i gramatyczne. Firma Microsoft nie ponosi odpowiedzialności za żadne nieścisłości, błędy ani szkody spowodowane przez niepoprawne tłumaczenia zawartości ani przez korzystanie z niej przez klientów. Więcej o strukturze CTF: http://support.microsoft.com/gp/machine-translation-corrections/pl.

Anglojęzyczna wersja tego artykułu to: 3004133
PROBLEM
Jeśli użytkownik usiłuje zmienić hasło użytkownika Microsoft Azure usługi Active Directory (Azure AD) i ustawienie Rola organizacyjnadla tego użytkownika jest ustawiona opcja wszelkie "Administrator", proces kończy się niepowodzeniem i generuje następujący komunikat o błędzie:

{"odata.error":{"code":"Authorization_RequestDenied","message":{"lang":"en","value":"Insufficient uprawnienia do ukończenia tej operacji."}}}

Kiedy można nadać uprawnienia do odczytu i zapisu danych katalogu aplikacji lub głównej usługi aplikacji, Włącz aplikację zmienić hasło typowy Azure AD użytkownika przy użyciu interfejsu API wykres. Na poniższej ilustracji przedstawiono to ustawienie.
ekran uprawnienia
Użytkownika w usłudze Azure AD jako administrator można delegować przez zmianę ustawienia Roli w organizacji użytkownika, jak pokazano na poniższej ilustracji.
Rola ekranu
PRZYCZYNA
Ten problem występuje, ponieważ użytkownicy, którzy mają jedną z ról organizacyjnych "Administrator" nie są członkami "firmy Administrator" lub "Konta użytkownika Administrator" w rolach administracyjnych pakietu Office 365.
ROZWIĄZANIE
Aby rozwiązać ten problem, należy dodać aplikację, aby Administrator"Firma" w ról administracyjnych pakietu Office 365. Aby to zrobić, uruchom wszystkie następujące Azure AD Module dla poleceń cmdlet programu Windows PowerShell (MSOL):

   #-----------------------------------------------------------   # This will prompt you for your tenant's credential   # You should be able to use your your Azure AD administrative user name   # (in the admin@tenant.onmicrosoft.com format)   #-----------------------------------------------------------   Connect-MsolService       #-----------------------------------------------------------   # Replace the Application Name with the name of your    # Application Service Principal   #-----------------------------------------------------------   $displayName = "Application Name"   $objectId = (Get-MsolServicePrincipal -SearchString $displayName).ObjectId       #-----------------------------------------------------------   # This will add your Application Service Prinicpal to    # the Company Administrator role   #-----------------------------------------------------------   $roleName = "Company Administrator"                 Add-MsolRoleMember -RoleName $roleName -RoleMemberType ServicePrincipal -RoleMemberObjectId $objectId
Ponadto należy dodać aplikacji do "Konta użytkownika Administrator" w ról administracyjnych pakietu Office 365, jeśli użytkownik Azure AD ma jedną z następujących ról organizacyjnych "Administrator":
  • Administrator globalny
  • Administrator fakturowania
  • Administrator usługi

Aby to zrobić, uruchom wszystkie następujące apletów MSOL:

   #-----------------------------------------------------------   # This will prompt you for your tenant's credential   # You should be able to use your your Azure AD administrative user name   # (in the admin@tenant.onmicrosoft.com format)   #-----------------------------------------------------------   Connect-MsolService      #-----------------------------------------------------------   # Replace the Application Name with the name of your    # Application Service Principal   #-----------------------------------------------------------   $displayName = "Application Name"   $objectId = (Get-MsolServicePrincipal -SearchString $displayName).ObjectId      #-----------------------------------------------------------   # This will add your Application Service Principal to    # the Company Administrator role   #-----------------------------------------------------------   $roleName = "User Account Administrator"     Add-MsolRoleMember -RoleName $roleName -RoleMemberType ServicePrincipal -RoleMemberObjectId $objectId
Po uruchomieniu oba zestawy poleceń cmdlet, aplikacja zostanie włączony do zmiany hasła wszystkie role organizacyjne "Administrator".

Uwaga: Może to potrwać do 30 minut odpowiadające uprawnieniom, które mają być stosowane do aplikacji głównej usługi po dodaniu uprawnień do ról administracyjnych pakietu Office 365.
WIĘCEJ INFORMACJI
Aby uzyskać więcej informacji o resetowaniu haseł użytkowników za pomocą interfejsu API wykres, zobacz następującą witrynę sieci Web Microsoft Azure:

Nadal potrzebujesz pomocy? Przejdź do Społeczności użytkowników usługi Office 365 witryny sieci Web lub Fora Azure usługi Active Directory .

Ostrzeżenie: ten artykuł przetłumaczono automatycznie

Właściwości

Identyfikator artykułu: 3004133 — ostatni przegląd: 11/12/2015 18:47:00 — zmiana: 3.0

Microsoft Office 365, Microsoft Azure Active Directory

  • o365022013 o365 o365e o365m o365a kbgraphxlink kbmt KB3004133 KbMtpl
Opinia