Zdjęcia użytkownika nie są synchronizowane ze środowiska lokalnego do programu Exchange Online w danym wdrożeniu hybrydowy

WAŻNE: Ten artykuł został przetłumaczony przy użyciu oprogramowania firmy Microsoft do tłumaczenia maszynowego i może być poprawiony przy użyciu technologii Community Translation Framework (CTF). Firma Microsoft udostępnia artykuły tłumaczone maszynowo, poprawione przez społeczność, a także tłumaczone przez tłumaczy profesjonalnych, aby zapewnić dostęp do wszystkich artykułów w bazie wiedzy w wielu językach. Artykuły tłumaczone maszynowo i poprawione mogą zawierać błędy pisowni, składniowe i gramatyczne. Firma Microsoft nie ponosi odpowiedzialności za żadne nieścisłości, błędy ani szkody spowodowane przez niepoprawne tłumaczenia zawartości ani przez korzystanie z niej przez klientów. Więcej o strukturze CTF: http://support.microsoft.com/gp/machine-translation-corrections/pl.

Anglojęzyczna wersja tego artykułu to: 3062745
PROBLEM
Wdrożenie hybrydowe lokalnego Microsoft Exchange Server i Microsoft Exchange Online mają usługi Microsoft Office 365. Gdy zmieniasz zdjęcie użytkownika w usłudze Office 365 przez uzyskiwanie dostępu do informacji użytkownika lokalnego, zmiana nie jest zsynchronizowane z programem Exchange Online. Na przykład gdy użytkownik wyświetla jego lub jej zdjęcie w programie Outlook, Outlook w sieci web (dawniej znany jako aplikacji sieci Web programu Outlook) lub Skype dla firm Online, poprzednie Exchange Online zdjęcie profilu użytkownika jest nadal wyświetlany.
PRZYCZYNA
Mimo że atrybut thumbnailPhoto jest synchronizowane ze środowiska lokalnego Azure Active Directory (Azure AD), następujące rzeczy może powodować ten problem.

Uwaga: Atrybut thumbnailPhoto może przechowywać zdjęcie użytkownika tak duży, jak 100 kilobajtów (KB).
  • Atrybut thumbnailPhoto jest synchronizowany tylko jeden raz między Azure AD i Exchange Online. Wszelkie późniejsze zmiany atrybutu ze środowiska lokalnego nie są synchronizowane do skrzynki pocztowej programu Exchange w trybie Online.
  • Exchange Online akceptuje tylko zdjęcie, które nie jest większy niż 10 KB z Azure usługi Active Directory.
ROZWIĄZANIE
Aby zmienić zdjęcie użytkownika, należy użyć apletu polecenia Set-UserPhoto lub programu Outlook w sieci web. Te metody umożliwiają przekazywanie fotografii, który jest tak duży, jak 500 KB.

Należy użyć polecenia cmdlet Set-UserPhoto (dla grupy Administratorzy)

Aby użyć apletu polecenia Set-UserPhoto , aby zmienić zdjęcie użytkownika, wykonaj następujące kroki:
  1. Połączyć się Exchange Online przy użyciu zdalnego programu PowerShell. Aby to zrobić, wykonaj następujące kroki:

    Ważne: Aby użyć polecenia cmdlet Set-UserPhoto , do jego możliwości pełnego rozmiaru, trzeba zmienić połączenia URI dołączając ? proxyMethod = RPS z parametrem ConnectionUri .
    1. $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://outlook.office365.com/powershell-liveid/?proxyMethod=RPS -Credential (Get-Credential) -Authentication Basic -AllowRedirection  
    2. Import-PSSession $Session -AllowClobber -WarningAction SilentlyContinue -ErrorAction SilentlyContinue
    Aby uzyskać więcej informacji zobaczPołączyć się z usługą Exchange Online przy użyciu programu PowerShell.
  2. Uruchom polecenie Set-UserPhoto , aby zmienić zdjęcie użytkownika. Aby uzyskać więcej informacji zobacz Zestaw UserPhoto.

Za pomocą programu Outlook w sieci web

Aby uzyskać więcej informacji o tym, jak zmienić zdjęcie użytkownika w programie Outlook w sieci web zobaczAktualizuj moje zdjęcia i informacje o koncie w programie Outlook Web App.
WIĘCEJ INFORMACJI
Administratorzy można użyć apletu polecenia Set-UserPhoto Aby zmienić własne zdjęcie bez konieczności zmiany parametru ConnectionUri . Jednakże aby zmienić zdjęcie innego użytkownika, Administratorzy należy najpierw zmienić parametr ConnectionUri . Jeżeli parametr nie jest zmieniany, przy korzystaniu z polecenia cmdlet Aby zmienić zdjęcie użytkownika administratorzy pojawić się następujący komunikat o błędzie:
Żądania zwróciła błąd następujący komunikat o błędzie:
Serwer zdalny zwrócił błąd: (413) żądania jednostka za duża...
+ CategoryInfo: Płeć nieznana: (:) [Set-UserPhoto] CmdletProxyException
+ FullyQualifiedErrorId: Microsoft.Exchange.Configuration.CmdletProxyException,Microsoft.Exchange.Management.RecipientTasks.SetUserPhoto
+ PSComputerName: outlook.office365.com
ODWOŁANIA
Aby uzyskać więcej informacji zobacz następujący artykuł z bazy wiedzy Microsoft Knowledge Base:
2497721 Zdjęcia kontaktu użytkownika w Lync nie są wyświetlane prawidłowo
Nadal potrzebujesz pomocy? Przejdź do Społeczności użytkowników usługi Office 365 witryny sieci Web lub Fora TechNet programu Exchange.

Ostrzeżenie: ten artykuł przetłumaczono automatycznie

Właściwości

Identyfikator artykułu: 3062745 — ostatni przegląd: 03/11/2016 02:44:00 — zmiana: 3.0

Microsoft Exchange Online, Microsoft Exchange Server 2013 Enterprise, Microsoft Exchange Server 2013 Standard

  • o365022013 o365 o365e o365m o365a hybrid kbmt KB3062745 KbMtpl
Opinia