Błąd 1638 "już jest zainstalowana inna wersja tego programu" podczas instalowania magazynu konfiguracji lokalnej

WAŻNE: Ten artykuł został przetłumaczony przy użyciu oprogramowania firmy Microsoft do tłumaczenia maszynowego i może być poprawiony przy użyciu technologii Community Translation Framework (CTF). Firma Microsoft udostępnia artykuły tłumaczone maszynowo, poprawione przez społeczność, a także tłumaczone przez tłumaczy profesjonalnych, aby zapewnić dostęp do wszystkich artykułów w bazie wiedzy w wielu językach. Artykuły tłumaczone maszynowo i poprawione mogą zawierać błędy pisowni, składniowe i gramatyczne. Firma Microsoft nie ponosi odpowiedzialności za żadne nieścisłości, błędy ani szkody spowodowane przez niepoprawne tłumaczenia zawartości ani przez korzystanie z niej przez klientów. Więcej o strukturze CTF: http://support.microsoft.com/gp/machine-translation-corrections/pl.

Anglojęzyczna wersja tego artykułu to: 3077464
Sprawdź wymagania wstępne Przed zainstalowaniem magazynu konfiguracji lokalnej.
Symptomy
Po uruchomieniu programu Microsoft Skype dla Business Server 2015 Deployment Wizard do zainstalowania magazynu konfiguracji lokalnych na komputerze, na którym został zainstalowany zestaw SDK Unified Communications zarządzane API (UCMA) w wersji 5.0, Instalator nie może odnaleźć lokalizacji Microsoft Skype Business Server 2015, składniki podstawowe (OCSCore.msi). Pojawi się następujący komunikat o błędzie:
INSTALLDIR = "C:\Program Skype dla Business Server 2015\")...failure kod 1638
Zwrócony został błąd podczas instalowania OcsCore.msi(Feature_LocalMgmtStore), kod 1638. Komunikat o błędzie: Jest już zainstalowana inna wersja tego produktu. Nie można kontynuować instalacji tej wersji. Aby skonfigurować lub usunąć istniejącą wersję tego produktu, użyj apletu Dodaj/Usuń programy w Panelu sterowania. Więcej szczegółów można znaleźć w dziennik przy C:\Users\ [Użytkownik] \AppData\Local\Temp\1\Add-OcsCore.msi-Feature_LocalMgmtStore-[Data][Czas] .log
Przyczyna
Ten problem występuje, ponieważ UCMA 5.0 SDK instaluje nowszą wersję OCSCore.msi niż lokalny magazyn konfiguracji. Nie można więc zainstalować lokalnego magazynu konfiguracji po instalacji zestawu SDK w wersji 5.0 UCMA.
Rozwiązanie
Aby rozwiązać ten problem, wykonaj jedną z następujących metod, w zależności od scenariusza, których jesteś w i zainstalować Magazyn konfiguracji lokalnych na komputerze:
  • Jeśli nie masz zestawu SDK w wersji 5.0 UCMA zainstalowana na komputerze, wykonaj następujące czynności:
    • Uruchom Instalatora z pełnego programu Skype do konfiguracji programu Business Server i zainstaluj magazyn konfiguracji lokalnej.
    • Następnie installUCMA 5.0 SDK.

    Zwróć uwagęNastępujące kroki sprawi, że gdy działa UCMASdkSetup.exe, instalacja OCSCore.msi jest pomijany.
  • Jeśli zainstalowano już UCMA 5.0 SDK, wykonaj następujące czynności:
    • Odinstaluj OCSCore.msi, który był instalowany za pomocą zestawu SDK w wersji 5.0 UCMA. OCSCore.msi jest wymieniony jakoProgram Skype for Business Server 2015 r., podstawowe składniki w Panelu sterowania > Programy > programy i funkcje.
    • Uruchom ponownie instalację dla magazynu konfiguracji lokalnej.

    Zwróć uwagęJeśli próbujesz uruchomić Skype dla Business Server Deployment Wizard był instalowany za pomocą zestawu SDK w wersji 5.0 UCMA, wskaż pełnego programu Skype do konfiguracji programu Business Server, gdy pojawi się monit o ścieżkę msi.

Wymagania wstępne

Aby zainstalować Magazyn konfiguracji lokalnej, musi mieć dostęp do pełnego programu Skype do konfiguracji programu Business server 2015.
Więcej informacji
Aby uzyskać więcej informacji na temat scenariuszy wdrażania dla UCMA aplikacji Zobacz Wdrażanie UCMA 4.0 i UCMA 5.0 aplikacji w programie Skype w środowisku serwera 2015 biznesowych.

Ostrzeżenie: ten artykuł przetłumaczono automatycznie

Właściwości

Identyfikator artykułu: 3077464 — ostatni przegląd: 07/17/2015 19:16:00 — zmiana: 1.0

Skype for Business Server 2015

  • kbqfe kbsurveynew kbfix kbexpertiseadvanced kbmt KB3077464 KbMtpl
Opinia