Komunikat o błędzie po zainstalowaniu skanera Hewlett-Packard 4400 w porcie równoległym

Zakończono świadczenie pomocy technicznej dla systemu Windows XP

Firma Microsoft zakończyła świadczenie pomocy technicznej dla systemu Windows XP 8 kwietnia 2014. Ta zmiana wpłynęła na Twoje aktualizacje oprogramowania i opcje zabezpieczeń. Dowiedz się, co to oznacza dla Ciebie i jak zapewnić sobie kontynuację ochrony.

Ten artykuł został opublikowany wcześniej pod numerem PL307969
Ten artykuł został zarchiwizowany. Jest oferowany „taki, jaki jest” i nie będzie już aktualizowany.
Symptomy
Po zainstalowaniu skanera Hewlett-Packard ScanJet 4400 lub 4470 w porcie równoległym może się pojawić niebieski ekran z komunikatem o błędzie.
Przyczyna
Po wysłaniu kwerendy dotyczącej identyfikatora urządzenia do skanera Hewlett-Packard 4400, który nie ma pamięci ROM zawierającej taki identyfikator, zostaje zwrócony ciąg z nieprawidłowym identyfikatorem urządzenia (same zera). Sterownik dostarczony przez firmę Microsoft nie może sprawdzić poprawności ciągu, a późniejsza próba obliczenia długości ciągu identyfikatora przy użyciu wartości USHORT powoduje wystąpienie błędu niedopełnienia.
Rozwiązanie
Aby rozwiązać ten problem, należy uzyskać najnowszy dodatek Service Pack dla systemu Windows XP. Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322389 Jak uzyskać najnowszy dodatek Service Pack dla systemu Windows XP

Informacje o poprawce

Firma Microsoft udostępniła obsługiwaną poprawkę. Jednak jest ona przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Tę poprawkę należy stosować tylko w tych systemach, w których występuje opisany problem. Ta poprawka może być nadal w fazie testowania. Jeśli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następną aktualizację oprogramowania zawierającą tę poprawkę.

Jeśli poprawka jest dostępna do pobrania, na początku tego artykułu z bazy wiedzy Knowledge Base jest umieszczona sekcja „Poprawka dostępna do pobrania”. Jeśli nie ma tej sekcji, skontaktuj się z działem obsługi klienta i pomocy technicznej firmy Microsoft w celu uzyskania poprawki.

Uwaga W przypadku wystąpienia dodatkowych błędów lub konieczności rozwiązania problemu może być wymagane utworzenie osobnego zlecenia usługi. Typowe opłaty za korzystanie z pomocy technicznej będą pobierane tylko w przypadku dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu tej poprawki. Aby uzyskać pełną listę numerów telefonów działu obsługi klienta i pomocy technicznej firmy Microsoft lub utworzyć osobne zlecenie usługi, odwiedź następującą witrynę firmy Microsoft w sieci Web: Uwaga Sekcja „Poprawka dostępna do pobrania” zawiera listę języków, dla których ta poprawka jest dostępna. Jeśli odpowiedni język nie jest widoczny, oznacza to, że ta poprawka nie jest dostępna dla tego języka.

Informacje o plikach

Wersja angielskojęzyczna tej poprawki powinna mieć następujące atrybuty plików (lub nowsze):
   Data        Godzina   Wersja         Rozmiar       Nazwa pliku   ----------------------------------------------------   21-sie-2001  14:49  5.1.2600.14  76 160  Parport.sys				

Stan
Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych na początku tego artykułu. Ten problem został po raz pierwszy rozwiązany w dodatku Service Pack 1 dla systemu Windows XP.
Właściwości

Identyfikator artykułu: 307969 — ostatni przegląd: 01/12/2015 18:55:01 — zmiana: 4.5

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbbug kbfix kboswin2000fix kbwinxpsp1fix KB307969
Opinia