Você está offline; aguardando reconexão

Jak używać funkcji INDEKS do wyszukiwania danych w tabeli w programie Excel

Zakończono świadczenie pomocy technicznej dla pakietu Office 2003

Firma Microsoft zakończyła świadczenie pomocy technicznej dla pakietu Office 2003 8 kwietnia 2014. Ta zmiana wpłynęła na Twoje aktualizacje oprogramowania i opcje zabezpieczeń. Dowiedz się, co to oznacza dla Ciebie i jak zapewnić sobie kontynuację ochrony.

Streszczenie
W artykule opisano zastosowanie funkcji INDEKS do wyszukiwania danych w tabeli na zbiegu określonego rzędu i określonej kolumny w programie Microsoft Excel.

Są dwie formy funkcji INDEKS, Zakresowa i Odwołaniowa. Główne różnice między nimi są następujące:
  • Forma Zakresowa może podać więcej niż jedną wartość na raz. Forma Odwołaniowa podaje odwołanie do komórki na zbiegu określonego rzędu i kolumny.
  • Formę Zakresową wprowadza się za pomocą kombinacji klawiszy CTRL + SHIFT + ENTER, zamiast samego klawisza ENTER, jak w przypadku funkcji Odwołaniowej.
Więcej informacji
Wprowadź następujące dane do pustego arkusza programu Excel. Wykorzystasz te dane do sprawdzenia przykładowych formuł opisanych w artykule.
ABC
1ImięWydziałWiek
2Henryk50128
3Stanisław20119
4Maria10122
5Leszek30129
6
7Heniek40121
8Józek10123
9Lena30130

Forma Odwołaniowa funkcji INDEKS

  1. Wprowadź następujące formuły do komórki E2 (lub dowolnej dostępnej pustej komórki):
    =INDEKS((A2:C5;A7:C9);2;3;2)
    (A2:C5,A7:C9) to zakresy, w obrębie których wyszukiwana będzie potrzebna ci wartość.

    2 to numer rzędu, w który, znajduje się wartość.

    3 to numer kolumny w zakresach, gdzie znajduje się wartość. Ponieważ są trzy kolumny (począwszy od kolumny A), trzecią kolumną jest kolumna C.

    2 to obszar, w obrębie A2:C5 lub A7:C9, gdzie znajduje się wartość. Ponieważ określono dwa obszary dla zakresu, drugim zakresem jest A7:C9.
  2. Naciśnij klawisz ENTER.
W przykładowej formule, funkcja INDEKS podaje wartość na zbiegu drugiego rzędu (2) i trzeciej kolumny (C) z zakresu A7:C9. Wartość w komórce C8 to 23. A zatem, formuła =INDEKS((A2:C5;A7:C9);2;3;2) zwraca wartość 23.

Forma Zakresowa funkcji INDEKS

  1. Wprowadź następujące formuły do komórki E3 (lub dowolnej dostępnej pustej komórki):
    =INDEKS(A2:C5;2;3)
    A2:C5 to zakres, w obrębie którego wyszukiwana będzie potrzebna ci wartość.

    2 to numer rzędu, w który, znajduje się wartość.

    3 to numer kolumny w zakresie, gdzie znajduje się wartość. Ponieważ są trzy kolumny (począwszy od kolumny A), trzecią kolumną jest kolumna C.
  2. Naciśnij klawisze CTRL+SHIFT+ENTER, aby wprowadzić formułę jako formułę zakresową.
W przykładowej formule funkcja INDEKS zwraca wartość na zbiegu drugiego rzędu (2) i trzeciej kolumny (C). Wartość w komórce C2 to 19. A zatem formuła =INDEKS(A2:C5;2;3) zwraca wartość 19.
inf XL2002 XL2003 XL2007
Propriedades

ID do Artigo: 324988 - Última Revisão: 07/28/2016 14:04:00 - Revisão: 4.0

Microsoft Office Excel 2007, Microsoft Excel 2002 Standard Edition, Microsoft Office Excel 2003, Microsoft Excel 2010

  • kbhowto KB324988
Comentários
rePV = 0; var varClickTracking = 1; var varCustomerTracking = 1; var Route = "76500"; var Ctrl = ""; document.write("