BŁĄD: Środowisko IDE programu Visual C# .NET przestaje odpowiadać po dodaniu zdarzenia programu Excel SheetSelectionChange lub SheetBeforeRightClick

Zakończono świadczenie pomocy technicznej dla pakietu Office 2003

Firma Microsoft zakończyła świadczenie pomocy technicznej dla pakietu Office 2003 8 kwietnia 2014. Ta zmiana wpłynęła na Twoje aktualizacje oprogramowania i opcje zabezpieczeń. Dowiedz się, co to oznacza dla Ciebie i jak zapewnić sobie kontynuację ochrony.

Ten artykuł został zarchiwizowany. Jest oferowany „taki, jaki jest” i nie będzie już aktualizowany.
Symptomy
Podczas tworzenia aplikacji programu Visual C# .NET wykorzystującej bibliotekę Microsoft Excel 11.0 Object Library, w trakcie wpisywania kodu obsługującego niektóre zdarzenia programu Excel, środowisko IDE przestaje odpowiadać.
Przyczyna
Ten problem jest spowodowany przez zdarzenie SheetSelectionChange lub SheetBeforeRightClick.
Obejście problemu
Uruchom edytor tekstów (np. Notatnik) wpisz wiersz kodu powodujący problem, a następnie wklej kod do edytora programu Visual Studio.
Stan
Firma Microsoft potwierdziła, że jest to usterka występująca w produktach firmy Microsoft wymienionych w sekcji "Informacje zawarte w tym artykule dotyczą".
Więcej informacji

Kroki prowadzące do odtworzenia problemu

  1. Uruchom program Microsoft Visual Studio .NET 2003.
  2. W menu File (Plik) wskaż polecenie New (Nowy), a następnie kliknij polecenie Project (Projekt).
  3. W obszarze Visual C# Projects (Projekty Visual C#) kliknij pozycję Windows Application (Aplikacja systemu Windows). Domyślnie jest tworzony formularz Form1.
  4. Dodaj odwołanie do biblioteki Microsoft Excel Object Library.
    1. W menu Project (Projekt) kliknij polecenie Add Reference (Dodaj odwołanie).
    2. Na karcie COM zlokalizuj pozycję Microsoft Excel 11.0 Object Library, a następnie kliknij przycisk Select (Wybierz).
    3. Kliknij przycisk OK w oknie dialogowym Add References (Dodawanie odwołań), aby zaakceptować wybór.
  5. W oknie Solution Explorer kliknij dwukrotnie pozycję Form1.cs, aby wyświetlić formularz w widoku Design (Projekt).
  6. W menu View (Widok) kliknij polecenie Toolbox (Przybornik), aby wyświetlić przybornik.
  7. Dodaj formant przycisku do formularza Form1.
  8. Kliknij dwukrotnie przycisk na formularzu, aby dodać procedurę obsługi zdarzenia Click.
  9. Dodaj następujący kod u góry okna kodu:
    using Excel = Microsoft.Office.Interop.Excel;
  10. Wpisz (nie wklejaj) następujący kod do procedury obsługi zdarzenia Click dla tego przycisku.

    Uwaga Musisz faktycznie wpisać kod, aby odtworzyć ten problem.
    Excel.Application oApp = new Excel.Application();Excel.Workbook oBook = oApp.Workbooks.Add(System.Type.Missing);oBook.SheetSelectionChange += new Excel.WorkbookEvents_SheetSelectionChangeEventHandler(SheetSelectionChange);
    Zauważ, że po zamknięciu nawiasu w ostatniej linii środowisko IDE programu Visual Studio przestaje odpowiadać.
Materiały referencyjne
Aby uzyskać dodatkowe informacje, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base.
311452 INFO: Develop Microsoft Office Solutions with Visual Studio .NET
Właściwości

Identyfikator artykułu: 824001 — ostatni przegląd: 01/17/2015 05:19:21 — zmiana: 1.3

  • Microsoft Visual C# .NET 2003 Standard Edition
  • Microsoft Visual Studio Tools for the Microsoft Office System
  • Microsoft Office Excel 2003
  • kbnosurvey kbarchive kbbug kbpia kbpending kbautomation KB824001
Opinia