Jesteś obecnie w trybie offline. Czekamy na ponowne połączenie z Internetem.

JAK: Przesyłanie za pomocą programu formularza InfoPath do biblioteki dokumentów usług SharePoint Team Services

Zakończono świadczenie pomocy technicznej dla pakietu Office 2003

Firma Microsoft zakończyła świadczenie pomocy technicznej dla pakietu Office 2003 8 kwietnia 2014. Ta zmiana wpłynęła na Twoje aktualizacje oprogramowania i opcje zabezpieczeń. Dowiedz się, co to oznacza dla Ciebie i jak zapewnić sobie kontynuację ochrony.

Streszczenie
W tym artykule opisano krok po kroku sposób projektowania szablonu formularza, który wykorzystuje skrypt do przesyłania danych formularza do biblioteki dokumentów usług SharePoint Team Services firmy Microsoft.

Projektowanie własnego źródła danych i układu formularza

  1. Uruchom program Microsoft Office InfoPath. Zaprojektuj nowy, pusty formularz.
  2. W okienku zadań Źródło danych dodaj do formularza źródło danych. Aby to zrobić, wykonaj następujące kroki:
    1. Kliknij prawym przyciskiem pozycję myFields, a następnie kliknij polecenie Dodaj.

      Pojawi się okno dialogowe Dodawanie pola lub grupy.
    2. Wpisz FirstName jako nazwę pola, a następnie kliknij przycisk OK.
    3. Powtórz krok a. Wpisz MiddleInitial jako nazwę pola, a następnie kliknij przycisk OK.
    4. Powtórz krok a. Wpisz LastName jako nazwę pola, a następnie kliknij przycisk OK.
  3. Przeciągnij pozycję myFields do formularza.
  4. Kliknij przycisk Sekcja z formantami.

Dodawanie skryptu do przesyłania danych formularza do biblioteki dokumentów SharePoint

  1. W menu Narzędzia kliknij polecenie Przesyłanie formularzy.

    Pojawi się okno dialogowe Przesyłanie formularzy.
  2. W oknie dialogowym Przesyłanie formularzy kliknij przycisk Włącz przesyłanie.
  3. W polu listy rozwijanej Przesyłanie kliknij polecenie Prześlij, używając skryptu niestandardowego.
  4. Kliknij przycisk Otwórz Microsoft Script Editor, a następnie kliknij przycisk OK.

    Otworzy się program Microsoft Script Editor.
  5. Zmodyfikuj zdarzenie OnSubmitRequest w następujący sposób:

    Uwaga: Konieczna jest zmiana wartości zmiennej strURL w kodzie na prawidłowy adres URL. Adres URL w następującym kodzie odwołuje się do serwera o nazwie NazwaSerwera, witryny SharePoint o nazwie NazwaWitryny oraz biblioteki dokumentów o nazwie NazwaBibliotekiDokumentów.
    function XDocument::OnSubmitRequest(eventObj){    // Jeśli przesłanie powiedzie się, ustawienie    // eventObj.ReturnStatus = true    var fSuccessful = false;     // Ustawienie adresu URL pliku, który tu trzeba przesłać.    var strUrl = "http://NazwaSerwera/NazwaWitryny/NazwaBibliotekiDokumentów/testform.xml";     try     {         // Utworzenie obiektu xmlhttp.        var oXmlHttp = new ActiveXObject("MSXML2.XMLHTTP");         // Sprawdzenie, czy dokument o tej samej nazwie już istnieje w usługach STS (SharePoint Team Services).        oXmlHttp.Open("HEAD", strUrl, false);         oXmlHttp.Send();          //  Nie znaleziono dokumentu o podanym adresie URL. Kontynuowanie przesyłania.        // Jeśli trzeba zastąpić oryginalny plik, należy wywołać procedurę        // oXmlHttp.Open("DELETE", strUrl, false), aby najpierw usunąć dokument         // z STS.        if (oXmlHttp.Status == 404)         {            // Umieszczenie dokumentu w STS.             oXmlHttp.Open("PUT", strUrl, false);             oXmlHttp.Send(XDocument.DOM.xml);             //  Kod stanu 200 lub 201 wskazuje, że formularz został przesłany pomyślnie.            if (oXmlHttp.Status == 200 || oXmlHttp.Status == 201)            {                fSuccessful = true;            }        }    }     catch (ex){}         if (fSuccessful)    {        XDocument.UI.Alert("Dokument przesłany pomyślnie!");         eventObj.ReturnStatus = true;    }    else    {        eventObj.ReturnStatus = false;    }}
  6. Zapisz skrypt, a następnie zamknij edytor Script Editor.
  7. Zapisz szablon formularza jako SubmitSTS.xsn.

Testowanie formularza

  1. W menu Plik kliknij polecenie Wypełnij formularz.
  2. W okienku zadań Wypełnianie formularza kliknij pozycję SubmitSTS.
  3. Wypełnij formularz.
  4. W menu Plik kliknij polecenie Prześlij.

    Jeśli formularz został pomyślnie przesłany, pojawi się komunikat wskazujący, że formularz został pomyślnie przesłany.
  5. Zakończ działanie programu InfoPath. Jeśli pojawi się monit o zapisanie zmian formularza, kliknij przycisk Nie.
  6. Uruchom program Microsoft Internet Explorer, a następnie odwiedź bibliotekę formularzy dokumentów. Na przykład odwiedź witrynę http://NazwaSerwera/NazwaWitryny/NazwBibliotekiDokumentów.

    Nowy element o nazwie testform znajduje się w bibliotece dokumentów.
  7. Kliknij element testform.

    Przesłany formularz zostanie otwarty w programie InfoPath.
Materiały referencyjne
Aby uzyskać dodatkowe informacje dotyczące skryptów w formularzach programu InfoPath, kliknij numery artykułów poniżej w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:
828853 How To: Change the Script Language for Your InfoPath Form
827002 HOW TO: Debug a Script for a Microsoft Office InfoPath 2003 Form
Właściwości

Identyfikator artykułu: 826993 — ostatni przegląd: 03/08/2004 15:27:59 — zmiana: 1.9

Microsoft Office InfoPath 2003, Microsoft Windows SharePoint Services

  • kbxml kbscript kbforms KB826993
Opinia