Świadczenie pomocy technicznej dla systemu Windows Vista z dodatkiem Service Pack 1 (SP1) kończy się 12 lipca 2011 r. Aby w dalszym ciągu otrzymywać aktualizacje zabezpieczeń dla systemu Windows, należy korzystać z systemu Windows Vista z dodatkiem Service Pack 2 (SP2). Aby uzyskać więcej informacji, zobacz tę stronę internetową firmy Microsoft: Kończy się wsparcie techniczne dla niektórych wersji systemu Windows.
Symptomy
Rozważmy następujący scenariusz.
-
Używasz systemu Windows XP z dodatkiem Service Pack 3 (SP3), Windows Vista z dodatkiem Service Pack 1 (SP1) lub komputerem z systemem Windows 7
-
Możesz użyć nazwy użytkownika, która zawiera znak dwu bajtowego zestawu znaków (DBCS).
Podczas próby zainstalowania aplikacji korzystającej z pakietu redystrybucyjnego Microsoft Visual C++ 2005 pojawia się następujący komunikat o błędzie:
Błąd składni opcji wiersza polecenia. Wpisz polecenie/? Aby uzyskać pomoc.
Przyczyna
Ten problem występuje, ponieważ narzędzie win32 Cabinet Self-Extractor nie obsługuje znaków DBCS w nazwie użytkownika.
Rozwiązanie
Abyśmy za Ciebie rozwiązali ten problem, przejdź do sekcji"Rozwiązywanieproblemu dla mnie". Aby rozwiązać ten problem samemu, przejdź do sekcji „Samodzielne rozwiązywanie problemu”.
Automatyczne rozwiązywanie problemu
Aby automatycznie rozwiązać ten problem, kliknij przycisk lub link Napraw. Następnie kliknij pozycję Uruchom w oknie dialogowym Pobieranie pliku i postępuj zgodnie z instrukcjami kreatora Naprawy.
Uwagi
-
Rozwiązanie Fix it nie zadziała, jeśli Twoje konto nie jest kontem administratora.
-
Ten kreator może być dostępny tylko w języku angielskim. Jednak ta poprawka automatyczna działa również w innych wersjach językowych systemu Windows.
-
Jeśli używany komputer nie jest tym, którego dotyczy problem, można zapisać to rozwiązanie w postaci poprawki automatycznej na dysku flash lub CD i uruchomić je na odpowiednim komputerze.
Następnie przejdź do sekcji"Czy to rozwiązało problem?".
Samodzielne rozwiązywanie problemu
Aby rozwiązać ten problem, wykonaj następujące czynności:
-
Kliknij przycisk Start, kliknij prawym przyciskiem myszy pozycję Komputer,a następnie kliknij polecenie Właściwości.
-
W obszarze ustawień Nazwa komputera, domena i grupa robocza kliknij pozycję Zmień ustawienia.
Jeśli zostanie wyświetlony monit o hasło administratora lub potwierdzenie, wpisz hasło lub kliknij przycisk Kontynuuj. -
Kliknij pozycję Zmień ustawienia, a następnie wybierz kartę Zaawansowane. Kliknij przycisk Zmienne środowiskowe
-
W obszarze Zmienne użytkownika kliknij pozycję TEMP, a następnie kliknij pozycję Edytuj.
-
W polu Wartość zmienna wpisz C:\Temp, a następnie kliknij przycisk OK dwa razy.
-
Kliknij przycisk Zastosuj, a następnie przycisk OK.
-
Wykonaj również kroki od 4 do 6 dla zmiennej środowiskowej TMP.
-
Potwierdź, że folder C:\Temp istnieje, jeśli nie istnieje.
-
Ponownie uruchom komputer.
-
Spróbuj ponownie zainstalować aplikację.
Czy problem został rozwiązany?
-
Sprawdź, czy problem został rozwiązany. Jeśli problem został rozwiązany, to koniec pracy z tą sekcją. Jeśli problem nie został rozwiązany, można skontaktować się z pomocą techniczną.
-
Prosimy o opinię. Aby przekazać opinię lub zgłosić problemy dotyczące tego rozwiązania, zostaw komentarz w blogu "Naprawdlamnie" lub wyślij do nas wiadomość e-mail.