Symptomy
Próbujesz zaimportować organizację do programu Microsoft Dynamics CRM 4.0 za pomocą Menedżera wdrażania. Importowanie organizacji przez Kreatora importu organizacji trwa jednak długo.
Przyczyna
Ten problem występuje, ponieważ istnieje wiele odwołań do użytkowników systemowych, które muszą zostać zaktualizowane.
Rozwiązanie
Ważne Ta sekcja, metoda lub zadanie zawiera kroki, które informują o tym, jak zmodyfikować rejestr. Niepoprawne zmodyfikowanie rejestru może jednak być przyczyną poważnych problemów. Dlatego należy uważnie wykonywać podane czynności. Dla większego bezpieczeństwa przed zmodyfikowaniem rejestru należy wykonać jego kopię zapasową. Dzięki temu będzie można przywrócić rejestr w przypadku wystąpienia problemu. Aby uzyskać więcej informacji dotyczących wykonywania kopii zapasowej i przywracania rejestru, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322756 Sposób kopii zapasowej i przywracania rejestru w systemie WindowsTo problem został rozwiązany w najnowszym zbiorczym zb. aktualizacji dla programu Microsoft Dynamics CRM 4.0.
Aby uzyskać więcej informacji, kliknij następujący numer artykułu, aby wyświetlić ten artykuł z bazy wiedzy Microsoft Knowledge Base:
949256 Aktualizacje i poprawki programu Microsoft Dynamics CRM 4.0 Po zainstalowaniu tej poprawki w celu dodania przez nas wpisu rejestru
OptimizeOrgImport REG_DWORD przejdź do sekcji "Napraw dla mnie". Jeśli wolisz samodzielnie dodać wpis rejestru OptimizeOrgIm REG_DWORD port, przejdź do sekcji"Pozwólmi rozwiązać ten problem samodzielnie".
Automatyczne rozwiązywanie problemu
Aby automatycznie dodać wpis REG_DWORD OptimizeOrgImport, kliknij przycisk lub link Napraw. Następnie w oknie dialogowym Pobieranie pliku kliknij przycisk Uruchom i wykonaj kroki kreatora rozwiązywania problemu.
Uwagi
-
Ten kreator może być dostępny tylko w języku angielskim. Jednak ta poprawka automatyczna działa również w innych wersjach językowych systemu Windows.
-
Jeśli używany komputer nie jest tym, którego dotyczy problem, można zapisać to rozwiązanie w postaci poprawki automatycznej na dysku flash lub CD i uruchomić je na odpowiednim komputerze.
Następnie przejdź do sekcji"Czy to rozwiązało problem?".
Samodzielne rozwiązywanie problemu
Po zainstalowaniu tej poprawki należy dodać wpis rejestru OptimizeOrgImport REG_DWORD na serwerze microsoft Dynamics CRM 4.0. W tym celu wykonaj następujące czynności:
-
Kliknij przycisk Start,kliknij przycisk Uruchom,wpisz polecenie regedit, a następnie kliknij przycisk OK.
-
Zlokalizuj, a następnie kliknij następujący podklucz rejestru:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
-
Kliknij prawym przyciskiem myszy polecenie MSCRM,wskaż polecenie
Nowy,a następnie kliknij polecenie Wartość DWORD. -
Nadaj tej wartości DWORD nazwę "OptimizeOrgImport"
-
Kliknij prawym przyciskiem myszy pozycję OptimizeOrgImport,a następnie kliknij polecenie Modyfikuj.
-
W polu Dane wartości wpisz
1, a następnie kliknij przycisk OK. -
W menu Plik kliknij polecenie
Zakończ.
Uwaga Jeśli chcesz wyłączyć tę poprawkę, ustaw wartość wpisu rejestru OptimizeOrgImport na 0.
Czy problem został rozwiązany?
-
Sprawdź, czy problem został rozwiązany. Jeśli problem został rozwiązany, to koniec pracy z tą sekcją. Jeśli problem nie został rozwiązany, można skontaktować się z pomocą techniczną.
-
Prosimy o opinię. Aby przekazać opinię lub zgłosić problemy dotyczące tego rozwiązania, zostaw komentarz w blogu"Naprawdla mnie" lub wyślij do nas wiadomość e-mail.
Więcej informacji
W przypadku użycia wpisu rejestru OptimizeOrgImport z ustawioną wartością 1 nie można zaimportować tej samej bazy danych organizacji więcej niż raz. Aby zaimportować tę samą bazę danych organizacji więcej niż raz, należy wykonać jedną z następujących czynności:
-
Ustaw wartość OptimizeOrgImport = 0 i użyj normalnego procesu importowania.
-
Usuń organizację, a następnie ponownie zaimportuj ją.
Stan
Firma Microsoft potwierdziła, że jest to problem w produktach firmy Microsoft wymienionych w sekcji "Dotyczy".