Dodawanie i usuwanie dodatków w programie Excel

Dodatki zawierają opcjonalne polecenia i funkcje dostępne w Microsoft Excel. Domyślnie dodatki nie są od razu dostępne w programie Excel, więc należy je najpierw zainstalować i (w niektórych przypadkach) aktywować, aby można było ich używać.

Szukasz informacji na temat dodatków do Office opartych na języku HTML, CSS i JS? Jeśli tak, zobacz Uzyskiwanie dodatku Office dla Excel.

Niektóre dodatki są wbudowane w wiele Excel, takie jak Solver i Analysis ToolPak. Inne dodatki są dostępne w Centrum pobierania i należy je najpierw pobrać i zainstalować. Ponadto istnieją dodatki utworzone przez inne firmy, takie jak programista w organizacji lub dostawca rozwiązań programowych. Mogą to być dodatki modelu COM (Component Object Model), dodatki Visual Basic for Applications (VBA) i dodatki DLL. Aby można było ich używać, należy zainstalować te dodatki.

Większość dodatków można podzielić na trzy różne typy:

  • Excel dodatki    Zazwyczaj należą do nich pliki dodatku Excel (xlam), dodatku programu Excel 97–2003 (xla) lub plików dodatków DLL (xll) lub są one dodatków automatyzacji. Niektóre Excel, takie jak Solver i Analysis ToolPak, mogą być dostępne po zainstalowaniu pakietu Excel lub Microsoft Office. Zazwyczaj wystarczy aktywować tylko te dodatki, aby z nich korzystać.

  • Dodatki do pobrania    Dodatkowe dodatki dla aplikacji Excel pobrać i zainstalować z materiałów do pobrania na stronie Office.com.

  • Dodatki niestandardowe    Deweloperzy i dostawcy rozwiązań zazwyczaj projektują niestandardowe dodatki MODELU COM, dodatki automatyzacji, dodatki VBA i dodatki XLL. Aby można było ich używać, należy je zainstalować.

Po zainstalowaniu lub aktywowaniu dodatku może on być dostępny w jednej z następujących lokalizacji:

  • Karta Dane. Po zainstalowaniu i aktywowaniu dodatków Analysis ToolPak i Solver w grupie Analiza są dostępne polecenia Analiza danych i Solver.

    Przycisk Analiza danych w grupie Analiza danych

  • Karta Formuły. Po zainstalowaniu i aktywowaniu narzędzi do waluty euro w grupie Rozwiązania są wyświetlane polecenia Konwersja euro i Formatowanie euro.

    Pozycje Konwersja euro i Formatowanie euro

  • Karta Dodatki. Inne dodatki mogą zostać dodane do karty Dodatki. Ta karta jest dodawana do wstążki podczas instalowania i aktywowania pierwszego dodatku wyświetlanego na karcie Dodatki. Jeśli nie widzisz karty Dodatki, zamknij ją, a następnie uruchom ponownie Excel.

Inne dodatki, takie jak karta Wprowadzenie, są dostępne w innych miejscach w programie Excel, takich jak karta na wstążce, albo za pośrednictwem makr lub dostosowanych menu.

Ważne: Jeśli jesteś deweloperem oprogramowania, możesz użyć tej procedury w celu zainstalowania lub usunięcia programu automatyzacji przed rozpoczęciem projektowania programów instalacyjnych i usuwanych dla dodatku.

Aby aktywować Excel dodatku    

  1. Kliknij kartę Plik, kliknij pozycję Opcje, a następnie kliknij kategorię Dodatki.

  2. W polu Zarządzaj kliknij pozycję Dodatki programu Excel, a następnie kliknij przycisk Przejdź.

    Zostanie wyświetlone okno dialogowe Dodatki.

  3. W polu Dostępne dodatki zaznacz pole wyboru obok dodatku, który chcesz aktywować, a następnie kliknij przycisk OK.

Jeśli w polu Dostępne dodatki nie możesz znaleźć dodatku, który chcesz aktywować, może być konieczne jego zainstalowanie.

Aby zainstalować Excel dodatku    

  • Aby zainstalować dodatek, który jest zazwyczaj instalowany razem z programem Excel, taki jak Solver lub Analysis ToolPak, uruchom program instalacyjny dodatku Excel lub Microsoft Office i wybierz opcję Zmień, aby zainstalować dodatek. Po ponownym uruchomieniu Excel dodatek powinien pojawić się w polu Dostępne dodatki.

  • Niektóre Excel dodatki znajdują się na komputerze i można je zainstalować lub aktywować, klikając przycisk Przeglądaj (w oknie dialogowym Dodatki), aby zlokalizować dodatek, a następnie klikając przycisk OK.

  • Niektóre Excel wymagają uruchomienia pakietu instalacyjnego. Może być konieczne pobranie lub skopiowanie pakietu instalacyjnego na komputer (pakiet instalacyjny to zazwyczaj plik z rozszerzeniem nazwy pliku .msi), a następnie go uruchomić.

  • Inne dodatki, które nie są dostępne na komputerze, można pobrać i zainstalować za pośrednictwem przeglądarki sieci Web z witryny Pobrane lub z innych witryn w Internecie lub na serwerze w organizacji. W razie potrzeby postępuj zgodnie z instrukcjami konfiguracji dotyczącymi pobierania.

Aby dezaktywować Excel dodatku    

  1. Kliknij kartę Plik, kliknij pozycję Opcje, a następnie kliknij kategorię Dodatki.

  2. W polu Zarządzaj kliknij pozycję Dodatki programu Excel, a następnie kliknij przycisk Przejdź.

  3. W polu Dostępne dodatki wyczyść pole wyboru obok dodatku, który chcesz dezaktywować, a następnie kliknij przycisk OK.

    W wielu przypadkach dezaktywowanie dodatku jest usuwane z jego grupy na wstążce. W innych przypadkach w celu usunięcia dodatku ze wstążki może być konieczne ponowne uruchomienie Excel.

    Uwaga    Dezaktywowanie dodatku nie powoduje jego usunięcia z komputera. Aby usunąć dodatek z komputera, musisz go odinstalować.

Aby usunąć Excel dodatku    

Ważne: Jeśli dodatek został pierwotnie Excel z sieciowego serwera plików lub folderu udostępnionego, może być konieczne usunięcie dodatku z tej lokalizacji. Jeśli zainstalowano dodatek Excel z dysku CD i po zainstalowaniu dodatku został zamapowany na nowy dysk, należy ponownie zainstalować ten dodatek z dysku CD. Jeśli używasz jakichkolwiek Excel z dysku CD, musisz odinstalować te dodatki Excel, a następnie zainstalować je ponownie z dysku CD.

  1. Kliknij kartę Plik, a następnie kliknij pozycję Zakończ.

  2. W Panelu sterowania kliknij pozycję Programy i funkcje (Windows 7 i Windows Vista) lub Dodaj/Usuń programy (Windows XP).

  3. Wykonaj jedną z następujących czynności:

    • Jeśli zainstalowano Excel w ramach programu Microsoft Office, kliknij pozycję Microsoft Office na liście zainstalowanych programów, a następnie kliknij przycisk Zmień.

    • Jeśli zainstalowano Excel, kliknij nazwę programu na liście zainstalowanych programów, a następnie kliknij przycisk Zmień.

    • Jeśli dodatek został zainstalowany w Centrum pobierania, kliknij nazwę programu na liście zainstalowanych programów, a następnie kliknij przycisk Odinstaluj.

  4. Postępuj zgodnie z instrukcjami w programie instalacyjnym.

Ważne: Jeśli jesteś deweloperem oprogramowania, możesz użyć tej procedury w celu zainstalowania lub usunięcia programu automatyzacji przed rozpoczęciem projektowania programów instalacyjnych i usuwanych dla dodatku. Jeśli nie jesteś deweloperem, nie musisz korzystać z tej procedury. Skontaktuj się administrator systemu, kto podał dodatek, jeśli chcesz uzyskać instrukcje dotyczące instalacji i usuwania.

Dodawanie dodatku COM

  1. Kliknij kartę Plik, kliknij pozycję Opcje, a następnie kliknij kategorię Dodatki.

  2. W polu Zarządzaj kliknij pozycję Dodatki COM, a następnie kliknij przycisk Przejdź.

    Zostanie wyświetlone okno dialogowe Dodatki COM.

  3. W polu Dostępne dodatki zaznacz pole wyboru obok dodatku, który chcesz zainstalować, a następnie kliknij przycisk OK.

    Porada    Jeśli dodatek, którego chcesz użyć, nie znajduje się na liście w polu Dostępne dodatki, kliknij pozycję Dodaj ,a następnie znajdź ten dodatek.

Usuwanie dodatku COM

  1. Kliknij kartę Plik, kliknij pozycję Opcje, a następnie kliknij kategorię Dodatki.

  2. W polu Zarządzaj kliknij pozycję Dodatki COM, a następnie kliknij przycisk Przejdź.

    Zostanie wyświetlone okno dialogowe Dodatki COM.

  3. W polu Dostępne dodatki wyczyść pole wyboru obok dodatku, który chcesz usunąć, a następnie kliknij przycisk OK.

    Uwaga    Spowoduje to usunięcie dodatku z pamięci, ale zachowuje jego nazwę na liście dostępnych dodatków. Dodatek nie jest usuwany z komputera.

  4. Aby usunąć dodatek COM z listy dostępnych dodatków i usunąć dodatek z komputera, kliknij jego nazwę w polu Dostępne dodatki, a następnie kliknij pozycję Usuń.

Uwaga: Jeśli jesteś deweloperem oprogramowania, możesz użyć tej procedury w celu zainstalowania lub usunięcia programu automatyzacji przed rozpoczęciem projektowania programów instalacyjnych i usuwanych dla dodatku. Jeśli nie jesteś deweloperem, nie musisz korzystać z tej procedury. Skontaktuj się administrator systemu, kto podał dodatek, jeśli chcesz uzyskać instrukcje dotyczące instalacji i usuwania.

  1. Kliknij kartę Plik, kliknij pozycję Opcje, a następnie kliknij kategorię Dodatki.

  2. W polu Zarządzaj kliknij pozycję Dodatki programu Excel, a następnie kliknij przycisk Przejdź.

    Zostanie wyświetlone okno dialogowe Dodatki.

  3. Aby zainstalować dodatek automatyzacji, w polu Dostępne serwery automatyzacji kliknij pozycję Automatyzacja, a następnie kliknij ten dodatek.

    Porada    Jeśli na liście nie ma tego dodatku, kliknij przycisk Przeglądaj,zlokalizuj dodatek, a następnie kliknij przycisk OK.

  4. Aby usunąć dodatek automatyzacji, należy go usunąć z rejestru. Aby uzyskać szczegółowe administrator systemu, zobacz swoje konto.

Niektóre dodatki są wbudowane w wiele Excel, takie jak Solver i Analysis ToolPak. Inne dodatki są dostępne w Centrum pobierania i należy je najpierw pobrać i zainstalować. Ponadto istnieją dodatki utworzone przez inne firmy, takie jak programista w organizacji lub dostawca rozwiązań programowych. Mogą to być dodatki modelu COM (Component Object Model), dodatki Visual Basic for Applications (VBA) i dodatki DLL. Aby można było ich używać, należy zainstalować te dodatki.

Większość dodatków można podzielić na trzy różne typy:

  • Excel dodatki    Zazwyczaj należą do nich pliki dodatku Excel (xlam), dodatku programu Excel 97–2003 (xla) lub plików dodatków DLL (xll) lub są one dodatków automatyzacji. Niektóre Excel, takie jak Solver i Analysis ToolPak, mogą być dostępne po zainstalowaniu pakietu Excel lub Microsoft Office. Zazwyczaj wystarczy aktywować tylko te dodatki, aby z nich korzystać.

  • Dodatki do pobrania    Dodatkowe dodatki dla aplikacji Excel pobrać i zainstalować z materiałów do pobrania na stronie Office.com.

  • Dodatki niestandardowe    Deweloperzy i dostawcy rozwiązań zazwyczaj projektują niestandardowe dodatki MODELU COM, dodatki automatyzacji, dodatki VBA i dodatki XLL. Aby można było ich używać, należy je zainstalować.

Po zainstalowaniu lub aktywowaniu dodatku może on być dostępny w jednej z następujących lokalizacji:

  • Karta Dane. Po zainstalowaniu i aktywowaniu dodatków Analysis ToolPak i Solver polecenia Analiza danych i Solver są dostępne na karcie Dane na wstążce.

  • Karta Narzędzia główne. Inne dodatki mogą zostać dodane do karty Narzędzia główne.

Inne dodatki, takie jak karta Wprowadzenie, są dostępne w innych miejscach w programie Excel, takich jak karta na wstążce, albo za pośrednictwem makr lub dostosowanych menu.

Ważne: Jeśli jesteś deweloperem oprogramowania, możesz użyć tej procedury w celu zainstalowania lub usunięcia programu automatyzacji przed rozpoczęciem projektowania programów instalacyjnych i usuwanych dla dodatku.

Aby aktywować preinstalowany Excel dodatku    

  1. W menu Narzędzia wybierz pozycję Dodatki.

  2. W polu Dostępne dodatki zaznacz pole wyboru dodatku, który chcesz aktywować, a następnie kliknij przycisk OK.

Aby zainstalować Excel dodatku    

  • Niektóre Excel dodatki znajdują się na komputerze i można je zainstalować lub aktywować, klikając przycisk Przeglądaj (w oknie dialogowym Dodatki powyżej), aby zlokalizować dodatek, a następnie klikając przycisk OK.

  • Niektóre Excel wymagają uruchomienia pakietu instalacyjnego. Może być konieczne pobranie lub skopiowanie pakietu instalacyjnego na komputer (pakiet instalacyjny to zazwyczaj plik z rozszerzeniem nazwy pliku .msi), a następnie go uruchomić.

  • Inne dodatki, które nie są dostępne na komputerze, można pobrać i zainstalować za pośrednictwem przeglądarki sieci Web z witryny Pobrane lub z innych witryn w Internecie, na serwerze w organizacji albo przy użyciu wbudowanej opcji Sklep w programie Excel. W razie potrzeby postępuj zgodnie z instrukcjami konfiguracji dotyczącymi pobierania.

    Aby zainstalować dodatki ze Sklepu

    1. Kliknij kartę Wstawianie na wstążce.

    2. Kliknij przycisk Sklep.

    3. Użyj pola Kategorie lubWyszukaj, aby znaleźć dodatki.

    4. Kliknij przycisk Dodaj, aby zainstalować dodatek.

      Uwaga: Niektóre dodatki należy kupić.

Aby usunąć Excel dodatku    

  1. Kliknij kartę Wstawianie, a następnie kliknij pozycję Moje dodatki.

  2. W Office dodatkikliknij menu z 3 kropkami obok dodatku.

  3. Kliknij przycisk Usuń.

  4. Przeczytaj powiadomienie, które zostanie wyświetlone dla innych urządzeń, i kliknij przycisk Usuń.

Potrzebna dalsza pomoc?

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

×