Jak naprawić #REF! typu #ZAJĘTY!

Jak naprawić #REF! typu #ZAJĘTY!

Błąd #ADR! pojawia się, gdy formuła zawiera odwołanie do komórki, która nie jest prawidłowa. Najczęściej tak się stanie, gdy zostaną usunięte komórki, do których odwołują się formuły, lub zostanie do nich wklejona zawartość.

Przykład — błąd #ADR! spowodowany przez usunięcie kolumny.

W poniższym przykładzie w kolumnie E jest używana formuła: =SUMA(B2;C2;D2).

Formuła używająca jawnych odwołań do komórek, takich jak =SUMA(B2;C2;D2), może #REF! w przypadku usunięcia kolumny.

Usunięcie kolumny B, C lub D spowoduje #REF! . W tym przypadku usuniemy kolumnę C (Sprzedaż 2007), a teraz formuła będzie mieć wartość =SUMA(B2#REF!;C2). W przypadku użycia jawnych odwołań do komórek w ten sposób (gdzie poszczególne komórki odwołują się do nich osobno, rozdzielone przecinkami) i usunięcia wiersza lub kolumny, do których odwołuje się odwołanie, program Excel nie będzie w stanie rozwiązać problemu, więc zwraca #REF! . Jest to główny powód, dla którego używanie jawnych odwołań do komórek w funkcjach nie jest zalecane.

Przykład błędu #ADR! spowodowanego przez usunięcie kolumny.

Rozwiązanie

  • W razie przypadkowego usunięcia wierszy lub kolumn możesz od razu kliknąć przycisk Cofnij na pasku narzędzi Szybki dostęp (lub nacisnąć klawisze CTRL+Z), aby je przywrócić.

  • Dopasuj formułę tak, aby używała odwołania do zakresu, a nie do pojedynczych komórek, jak formuła: =SUMA(B2:D2). Teraz możesz usunąć dowolną kolumnę w zakresie funkcji SUMA, a program Excel automatycznie dostosuje formułę. Możesz również użyć formuły: =SUMA(B2:B5) do obliczenia sumy wierszy.

Przykład — funkcja WYSZUKAJ.PIONOWO z odwołaniami do nieprawidłowego zakresu

W poniższym przykładzie formuła =WYSZUKAJ.POZIOMO(A8;A2:D5;5;FAŁSZ) zwróci #REF! ponieważ szuka wartości do zwrócenia z kolumny 5, ale zakres odwołania to A:D, czyli tylko 4 kolumny.

Przykład formuły WYSZUKAJ.V.WYSZUKAJ z nieprawidłowym zakresem.  Formuła to =VLOOKU(A8;A2:D5;5;FAŁSZ).  W zakresie funkcji WYSZUKAJ.WIRTUALNE nie ma kolumny piątej, więc 5 powoduje #REF! .

Rozwiązanie

Dostosuj zakres, powiększając go, lub zmniejsz wartość odnośnika kolumny, aby był zgodny z zakresem odwołania. =WYSZUKAJ.PIONOWO(A8;A2:E5;5;FAŁSZ) będzie prawidłowym zakresem odwołania, tak jak =WYSZUKAJ.PIONOWO(A8;A2:D5;4;FAŁSZ).

Przykład — funkcja INDEKS z nieprawidłowym odwołaniem do wiersza lub kolumny

W tym przykładzie formuła =INDEKS(B2:E5;5;5) zwraca #REF! ponieważ zakres INDEKS ma rozmiar 4 wiersze na 4 kolumny, ale formuła prosi o zwrócenie zawartości 5 wiersza i 5 kolumny.

Przykład formuły INDEKS z odwołaniem do nieprawidłowego zakresu.  Formuła ma postać: =INDEKS(B2:E5;5;5), ale zakres to tylko 4 wiersze na 4 kolumny.

Rozwiązanie

Dostosuj odwołania wiersza lub kolumny, aby występowały wewnątrz zakresu wyszukiwania funkcji INDEKS. Formuła =INDEKS(B2:E5;4;4) zwróci prawidłowy wynik.

Przykład — odwołanie do zamkniętego skoroszytu za pomocą funkcji ADR.POŚR

W poniższym przykładzie funkcja INDIRECT próbuje odwołać się do skoroszytu, który jest zamknięty, co powoduje #REF! .

Przykład błędu #ADR! spowodowanego przez odwołanie ADR.POŚR do zamkniętego skoroszytu.

Rozwiązanie

Otwórz skoroszyt, do których odwołuje się odwołanie. Ten sam błąd wystąpi w przypadku odwołania do zamkniętego skoroszytu z funkcją tablicy dynamicznej.

Problemy z ole

Jeśli używasz linku OLE (Object Linking and Embedding), który zwraca #REF! , a następnie uruchom program, na który jest wywoływany link.

Uwaga: OLE to technologia, która umożliwia współdzielenie informacji między programami.

Problemy dotyczące DDE

Jeśli używasz tematu dynamicznej wymiany danych (DDE, Dynamic Data Exchange), który zwraca #REF! najpierw sprawdź, czy odwołujesz się do właściwego tematu. Jeśli nadal otrzymujesz #REF! sprawdź w ustawieniach Centrum zaufania zawartość zewnętrzną zgodnie z tym, co opisano w tece Blokowanie lub odblokowywanie zawartości zewnętrznej w dokumentach pakietu Office.

Uwaga: Dynamic Data Exchange (DDE)to ustalony protokół wymiany danych między programami systemu Microsoft Windows.

Problemy dotyczące makr

Jeśli makro wprowadza w arkuszu funkcję, która odwołuje się do komórki nad funkcją, a komórka zawierająca tę funkcję znajduje się w wierszu 1, funkcja zwróci #REF! ponieważ nad wierszem 1 nie ma komórek. Sprawdź, czy argument funkcji nie odwołuje się do nieprawidłowej komórki lub zakresu komórek. W celu uwzględnienia takiej sytuacji może to wymagać edytowania makra w Edytorze Visual Basic.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach

Funkcje programu Excel (lista alfabetyczna)

Funkcje programu Excel (według kategorii)

Potrzebna dalsza pomoc?

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×