Microsoft Excel pokazuje #DIV/0! w sytuacji, gdy liczba jest dzielona przez zero (0). Dzieje się tak, gdy wprowadzasz prostą formułę, taką jak =5/0,lub gdy formuła odwołuje się do komórki, która ma wartość 0 lub jest pusta, jak pokazano na tym obrazie.

Przykłady formuł powodujących #DIV/0! .

Aby usunąć ten błąd, wykonaj dowolną z następujących czynności:

  • Dopilnuj, aby dzielnik w funkcji lub formule nie był zerem ani pustą komórką.

  • Zmień odwołanie w formule na odwołanie do innej komórki, która nie zawiera zera (0) ani wartości pustej.

  • Wpisz wartość #N/D! w komórce, która przez odwołanie pełni funkcję dzielnika w formule, co spowoduje zmianę wyniku formuły na wartość błędu #N/D! oznaczającą, że wartość dzielnika jest niedostępna.

W wielu przypadkach nie da się uniknąć błędu #DZIEL/0!, ponieważ formuły oczekują na dane wejściowe od Ciebie lub innego użytkownika. W takim przypadku możesz woleć, aby komunikat o błędzie nie był w ogóle wyświetlany. W tym celu można użyć kilku metod obsługi błędów umożliwiających pominięcie wyświetlania błędu podczas oczekiwania na dane wejściowe.

Sprawdzanie, czy dzielnik ma wartość 0 lub nie ma żadnej wartości

Najprostszym sposobem pominięcia błędu #DZIEL/0! jest użycie funkcji JEŻELI w celu sprawdzenia istnienia dzielnika. Jeśli ma on wartość 0 lub nie ma żadnej wartości, jako wynik formuły można wyświetlić wartość 0 lub nie wyświetlać żadnej wartości zamiast wartości błędu #DZIEL/0! W przeciwnym razie będzie obliczana wartość formuły.

Jeśli na przykład formuła zwracająca błąd to =A2/A3, użyj formuły =JEŻELI(A3;A2/A3;0), aby została zwrócona wartość 0, lub formuły =JEŻELI(A3;A2/A3;””), aby został zwrócony pusty ciąg. Można również wyświetlić komunikat niestandardowy podobny do tego: =JEŻELI(A3;A2/A3;"Wprowadź dane wejściowe"). Korzystając z funkcji CZ.CAŁK.DZIELENIA z pierwszego przykładu, można zastosować formułę =JEŻELI(A3;CZ.CAŁK.DZIELENIA(A2;A3);0). Sygnalizuje to programowi Excel, że JEŻELI(A3 istnieje, zwracany jest wynik formuły; w przeciwnym razie zostaje on zignorowany).

Przykłady rozwiązywania #DIV/0! .

Użyj funkcji JEŻELI.JEŻELI.POSUM, aby pominąć #DIV/0! typu #ZAJĘTY!

Ten błąd można także pominąć, zagnieżdżając operację dzielenia w funkcji JEŻELI.BŁĄD. Ponownie, chcąc wykonać działanie A2/A3, można użyć formuły =JEŻELI.BŁĄD(A2/A3;0). Sygnalizuje to programowi Excel, że jeśli wynikiem formuły jest błąd, zwracana jest wartość 0; w przeciwnym razie zwracany jest wynik formuły.

W wersjach programu Excel starszych niż Excel 2007 można użyć metody JEŻELI(CZY.BŁĄD()): =JEŻELI(CZY.BŁĄD(A2/A3);0;A2/A3) (zobacz Funkcje CZY).

Uwaga: metody z metodami JEŻELI.BŁĄD i JEŻELI(CZY.BŁĄD()) nie są koce, ponieważ będą pomijać wszystkie błędy, nie tylko #DIV/0!. Przed zastosowaniem obsługi błędów należy upewnić się, że formuła działa poprawnie. W przeciwnym razie możesz nie zdawać sobie sprawy z tego, że formuła nie działa zgodnie z oczekiwaniami.

Porada: Jeśli w programie Excel jest włączone sprawdzanie błędów, kliknij przycisk Obraz przycisku obok komórki z wyświetlonym błędem. Kliknij polecenie Pokaż kroki obliczania, jeśli jest dostępne, a następnie wybierz rozwiązanie odpowiednie dla używanych danych.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel lub uzyskać pomoc techniczną w społeczności witryny Answers.

Zobacz też

JEŻELI

JEŻELI.BŁĄD

CZY

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach

Funkcje programu Excel (lista alfabetyczna)

Funkcje programu Excel (według kategorii)

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów Microsoft Office

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×