Jak utworzyć wykres Bell-krzywa

Podsumowanie

Krzywa Bell to wykres rozkładu normalnego danego zestawu danych. W tym artykule opisano, jak można utworzyć wykres krzywej Bell w programie Microsoft Excel.

Więcej informacji

w poniższym przykładzie można utworzyć krzywą typu Bell dla danych generowanych przez program Excel przy użyciu narzędzia do generowania liczb losowych w dodatku Analysis ToolPak. Po wygenerowaniu zestawu liczb losowych w programie Microsoft Excel można utworzyć histogram przy użyciu tych liczb losowych oraz narzędzia histogram z dodatku Analysis ToolPak. Na histogramie możesz utworzyć wykres przedstawiający krzywą dzwonek.

Aby utworzyć przykładową krzywą dzwonek, wykonaj następujące czynności:

  1. Uruchom program Excel.

  2. Wprowadź następujące nagłówki kolumn w nowym arkuszu:

    A1:Original B1:Average C1:Bin D1:Random E1:Histogram G1:Histogram

  3. Wprowadź następujące dane w tym samym arkuszu:

    A2: 23   B2:
    A3: 25   B3: STDEV
    A4: 12   B4:
    A5: 24
    A6: 27
    A7: 57
    A8: 45
    A9: 19
  4. Wprowadź następujące formuły w tym samym arkuszu:

    B2: =AVERAGE(A2:A9)
    B3:
    B4: =STDEV(A2:A9)

    Te formuły generują odpowiednio średnią (średnią) i odchylenie standardowe oryginalnych danych.

  5. Wprowadź następujące formuły, aby wygenerować zakres zasobników histogramu:

    C2: =$B$2-3*$B4

    Spowoduje to wygenerowanie dolnej granicy zakresu zbioru. Ta liczba przedstawia trzy odchylenia standardowe mniejsze niż średnia.

    C3: =C2+$B$4

    W tej formule do liczby obliczonej w powyższej komórce jest dodawane jedno odchylenie standardowe.

  6. Zaznacz komórkę C3, pociągnij uchwyt wypełniania, a następnie wypełnij formułę w dół od komórki C3 do komórki C8.

  7. Aby wygenerować dane losowe, które będą stanowić podstawę krzywej Bell, wykonaj następujące czynności:

    1. W menu Narzędzia kliknij polecenie Analiza danych.

    2. W oknie narzędzia do analizy kliknij pozycję Generowanie liczb losowych, a następnie kliknij przycisk OK.

    3. W polu Liczba zmiennych wpisz wartość 1.

    4. W polu liczba liczb pseudolosowych wpisz 2000.

      Uwaga: Zróżnicowanie ta liczba zwiększa lub zmniejsza dokładność krzywej dzwonka.

    5. W polu dystrybucja wybierz pozycję Normalny.

    6. W okienku Parametry wprowadź liczbę obliczoną w komórce B2 (29 w przykładzie) w polu średnia.

    7. W polu odchylenie standardowe wprowadź liczbę obliczoną w komórce B4 (14,68722).

    8. Pozostaw puste pole inicjatora losowego.

    9. W okienku Opcje wyjściowe kliknij pozycję zakres wyjściowy.

    10. Wpisz D2 w polu Zakres wyjściowy.

      Spowoduje to wygenerowanie 2 000 liczb losowych, które pasują do rozkładu normalnego.

    11. Kliknij przycisk OK.

  8. Aby utworzyć histogram dla danych losowych, wykonaj następujące czynności:

    1. W menu Narzędzia kliknij polecenie Analiza danych.

    2. W oknie narzędzia do analizy wybierz pozycję histogram, a następnie kliknij przycisk OK.

    3. W polu zakres wejściowy wpisz D2: D2001.

    4. W polu Zakres zasobnika wpisz C2: C8.

    5. W okienku Opcje wyjściowe kliknij pozycję zakres wyjściowy.

    6. W polu Zakres wyjściowy wpisz ciąg E2.

    7. Kliknij przycisk OK.

  9. Aby utworzyć histogram dla oryginalnych danych, wykonaj następujące czynności:

    1. W menu Narzędzia kliknij polecenie Analiza danych.

    2. Kliknij pozycję histogram, a następnie kliknij przycisk OK.

    3. W polu zakres wejściowy wpisz tekst a2: A9.

    4. W polu Zakres zasobnika wpisz C2: C8.

    5. W okienku Opcje wyjściowe kliknij pozycję zakres wyjściowy.

    6. W polu Zakres wyjściowy wpisz ciąg G2.

    7. Kliknij przycisk OK.

  10. Utwórz etykiety legendy na wykresie, wprowadzając następujące elementy:

    E14: =G1&"-"&G2
    E15: =E1&"-"&F2
    E16: =G1&"-"&H2
  11. Zaznacz zakres komórek, E2: H10, w arkuszu.

  12. W menu Wstaw kliknij polecenie Wykres.

  13. W obszarze Typ wykresukliknij pozycję XY (punktowy).

  14. W obszarze podtyp wykresuw środkowym wierszu kliknij wykres po prawej stronie.

    Uwaga: Tuż poniżej tych 5 podtypów, opis będzie wskazywał "punktowy z punktami danych połączony za pomocą wygładzonych linii bez znaczników".

  15. Kliknij przycisk Dalej.

  16. Kliknij kartę serie.

  17. W polu Nazwa usuń odwołanie do komórki, a następnie wybierz pozycję E15 komórki.

  18. W polu wartości X usuń odwołanie do zakresu, a następnie wybierz zakres E3: E10.

  19. W polu wartości Y usuń odwołanie do zakresu, a następnie wybierz zakres F3: F10.

  20. Kliknij przycisk Dodaj, aby dodać kolejną serię.

  21. Kliknij pole Name (nazwa), a następnie wybierz komórkę E14.

  22. Kliknij pole wartości X, a następnie wybierz zakres E3: E10.

  23. W polu wartości Y usuń wartość, która tam znajdujesz, a następnie wybierz zakres G3: G10.

  24. Kliknij przycisk Dodaj, aby dodać kolejną serię.

  25. Kliknij pole Name (nazwa), a następnie wybierz komórkę E16.

  26. Kliknij pole wartości X, a następnie wybierz zakres E3: E10.

  27. Kliknij pole wartości Y, usuń wartość znajdującą się w tym miejscu, a następnie wybierz zakres H3: H10.

  28. Kliknij przycisk Zakończ.

    Wykres będzie miał dwie serie zakrzywione i serie płaskie wzdłuż osi x.

  29. Kliknij dwukrotnie drugą serię. etykieta powinna być oznaczona jako "-bin" w legendzie.

  30. W oknie dialogowym Formatowanie serii danych kliknij kartę oś.

  31. Kliknij pozycję oś pomocnicza, a następnie kliknij przycisk OK.

Teraz masz wykres, który porównuje dany zestaw danych z krzywą dzwonka.

Źródła informacji

Aby uzyskać więcej informacji na temat tworzenia wykresów, kliknij pozycję Microsoft Excel — Pomoc w menu Pomoc, wpisz polecenie Utwórz wykres w Asystencie pakietu Office lub Kreatorze odpowiedzi, a następnie kliknij pozycję Wyszukaj, aby wyświetlić temat.

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Potrzebna dalsza pomoc?

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×