Spis treści
×
Formuły i funkcje
Formuły i funkcje

JEŻELI, funkcja

Funkcja JEŻELI jest jedną z najbardziej popularnych funkcji programu Excel, która umożliwia tworzenie logicznych porównań wartości z oczekiwanymi wynikami.

Instrukcja JEŻELI może zatem generować dwa wyniki. Pierwszy wynik otrzymamy, jeśli porównanie jest prawdziwe, a drugi — jeśli porównanie jest fałszywe.

Na przykład działanie formuły =JEŻELI(C2="Tak";1;2) jest następujące: JEŻELI(C2 = Tak, to zwróć wartość 1, a w przeciwnym razie zwróć wartość 2).

Przeglądarka nie obsługuje klipu wideo.

Użyj funkcji JEŻELI, jednej z funkcji logicznych, aby zwrócić jedną wartość, jeśli warunek jest prawdziwy, lub inną wartość, jeśli jest fałszywy.

JEŻELI(test_logiczny;wartość_jeżeli_prawda;[wartość_jeżeli_fałsz])

Na przykład:

  • =JEŻELI(A2>B2;"Budżet przekroczony";"OK")

  • =JEŻELI(A2=B2;B4-A4;"")

Nazwa argumentu

Opis

test_logiczny    (wymagane)

Warunek, który ma zostać sprawdzony.

wartość_jeżeli_prawda    (wymagane)

Wartość, która ma zostać zwrócona, jeśli wynik argumentu test_logiczny ma wartość PRAWDA.

wartość_jeżeli_fałsz    (opcjonalne)

Wartość, która ma zostać zwrócona, jeśli wynik argumentu test_logiczny ma wartość FAŁSZ.

Proste przykłady działania funkcji JEŻELI

Komórka D2 zawiera formułę =JEŻELI(C2="Tak";1;2)
  • =JEŻELI(C2="Tak";1;2)

W powyższym przykładzie działanie formuły w komórce D2 jest następujące: JEŻELI(C2 = Tak, to zwróć wartość 1, a w przeciwnym razie zwróć wartość 2)

Komórka D2 zawiera formułę =JEŻELI(C2=1;"Tak";"Nie")
  • =JEŻELI(C2=1;"Tak";"Nie")

W tym przykładzie działanie formuły w komórce D2 jest następujący: JEŻELI(C2 = 1,to zwróć wartość Tak, a w przeciwnym razie zwróć wartość Nie) Jak widać, funkcji JEŻELI można używać do oceny zarówno wartości, jak i tekstu. Można jej również używać do oceny błędów. Oprócz porównywania wyrażeń i zwracania pojedynczych wyników można również używać operatorów matematycznych i wykonywać dodatkowe obliczenia w zależności od używanych kryteriów. Można również zagnieżdżać szereg funkcji JEŻELI w celu wykonywania wielokrotnych porównań.

Formuła w komórce D2: =JEŻELI(C2>B2;”Budżet przekroczony”;”W ramach budżetu”)
  • =JEŻELI(C2>B2;”Budżet przekroczony”;”W ramach budżetu”)

W powyższym przykładzie działanie funkcji JEŻELI w komórce D2 jest następujące: JEŻELI(wartość w komórce C2 jest większa niż wartość w komórce B2, to zwróć „Budżet przekroczony”, a w przeciwnym razie zwróć „W ramach budżetu”)

Formuła w komórce E2: =JEŻELI(C2>B2;C2-B2;"")
  • =JEŻELI(C2>B2;C2-B2;0)

Na powyższej ilustracji zamiast wyniku tekstowego zostanie zwrócone wyrażenie matematyczne. Działanie formuły w komórce E2 jest następujące: JEŻELI(wartość rzeczywista przekracza koszty według budżetu, to odejmij koszty według budżetu od wartości rzeczywistej, a w przeciwnym razie nic nie zwracaj).

Formuła w komórce F7: JEŻELI(E7="Tak";F5*0,0825;0)
  • =JEŻELI(E7="Tak";F5*0,0825;0)

W tym przykładzie działanie formuły w komórce F7 jest następujące: JEŻELI(E7 = "Tak", to przemnóż wartość łącznej kwoty w komórce F5 przez 8,25%, a w przeciwnym razie zwróć wartość 0, ponieważ podatek od sprzedaży nie jest naliczany)

Uwaga: Jeśli chcesz używać tekstu w formułach, musisz ująć go w cudzysłów (np. "Tekst"). Jedynym wyjątkiem od tej reguły jest użycie wartości PRAWDA lub FAŁSZ, Excel automatycznie rozumie.

Typowe problemy

Problem

Przyczyna

0 (zero) w komórce

Brak argumentu wartość_jeżeli_prawda lub wartość_jeżeli_fałsz. Aby była wyświetlana prawidłowa wartość, dodaj tekst argumentu do obu argumentów lub dodaj wartość PRAWDA lub FAŁSZ do argumentu.

#NAZWA? w komórce

Zazwyczaj oznacza to, że formuła jest błędnie wpisana.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel lub uzyskać pomoc techniczną w społeczności witryny Answers.

Zobacz też

Operatory i pierwszeństwo obliczeń w Excel

Używanie w formule funkcji zagnieżdżonych

Korzystanie z funkcji JEŻELI w celu sprawdzenia, czy komórka jest pusta

Klip wideo: zaawansowane funkcje JEŻELI

Funkcja JEŻELI (funkcja Microsoft 365, Excel 2016 lub nowszy)

Zaawansowane funkcje JEŻELI — praca z formułami zagnieżdżona i unikanie problemów

Szkoleniowe klipy wideo: Zaawansowane funkcje JEŻELI

Funkcja LICZ.JEŚLI zlicza wartości na podstawie jednego kryterium

Funkcja LICZ.WARUNKI zlicza wartości na podstawie wielu kryteriów

Funkcja SUMA.JEŚLI sumuje wartości na podstawie jednego kryterium

Funkcja SUMA.WARUNKI sumuje wartości na podstawie wielu kryteriów

ORAZ

LUB

WYSZUKAJ.PIONOWO

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach

Funkcje logiczne

Funkcje programu Excel (lista alfabetyczna)

Funkcje programu Excel (według kategorii)

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów firmy Microsoft

Czy te informacje były pomocne?

Jak zadowalająca jest jakość tłumaczenia?

Co wpłynęło na Twoje wrażenia?

Czy chcesz przekazać jakieś inne uwagi? (Opcjonalnie)

Dziękujemy za opinię!

×