Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Formuły można szybko kopiować do przylegających komórek, używając uchwytu wypełniania.

Uchwyt wypełniania
 

Podczas przeciągania uchwytu do innych komórek program Excel wyświetla różne wyniki dla każdej komórki.

Kopiowanie formuły przez przeciąganie uchwytu wypełniania

Wykonaj następujące czynności:

  1. Zaznacz komórkę zawierającą formułę, którą chcesz wypełnić przylegające komórki.

  2. Zatrzymaj kursor w prawym dolnym rogu, tak aby zmienił się w znak plus (+):

    Kursor znajdujący się na uchwycie wypełniania

  3. Przeciągnij uchwyt wypełniania w dół, w górę lub przez komórki, które chcesz wypełnić. W tym przykładzie na rysunku pokazano przeciąganie uchwytu wypełniania w dół:

    Kursor, przy użyciu którego jest przeciągany w dół uchwyt wypełniania

  4. Po zwolnieniu przycisku formuła jest automatycznie wypełniana w innych komórkach:

    Pokazane są wartości komórek, które zostały wypełnione

  5. Aby zmienić sposób wypełniania komórek, kliknij przycisk Opcje Autowypełniania Przycisk Opcje Autowypełniania wyświetlany po zakończeniu przeciągania i wybierz odpowiednią opcję.

Aby uzyskać więcej informacji na temat kopiowania formuł, zobacz Kopiowanie i wklejanie formuły do innej komórki lub innego arkusza.

Porady: 

  • Możesz również nacisnąć klawisze Ctrl+D, aby wypełnić formułą kolumnę w dół. Najpierw zaznacz komórkę z formułą, którą chcesz wypełnić komórki, zaznacz komórki poniżej, a następnie naciśnij klawisze Ctrl+D.

  • Możesz również nacisnąć klawisze Ctrl+R, aby wypełnić formułą formułę w prawo w wierszu. Najpierw zaznacz komórkę z formułą, którą chcesz wypełnić komórki, zaznacz komórki po prawej stronie, a następnie naciśnij klawisze Ctrl+R.

Gdy wypełnianie nie działa

Czasami wypełnianie działa prawidłowo, a czasami nie działa zgodnie z oczekiwaniami. Dlatego ważne jest sprawdzenie odwołań do komórek w pierwszej komórce.

Odwołania do komórek są po prostu wskaźnikami do innych komórek. Załóżmy na przykład, że pierwsza komórka zawiera następującą formułę:


=SUMA(A1;B1)


A1 i B1 to odwołania względne. Oznacza to po prostu, że podczas wypełniania formuły w dół odwołania będą zmieniać się stopniowo z A1, B1 na A2, B2 i tak dalej, w ten sposób:

=SUMA(A1;B1)

=SUMA(A2;B2)

=SUMA(A3;B3)

Czasami odwołania do innych komórek mogą nie być zmieniane. Załóżmy na przykład, że pierwsze odwołanie (A1) ma pozostać stałe, a odwołanie B1 ma zmieniać się podczas przeciągania uchwytu wypełniania. W takim przypadku wprowadź znak dolara ($) w pierwszym odwołaniu: =SUMA($A$1;B1). Znak dolara wymusza Excel, aby nadal wskazać komórkę A1 podczas wypełniania innych komórek. Wygląda to następująco:

=SUMA($A$1;B1)

=SUMA($A$1;B2)

=SUMA($A$1;B3)

Odwołania ze znakiem dolara ($) są nazywane odwołaniami bezwzględnymi. Podczas wypełniania w dół odwołanie do komórki A1 pozostaje stałe, ale program Excel zmienia odwołanie B1 na B2 i B3.

Masz problemy z wyświetleniem uchwytu wypełniania?

Jeśli nie widzisz uchwytu wypełniania, być może jest on ukryty. Aby go wyświetlić:

  1. W menu Excel kliknij polecenie Preferencje.

  2. Kliknij pozycję Edycja.

  3. W obszarze Opcje edycji zaznacz pole Zezwalaj na uchwyt wypełniania oraz przeciąganie i upuszczanie komórek.

Jeśli automatyczne obliczanie skoroszytu nie działa, formuły nie są ponownie obliczanie podczas wypełniania komórek.

Aby ją włączyć:

  1. W menu Excel kliknij polecenie Preferencje.

  2. Kliknij pozycję Obliczanie.

  3. Upewnij się, żew menu Opcje obliczania jest wybrana opcja Automatycznie.

Potrzebujesz dalszej pomocy?

Rozwijaj swoje umiejętności

Poznaj szkolenia >

Uzyskuj nowe funkcje w pierwszej kolejności

DOŁĄCZ DO MICROSOFT 365 INSIDERS >

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×