Zarządzanie terminami, planami, budżetami — jest to proste dzięki platformie Microsoft 365

Naprawianie błędu #ARG! w funkcjach INDEKS/PODAJ.POZYCJĘ

W tym temacie opisano typowe scenariusze występowania błędów #ARG! w przypadku używania formuł z funkcjami INDEKS i PODAJ.POZYCJĘ. Funkcji INDEKS i PODAJ.POZYCJĘ najczęściej używa się łącznie w celu wyszukania wartości w sytuacji, w której nie można użyć do tego celu funkcji WYSZUKAJ.PIONOWO, na przykład wówczas, gdy szukana wartość ma ponad 255 znaków.

Problem: formuła nie została wprowadzona jako formuła tablicowa

Jeśli indeks jest używany jako formuła tablicowa wraz z DOPASOWANIEm w celu umożliwienia pobierania wartości, należy przekonwertować formułę na formułę tablicową, w przeciwnym razie zobaczysz #VALUE! .

RozwiązaćElement INDEX i MATCH powinien być wykorzystywany jako formuła tablicowa, co oznacza, że należy nacisnąć klawisze CTRL + SHIFT + ENTER. Spowoduje to automatyczne zawijanie formuły w nawiasach klamrowych {}. Jeśli spróbujesz wprowadzić je samodzielnie, Excel będzie wyświetlał formułę jako tekst.

Jeśli korzystasz z funkcji INDEKS/PODAJ.POZYCJĘ do wyszukania wartości mającej więcej niż 255 znaków, konieczne jest wprowadzenie formuły tablicowej.  Komórka F3 zawiera formułę =INDEKS(B2:B4;PODAJ.POZYCJĘ(PRAWDA;A2:A4=F2;0);0), którą należy wprowadzić, naciskając klawisze Ctrl+Shift+Enter

Uwaga: Jeśli masz aktualną wersję programu Microsoft 365, możesz po prostu wprowadzić formułę w komórce Output, a następnie nacisnąć klawisz Enter , aby potwierdzić formułę jako dynamiczną formułę tablicową. W przeciwnym razie formułę należy wprowadzić jako starszą formułę tablicową, wybierając najpierw komórkę wyjściową, wprowadzając formułę w komórce wyjociowej, a następnie naciskając klawisze CTRL + SHIFT + ENTER , aby potwierdzić. Program Excel wstawia nawiasy klamrowe na początku i końcu formuły. Aby uzyskać więcej informacji na temat formuł tablicowych, zobacz Wskazówki i przykłady dotyczące formuł tablicowych.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Naprawianie błędu #ARG! błąd

INDEKS

PODAJ.POZYCJĘ

Wyszukiwanie wartości za pomocą funkcji Wyszukaj. pionowo, indeks lub dopasowanie

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach

Wszystkie funkcje programu Excel (alfabetycznie)

Wszystkie funkcje programu Excel (według kategorii)

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Potrzebna dalsza pomoc?

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×