Ten artykuł zawiera porady dotyczące poprawy wydajności bazy danych programu Microsoft Office Access. Korzystając z tych porad, można przyspieszyć wiele operacji bazy danych, takich jak uruchamianie raportów lub otwieranie formularzy opartych na złożonych zapytaniach.

Jednym z najlepszych sposobów na zwiększenie wydajności bazy danych jest tworzenie indeksów dla często używanych pól. Tworząc indeksy, można zwiększyć wydajność bardziej niż można to zrobić, korzystając z dowolnych porad w tym artykule. Program Access automatycznie tworzy niektóre indeksy, ale należy starannie rozważyć, czy dodatkowe indeksy zwiększą wydajność.

W tym artykule nie omówiono sposobów optymalizowania wydajności określonych obiektów bazy danych, na przykład przez utworzenie indeksu. Aby uzyskać więcej informacji, zobacz artykuł Tworzenie indeksu i używanie go w celu zwiększenia wydajności.

W tym artykule

Pomóż zwiększyć wydajność lokalnej bazy danych

Poniższe wskazówki mogą pomóc w optymalizacji wydajności lokalnej bazy danych programu Access — bazy danych przechowywanej na lokalnym dysku twardym, a nie w sieci.

Wyłączanie Autokorekty nazw

Funkcja Autokorekty nazw pomaga zapewnić, że funkcjonalność obiektów bazy danych pozostanie niezmieniona, gdy zmieni się nazwa innych obiektów bazy danych, od których są one zależne. Jeśli na przykład zmienisz nazwę tabeli i istnieją zapytania, które używają tej tabeli, Autokorekta nazw zapewnia, że te zapytania nie zostaną przerwać z powodu tej zmiany. Ta funkcja może być przydatna, ale niektóre z nich spowalniają działanie.

Jeśli projekt bazy danych jest stabilny i jego nazwy nie zostaną zmienione, możesz bezpiecznie wyłączyć Autokorektę nazw, aby zwiększyć wydajność.

  1. Otwórz bazę danych, którą chcesz zoptymalizować.

  2. Kliknij pozycję Plik > Opcje, aby otworzyć okno dialogowe Opcje programu Access.

  3. W lewym okienku okna dialogowego Opcje programu Access kliknij pozycję Bieżąca baza danych.

  4. W prawym okienku w obszarze Opcje Autokorektynazw wyczyść wszystkie pola wyboru.

Automatyczne kompaktowanie i naprawianie bazy danych

Z czasem wydajność pliku bazy danych może się spowolnić ze względu na ilość miejsca przydzielonego do usuniętych lub tymczasowych obiektów. Polecenie Kompaktuj i napraw usuwa to zmarnowane miejsce i może ułatwić szybsze i wydajniejsze uruchamianie bazy danych. Możesz ustawić opcję automatycznego uruchamiania polecenia Kompaktuj i napraw po zamknięciu bazy danych.

  1. Otwórz bazę danych, którą chcesz zoptymalizować.

  2. Kliknij pozycję Plik > Opcje, aby otworzyć okno dialogowe Opcje programu Access.

  3. W lewym okienku okna dialogowego Opcje programu Access kliknij pozycję Bieżąca baza danych.

  4. W prawym okienku w obszarze Opcje aplikacjizaznacz pole wyboru Kompaktowy przy zamknięciu.

Otwieranie bazy danych w trybie wyłączności

Jeśli jesteś jedyną osobą korzystającą z bazy danych, otwarcie jej w trybie wyłączność uniemożliwia innym użytkownikom korzystanie z bazy danych w tym samym czasie i może zwiększyć wydajność.

  1. Uruchom program Access, ale nie otwieraj bazy danych. Jeśli masz już otwartą bazę danych, zamknij ją.

  2. Kliknij przycisk Otwórz, a następnie kliknij przycisk Przeglądaj.

  3. W oknie dialogowym Otwieranie wybierz plik bazy danych, który chcesz otworzyć. Jeśli chcesz znaleźć plik bazy danych, możesz użyć listy Szukaj w.

  4. Kliknij strzałkę na przycisku Otwórz, a następnie kliknij pozycję Otwórz z wyłączności.

Wyłączanie opcji Autokorekty

Domyślnie program Access poprawia pisownię podczas pisania. Funkcję Autokorekty można wyłączyć, aby zwiększyć wydajność.

  1. Otwórz bazę danych, którą chcesz zoptymalizować.

  2. Kliknij pozycję Plik > Opcje, aby otworzyć okno dialogowe Opcje programu Access.

  3. W lewym okienku okna dialogowego Opcje programu Access kliknij pozycję Narzędzia próbne.

  4. W prawym okienku w obszarze opcji Autokorektykliknij pozycję Opcje Autokorekty.

  5. W oknie dialogowym Opcje Autokorekty wyczyść pola wyboru dla opcji, których nie chcesz.

    Uwaga: Nie musisz wyłączać wszystkich opcji Autokorekty, aby uzyskać korzyść, ale im więcej opcji Autokorekty wyłączysz, tym większa korzyść.

Początek strony

Pomóż zwiększyć wydajność w środowisku z wieloma użytkownikami

Poniższe wskazówki mogą ułatwić zoptymalizowanie wydajności bazy danych programu Access używanej w środowisku wielu użytkowników.

Dzielenie bazy danych

Podczas dzielenia bazy danych tabele danych są umieszczane w pliku bazy danych na serwerze sieciowym w tak zwanej bazie danych typu back-end. Inne obiekty bazy danych, takie jak zapytania, formularze i raporty, umieszcza się w innym pliku bazy danych, który jest nazywany frontonem bazy danych. Użytkownicy przechowują własną kopię frontodanowej bazy danych na swoich komputerach. Wydajność będzie zwiększana, ponieważ tylko dane są wysyłane przez sieć.

Bazę danych można podzielić przy użyciu Kreatora podziału bazy danych.

  • Na karcie Narzędzia bazy danych w grupie Przenoszenie danych kliknij pozycję Baza danych programu Access.

Zmienianie ustawienia blokowania na poziomie strony lub na poziomie rekordu

Program Access blokuje określoną ilość danych podczas edytowania rekordów. Ilość zablokowanych danych zależy od wybranego ustawienia blokowania. Możesz zwiększyć wydajność, wybierając blokowanie na poziomie strony. Jednak blokowanie na poziomie strony może zmniejszać dostępność danych, ponieważ więcej danych jest zablokowanych niż w przypadku blokowania na poziomie rekordu.

  • Blokowanie na poziomie strony    Program Access blokuje stronę zawierającą rekord (strona to obszar pamięci, w którym znajduje się rekord). Edytowanie rekordu z włączonym blokowaniem na poziomie strony może również powodować zablokowanie innych rekordów przechowywanych w pobliżu w pamięci. Jednak na ogół wydajność jest szybsza w przypadku używania blokowania na poziomie strony zamiast blokowania na poziomie rekordu.

  • Blokowanie na poziomie rekordu    Program Access blokuje tylko edytowany rekord. Nie wpływa to na inne rekordy.

Zmienianie ustawienia blokowania na poziomie strony lub na poziomie rekordu    

  1. Otwórz bazę danych, którą chcesz dostosować.

  2. Kliknij pozycję Plik > Opcje, aby otworzyć okno dialogowe Opcje programu Access.

  3. W okienku po lewej stronie kliknij pozycję Ustawienia klienta.

  4. W prawym okienku w sekcji Zaawansowane zaznacz lub wyczyść pole wyboru Otwórz bazy danych przy użyciu blokowania na poziomie rekordów.

Wybieranie odpowiedniego ustawienia blokowania rekordów

Program Access blokuje rekordy podczas ich edytowania. Liczba rekordów blokowanych przez program Access i czas ich blokowania zależą od wybranego ustawienia blokowania rekordów.

  • Bez blokad     Program Access nie blokuje rekordu ani strony, dopóki użytkownik nie zapisze w nim zmian, co spowoduje, że dane będą bardziej dostępne. W przypadku użycia tego ustawienia mogą jednak wystąpić konflikty danych (jednoczesne zmiany wprowadzone w tym samym rekordzie). W przypadku wystąpienia konfliktu danych użytkownik musi zdecydować, którą wersję danych zachować. Zazwyczaj jest to opcja najszybsza, ale konflikty danych mogą spowodować wzrost wydajności.

  • Edytowany rekord     Program Access blokuje rekord, gdy tylko użytkownik zacznie go edytować. W wyniku tego rekordy są blokowane przez dłuższy czas, ale konflikty danych są mniej prawdopodobne.

  • Wszystkie rekordy     Program Access blokuje wszystkie rekordy w tabeli, gdy jest otwarty dowolny formularz lub arkusz danych, w których jest używana ta tabela. Może to zwiększyć wydajność użytkownika edytującego dane w tabeli, ale ogranicza możliwość edytowania danych przez innych użytkowników bardziej niż inne opcje.

Zmienianie ustawienia blokowania rekordów    

  1. Otwórz bazę danych, którą chcesz dostosować.

  2. Kliknij pozycję Plik > Opcje, aby otworzyć okno dialogowe Opcje programu Access.

  3. W okienku po lewej stronie kliknij pozycję Ustawienia klienta.

  4. W prawym okienku w sekcji Zaawansowane w obszarze Domyślneblokowanie rekordów kliknij odpowiednią opcję.

Dostosowywanie ustawień odświeżania sieci i aktualizacji

Spróbuj dostosować ustawienia interwału odświeżania (s),Zaktualizuj interwał ponownej próby (msec),Liczbę ponownych prób aktualizacji i ustawienia interwału odświeżania ODBC (s) zgodnie z ustawieniami.

Ustawienia Interwał ponownej próby aktualizacji i Liczba ponownych prób aktualizacji określają, jak często i ile razy program Access próbuje zapisać rekord po zablokowaniu przez innego użytkownika.

Aby kontrolować częstotliwość odświeżania danych w programie Access, użyj interwału odświeżania ODBC i ustawień interwału odświeżania. Odświeżenie dotyczy tylko danych, które już istnieją w arkuszu danych lub formularzu. Odświeżanie nie powoduje zmiany kolejności rekordów, wyświetlania nowych rekordów ani usuwania usuniętych rekordów i rekordów z wyników zapytania, które nie spełniają już określonych kryteriów. Aby wyświetlić takie zmiany, należy ponownie uzyskać zapytanie dotyczące rekordów źródłowych arkusza danych lub formularza.

Zmienianie ustawień odświeżania sieci i aktualizacji    

  1. Otwórz bazę danych, której uruchamianie ma przyspieszyć pracę.

  2. Kliknij pozycję Plik > Opcje, aby otworzyć okno dialogowe Opcje programu Access.

  3. W okienku po lewej stronie kliknij pozycję Ustawienia klienta.

  4. W prawym okienku w sekcji Zaawansowane zmień odpowiednie ustawienia.

Porada: Aby ponownie kwerenda, naciśnij klawisze SHIFT+F9.

Początek strony

Pomóż zwiększyć wydajność programu Access na komputerze

Poniższe wskazówki mogą pomóc zwiększyć wydajność programu Access niezależnie od tego, czy baza danych, z którą pracujesz, jest przechowywana na komputerze, czy w sieci.

Wyłączanie animacji interfejsu użytkownika

Interfejs użytkownika programu Access zawiera animacje, na przykład podczas otwierania menu. Te animacje ułatwiają korzystanie z interfejsu, ale mogą nieco spowolnić pracę. Możesz je wyłączyć, aby zwiększyć wydajność.

  1. Kliknij pozycję Plik > Opcje, aby otworzyć okno dialogowe Opcje programu Access.

  2. W okienku po lewej stronie kliknij pozycję Ustawienia klienta.

  3. W prawym okienku w obszarze Wyświetlaniewyczyść pole wyboru Pokaż animacje.

Wyłączanie tagów akcji

Jeśli nie używasz tagów akcji, wyłącz je, aby zwiększyć wydajność.

  1. Kliknij pozycję Plik > Opcje, aby otworzyć okno dialogowe Opcje programu Access.

  2. W okienku po lewej stronie kliknij pozycję Ustawienia klienta.

  3. W prawym okienku w obszarzeWyświetlanie wyczyść pola wyboru Pokaż tagi akcji w arkuszach danych i Pokaż tagi akcji w formularzach i raportach.

Zamykanie innych programów, które nie są używane

Zamknięcie innych programów zwiększa ilość dostępnej pamięci w programie Access, co pomaga zminimalizować zużycie dysku i poprawić wydajność.

Uwaga: Po zamknięciu programu możesz również zamknąć niektóre programy, które będą nadal działać w tle. Poszukaj w obszar powiadomień programów tego typu. Podczas końania działania tych programów należy zachować ostrożność, ponieważ może być konieczne, aby komputer działał zgodnie z oczekiwaniami. Jeśli masz wątpliwości, prawdopodobnie nie należy zamykać tych programów.

Dodawanie pamięci RAM do komputera

Dodanie pamięci RAM do komputera może przyspieszyć uruchamianie dużych zapytań i umożliwić otwieranie większej liczby obiektów bazy danych jednocześnie. Ponadto pamięć RAM jest znacznie szybsza niż pamięć wirtualna na dysku twardym. Dodanie pamięci RAM pomaga zminimalizować zużycie dysku i zwiększyć wydajność.

Oczyszczanie dysków twardych

Okresowo wykonaj następujące czynności:

  1. Usuń pliki z komputera, których już nie potrzebujesz.

  2. Usuń tymczasowe pliki internetowe.

  3. Opróżnij Kosz.

  4. W bazach danych można uruchamiać operacje kompaktowania i naprawiania.

  5. Defragmentuj dyski twarde.

Wyłączanie usług systemu Windows, które nie są wymagane

Jeśli na przykład masz dobre rozwiązanie do tworzenia kopii zapasowych na komputerze stacjonarnym, rozważ wyłączenie usługi przywracania systemu. Wyłączenie usług systemu Microsoft Windows, których nie używasz, powoduje, że program Access udostępnia więcej pamięci RAM.

Ważne: Jeśli zdecydujesz się wyłączyć usługi systemu Windows, śledź informacje o tym, co wyłączasz, aby można było łatwo ponownie włączyć wszystkie usługi systemu Windows, które są wymagane.

Dostosowywanie ustawień pamięci wirtualnej

W większości przypadków domyślne ustawienie pamięci wirtualnej używane przez system Windows powinno działać optymalnie. Jednak w niektórych sytuacjach dostosowanie ustawień pamięci wirtualnej może poprawić wydajność programu Access. Rozważ dostosowanie domyślnych ustawień pamięci wirtualnej w następujących przypadkach:

  • Nie masz dużo miejsca na dysku, który jest obecnie używany w pamięci wirtualnej, a inny dysk lokalny ma do dyspozycji miejsce.

  • Inny dysk lokalny, który jest szybszy niż bieżący, ma dostępną ilość miejsca i nie jest intensywnie używany.

W takich przypadkach możesz uzyskać lepszą wydajność, określając inny dysk pamięci wirtualnej.

Możesz również uzyskać lepszą wydajność, określając stałą ilość miejsca na dysku dla pamięci wirtualnej. Rozważ 1,5 razy większą ilość pamięci wirtualnej niż ilość pamięci RAM zainstalowanej na komputerze. Jeśli na przykład masz 1024 megabajty (MB), określ 1536 MB pamięci wirtualnej.

Uwaga: Jeśli często używasz wielu dużych aplikacji jednocześnie, możesz określić większą ilość pamięci wirtualnej.

Aby uzyskać pomoc w zmienianiu ustawień pamięci wirtualnej, wyszukaj w Pomocy systemu Windows "zmienianie pamięci wirtualnej".

Nie używaj oszczędzania ekranu

Oszczędzanie ekranu korzysta z pamięci i uruchamia się automatycznie. Ze względu na udoskonalenia w projekcie monitorów oszczędzanie ekranu nie jest już potrzebne, aby chronić monitor przed "nagrywaniem". Możesz zwiększyć wydajność nieco i pomóc w bardziej płynnym uruchomieniu komputera, nie używając wygaszacza ekranu.

Porada: Nie polegaj na oszczędzaniu ekranu, aby chronić komputer przed nieautoryzowanym dostępem. Aby pomóc w ochronie komputera podczas odejdę od komputera, naciśnij klawisze logo Windows+L.

Nie używaj tła pulpitu

Możesz zobaczyć pewne ulepszenie, ustawiając dla tła pulpitu ustawienie (Brak).

Początek strony

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów firmy Microsoft

Czy te informacje były pomocne?

Jak zadowalająca jest jakość tłumaczenia?

Co wpłynęło na Twoje wrażenia?

Czy chcesz przekazać jakieś inne uwagi? (Opcjonalnie)

Dziękujemy za opinię!

×