Ręczne odinstalowywanie pakietu Office

WAŻNE: przed rozpoczęciem warto wiedzieć, że ręczne usuwanie pakietu Office jest długim i złożonym procesem, który może wymagać ponownego zainstalowania systemu operacyjnego, jeśli pewne czynności zostaną wykonywane niepoprawnie.

Wybierz poniżej swoją wersję pakietu Office.

Krok 1. Określanie typu używanej instalacji

Przed rozpoczęciem procedury ręcznego odinstalowywania należy określić typ instalacji pakietu Office, aby wybrać właściwy sposób odinstalowania go:

  • Szybka instalacja to nowa metoda instalowania i aktualizowania pakietu Office przez Internet, która działa podobnie do przesyłania strumieniowego wideo. Domyślnie najnowsza wersja pakietu Office dostępna w ramach usługi Microsoft 365 i większość kupowanych jednorazowo produktów pakietu Office 2019 i Office 2016 (takich jak pakiet Office dla Użytkowników Domowych i Małych Firm) jest instalowanych przy użyciu technologii Szybka instalacja.

  • MSI, czyli Instalator systemu Microsoft Windows, to tradycyjny sposób instalowania pakietu Office za pośrednictwem lokalnych zasobów instalacyjnych.

  • Aplikacja ze sklepu Microsoft jest instalacją pakietu Office ze sklepu Microsoft na niektórych komputerach z systemem Windows 10.

Aby wybrać typ instalacji, wykonaj następujące czynności:

  1. Utwórz plik lub otwórz istniejący i wybierz kolejno pozycje Plik > Konto (lub Konto pakietu Office).

  2. W obszarze Informacje o produkcie znajdź przycisk Informacje i sprawdź następujące elementy:

    Szybka instalacja

    Zrzut ekranu przedstawiający informacje o wersji i kompilacji Szybkiej instalacji

    Instalacje typu Szybka instalacja zawierają numer wersji i kompilacji oraz frazę Szybka instalacja.

    MSI

    Zrzut ekranu przedstawiający przycisk pakiet Office — informacje dla instalacji MSI. Nie zawiera informacji o wersji i numerze kompilacji

    Instalacje typu MSI nie zawierają numeru wersji i kompilacji obok sekcji Office — informacje.

    Microsoft Store

    Zrzut ekranu przedstawiający informacje o wersji i kompilacji Sklepu Microsoft

    Instalacje z aplikacji Microsoft Store zawierają numer wersji i kompilacji oraz frazę Microsoft Store.

Następnie wybierz odpowiedni typ instalacji i wykonaj te instrukcje odinstalowywania pakietu Office.

Krok 2. Wybieranie typu instalacji do odinstalowania

Zanim rozpoczniesz, upewnij się, że używasz konta administratora systemu Windows. Jeśli nie masz pewności, czy masz konto administratora, dowiedz się, jak ustalić typ konta użytkownika w systemie Windows.

Krok 1. Usunięcie pakietów Instalatora Windows

  1. Znajdź folder instalacji pakietu Office 16. Zwykle znajduje się on w folderze C:\Program Files\.

  2. Kliknij prawym przyciskiem myszy folder Microsoft Office 16, a następnie wybierz polecenie Usuń.

Krok 2. Usunięcie zaplanowanych zadań pakietu Office

  1. Otwórz okno wiersza polecenia jako administrator.

  2. W wierszu polecenia wpisz następujące polecenia, naciskając po każdym z nich klawisz Enter:

    schtasks.exe /delete /tn "\Microsoft\Office\Office Automatic Updates"

    schtasks.exe /delete /tn "\Microsoft\Office\Office Subscription Maintenance"

    schtasks.exe /delete /tn "\Microsoft\Office\Office ClickToRun Service Monitor"

    schtasks.exe /delete /tn "\Microsoft\Office\OfficeTelemetryAgentLogOn2016"

    schtasks.exe /delete /tn "\Microsoft\Office\OfficeTelemetryAgentFallBack2016"

Krok 3. Zakończenie zadań technologii Szybka instalacja za pomocą Menedżera zadań

  1. Otwórz Menedżera zadań.

    • Windows 10: Kliknij prawym przyciskiem myszy przycisk Start i kliknij pozycję Menedżer zadań. (Menu dostępu można również otworzyć, naciskając klawisze logo Windows + X).

    • Windows 8 lub 8.1: Wskaż prawy górny róg ekranu, przesuń wskaźnik myszy w dół, a następnie kliknij pozycję Wyszukiwanie. Wpisz tekst Menedżer zadań w polu wyszukiwania, a następnie kliknij pozycję Menedżer zadań w wynikach.

    • Windows 7: Kliknij prawym przyciskiem myszy pusty obszar na pasku zadań, a następnie kliknij polecenie Uruchom Menedżera zadań.

  2. Kliknij kartę Proces.

  3. Jeśli są uruchomione następujące procesy, wybierz każdy z nich, kliknij prawym przyciskiem myszy, a następnie kliknij polecenie Zakończ zadanie w systemie Windows 10, Zakończ zadanie w systemie Windows 8 lub 8.1 bądź Zakończ proces w systemie Windows 7.

    • OfficeClickToRun.exe

    • OfficeC2RClient.exe

    • AppVShNotify.exe

    • setup*.exe

Krok 4. Usunięcie usługi pakietu Office

  1. Otwórz okno wiersza polecenia jako administrator, wpisz następujące polecenie i naciśnij klawisz Enter:

    • sc delete ClickToRunSvc

Krok 5. Usunięcie plików pakietu Office

  1. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  2. W polu Otwórz wpisz tekst %ProgramFiles%, a następnie kliknij przycisk OK.

  3. Usuń folder „Microsoft Office 16”.

  4. Usuń folder „Microsoft Office”.

  5. Otwórz okno dialogowe Uruchamianie, wpisz polecenie %ProgramFiles(x86)%, a następnie kliknij przycisk OK.

  6. Usuń folder „Microsoft Office”.

  7. Otwórz okno dialogowe Uruchamianie, wpisz polecenie %CommonProgramFiles%\Microsoft Shared, a następnie kliknij przycisk OK.

  8. Usuń folder „ClickToRun”.

  9. Otwórz okno dialogowe Uruchamianie, wpisz polecenie %ProgramData%\Microsoft, a następnie kliknij przycisk OK.

  10. Usuń folder ClickToRun. Jeśli ten folder nie istnieje, przejdź do następnego kroku.

  11. Otwórz okno dialogowe Uruchamianie, wpisz polecenie %ProgramData%\Microsoft\Office, a następnie kliknij przycisk OK.

  12. Usuń plik ClickToRunPackagerLocker.

    Uwaga: Jeśli nie możesz usunąć folderu lub pliku, który jest otwarty lub używany w innym programie, ponownie uruchom komputer, a następnie spróbuj jeszcze raz. Jeśli nadal nie możesz usunąć folderu, przejdź do następnego kroku.

Krok 6. Usunięcie podkluczy rejestru pakietu Office

Ważne: Wykonując czynności opisane w tej sekcji, zachowaj ostrożność. Niepoprawne zmodyfikowanie rejestru może spowodować poważne problemy. Zanim zaczniesz, wykonaj kopię zapasową rejestru, aby móc przywrócić go w przypadku wystąpienia problemów.

  1. Otwórz Edytor rejestru.

    • Windows 10: Kliknij prawym przyciskiem myszy przycisk Start, kliknij polecenie Uruchom, wpisz regedit, a następnie kliknij przycisk OK.

    • Windows 8 lub 8.1: Kliknij prawym przyciskiem myszy przycisk Start, kliknij polecenie Uruchom, wpisz regedit, a następnie kliknij przycisk OK.

    • Windows 7: Kliknij przycisk Start, wpisz tekst Uruchom w polu Rozpocznij wyszukiwanie, a następnie kliknij pozycję Uruchom w wynikach.

  2. Usuń następujące podklucze rejestru:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\AppVISV

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Microsoft Office <wersja> - pl-pl

    • HKEY_CURRENT_USER\Software\Microsoft\Office

    • Następnie usuń klucz pakietu Office.

      Uwaga: W trzecim punkcie podklucza ciąg „Microsoft Office <wersja> - pl-pl” odpowiada rzeczywistej nazwie programu. Ta nazwa zależy od zainstalowanej wersji pakietu Office 2016 i od używanej wersji językowej.

Krok 7. Usunięcie skrótów z menu Start

  1. Otwórz okno wiersza polecenia jako administrator.

  2. Wpisz tekst %ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs, a następnie naciśnij klawisz Enter.

  3. Usuń folder „Microsoft Office 2016 Tools”.

  4. Usuń skróty „<aplikacja> 2016” dla każdej aplikacji pakietu Office 2016. Na przykład „Word 2016”, „Excel 2016” i „PowerPoint 2016”.

Krok 8. Odinstalowywanie składnika lokalizacji, składnika rozszerzalności i składnika licencjonowania funkcji Szybka instalacja pakietu Office 16

  1. Otwórz okno wiersza polecenia jako administrator.

  2. W wierszu polecenia wpisz polecenie przeznaczone dla używanego systemu operacyjnego, a następnie naciśnij klawisz Enter:

    • Jeśli korzystasz z 32-bitowej wersji pakietu Office 2016 w 64-bitowym systemie operacyjnym, uruchom następujące polecenia:

      MsiExec.exe /X{90160000-008F-0000-1000-0000000FF1CE}

      MsiExec.exe /X{90160000-008C-0000-0000-0000000FF1CE}

      MsiExec.exe /X{90160000-008C-0409-0000-0000000FF1CE}

    • Jeśli korzystasz z 32-bitowej wersji pakietu Office 2016 w 32-bitowym systemie operacyjnym, uruchom następujące polecenie:

      MsiExec.exe /X{90160000-007E-0000-0000-0000000FF1CE}

      MsiExec.exe /X{90160000-008C-0000-0000-0000000FF1CE}

      MsiExec.exe /X{90160000-008C-0409-0000-0000000FF1CE}

    • Jeśli korzystasz z 64-bitowej wersji pakietu Office 2016 w 64-bitowym systemie operacyjnym, uruchom następujące polecenie:

      MsiExec.exe /X{90160000-007E-0000-1000-0000000FF1CE}

      MsiExec.exe /X{90160000-008C-0000-1000-0000000FF1CE}

      MsiExec.exe /X{90160000-008C-0409-1000-0000000FF1CE}

Przed odinstalowaniem pakietu Office 2016 konieczne jest wyświetlenie ukrytych plików i folderów:

Wyświetlanie ukrytych plików i folderów

  1. Aby wyświetlić ukryte pliki i foldery:

    • Windows 10: Kliknij prawym przyciskiem myszy przycisk Start, a następnie kliknij pozycję Panel sterowania. (Menu dostępu można również otworzyć, naciskając klawisze logo Windows + X).

    • Windows 8 lub 8.1: Naciśnij klawisze Windows + X, a następnie kliknij pozycję Panel sterowania.

    • Windows 7: Kliknij pozycję Start > Panel sterowania.

  2. Naciśnij klawisz Alt, aby wyświetlić pasek menu.

  3. Kliknij pozycję Narzędzia > Opcje folderów, a następnie kliknij kartę Widok.

  4. W okienku Ustawienia zaawansowane kliknij pozycję Pokaż ukryte pliki i foldery w obszarze Ukryte pliki i foldery.

  5. Wyczyść pole Ukryj rozszerzenia plików znanych typów.

  6. Kliknij przycisk OK, a następnie zamknij Eksploratora Windows.

Krok 1. Usunięcie wszystkich pozostałych pakietów Instalatora Windows dla pakietu Office

  1. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  2. Wpisz tekst installer, a następnie kliknij przycisk OK, aby otworzyć folder %windir%\Installer.

  3. Naciśnij klawisz Alt, aby wyświetlić pasek menu, jeśli nie jest widoczny, a następnie wykonaj poniższe czynności, w zależności od używanego systemu operacyjnego.

    • Windows 10: Kliknij pozycję Widok, a następnie kliknij pozycję Szczegóły w grupie Układ.

    • Windows 8 lub 8.1: Kliknij pozycję Widok, a następnie kliknij pozycję Szczegóły w grupie Układ.

    • Windows 7: W menu Widok kliknij pozycję Wybierz szczegóły.

  4. Zmień szerokość kolumny, w zależności od używanego systemu operacyjnego.

    • Windows 10: Kliknij pozycję Widok, w grupie Układ wybierz polecenie Dodaj kolumny > Wybierz kolumny, a następnie wybierz pozycję Temat i wpisz 340 w polu Szerokość wybranej kolumny (w pikselach).

    • Windows 8 lub 8.1: Kliknij pozycję Widok, a następnie w grupie Układ kliknij pozycję Szczegóły i wpisz 340 w polu Szerokość wybranej kolumny (w pikselach).

    • Windows 7: W menu Widok kliknij pozycję Wybierz szczegóły, a następnie wpisz 340 w polu Szerokość wybranej kolumny (w pikselach).

    Uwaga: Wyświetlenie tematu obok każdego pliku msi może potrwać kilka minut.

  5. Kliknij przycisk OK.

  6. Kliknij pozycję Widok > Sortuj według > Temat.

  7. Jeśli pojawi się okno dialogowe Kontrola konta użytkownika, kliknij przycisk Zezwalaj, aby kontynuować.

  8. Odszukaj i kliknij prawym przyciskiem myszy każdy plik msi, który ma temat „Microsoft Office <nazwa produktu> 2016”, a następnie kliknij polecenie Odinstaluj.

    W tym kroku <nazwa produktu> odpowiada rzeczywistej nazwie produktu pakietu Office 2016.

Krok 2. Zatrzymanie usługi Aparat źródłowy pakietu Office

  1. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  2. Wpisz tekst services.msc, a następnie kliknij przycisk OK.

  3. W oknie Usługi ustal, czy usługa Aparat źródłowy pakietu Office jest uruchomiona. (Jeśli jest uruchomiona, w kolumnie Stan widnieje wpis „Uruchomiono”). Jeśli ta usługa jest uruchomiona, kliknij prawym przyciskiem myszy pozycję Aparat źródłowy pakietu Office, a następnie kliknij polecenie Zatrzymaj.

  4. Zamknij okno Usługi.

Krok 3. Usunięcie wszelkich pozostałych folderów instalacji pakietu Office

  1. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  2. Wpisz tekst %CommonProgramFiles%\Microsoft Shared, a następnie kliknij przycisk OK.

    Uwaga: Na komputerze z 64-bitową wersją systemu Windows wpisz tekst %CommonProgramFiles(x86)%\Microsoft Shared, a następnie kliknij przycisk OK.

  3. Jeśli istnieją foldery Office16 i Source Engine, usuń je.

  4. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  5. Wpisz tekst %ProgramFiles%\Microsoft Office, a następnie kliknij przycisk OK.

    Uwaga: Na komputerze z 64-bitową wersją systemu Windows wpisz tekst %ProgramFiles(x86)%\Microsoft Office, a następnie kliknij przycisk OK.

  6. Usuń folder Office16.

  7. W folderze głównym każdego dysku twardego znajdź i otwórz folder MSOCache.

  8. Otwórz folder All Users w folderze MSOCache, a następnie usuń każdy folder mający w nazwie tekst: "0FF1CE}-.

    Uwagi: Ten tekst zawiera cyfry zero (0) i jeden (1) zamiast liter „O” i „I”. Na przykład usuń folder o tej nazwie:

    {90160000-001B-0409-0000-0000000FF1CE}-C

Krok 4. Usunięcie wszelkich pozostałych plików instalacji pakietu Office

  1. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  2. Wpisz tekst %appdata%\microsoft\templates, a następnie kliknij przycisk OK.

  3. Usuń pliki Normal.dotm i Welcome to Word.dotx.

  4. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  5. Wpisz tekst %appdata%\microsoft\document building blocks, a następnie kliknij przycisk OK.

  6. W folderze Document Building Blocks otwórz podfolder, a następnie usuń plik Building blocks.dotx.

    Uwaga: Nazwa tego podfolderu jest czterocyfrową liczbą odpowiadającą językowi pakietu Microsoft Office.

  7. Zamknij wszystkie programy przed wykonaniem pozostałych czynności.

Krok 5. Usunięcie podkluczy rejestru systemu Office

  1. Zanim zaczniesz, wykonaj kopię zapasową rejestru, aby móc przywrócić go w przypadku wystąpienia problemów.

    Ostrzeżenie: Niepoprawne zmodyfikowanie rejestru przy użyciu Edytora rejestru lub innej metody może stać się przyczyną poważnych problemów. Ich usunięcie może wymagać ponownego zainstalowania systemu operacyjnego. Firma Microsoft nie może zagwarantować, że rozwiązanie tych problemów będzie możliwe. Użytkownik modyfikuje rejestr na własną odpowiedzialność.

Usuwanie podkluczy rejestru pakietu Office 2016

  1. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  2. Wpisz tekst regedit, a następnie kliknij przycisk OK.

  3. Kliknij następujący podklucz rejestru:

    • HKEY_CURRENT_USER\Software\Microsoft\Office\16.0

  4. Kliknij pozycję Plik > Eksportuj, wpisz tekst Usunięty_klucz_01, a następnie kliknij przycisk Zapisz.

  5. Kliknij pozycję Edytuj > Usuń, a następnie kliknij przycisk Tak w celu potwierdzenia operacji.

  6. Powtórz te czynności (od 1 do 5) dla każdego podklucza rejestru z poniższych list. Zmień nazwę eksportowanego klucza, zwiększając cyfrę w nazwie każdego podklucza o jeden.

    Na przykład: dla drugiego klucza wpisz nazwę Usunięty_klucz_02, dla trzeciego klucza wpisz nazwę Usunięty_klucz_03 itd.

    Uwaga: W podanych niżej kluczach rejestru znak gwiazdki (*) reprezentuje co najmniej jeden znak w nazwie podklucza.

    32-bitowe wersje systemu Windows

    • HKEY_CURRENT_USER\Software\Microsoft\Office\16.0

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\Upgrade Codes\*F01FEC

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC

    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose

    • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\Win32Assemblies\*Office16*

    64-bitowe wersje systemu Windows

    • HKEY_CURRENT_USER\Software\Microsoft\Office\16.0

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\16.0

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*

    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose

    • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\Win32Asemblies\*Office16*

    Usuń też następujące podklucze rejestru:

    1. Znajdź jeden z następujących podkluczy, stosownie do używanej wersji systemu Windows:

      • Wersja 32-bitowa: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

      • Wersja 64-bitowa: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall

    2. Kliknij pozycję Plik > Eksportuj, wpisz tekst Klucz_odinstalowywania_01, a następnie kliknij przycisk Zapisz.

    3. W podkluczu Uninstall znalezionym w kroku nr 1 kliknij każdy z podkluczy i określ, czy jest do niego przypisana następująca wartość:

      • Nazwa: UninstallString

      • Dane: ścieżka nazwa_pliku ścieżka\Office Setup Controller\Setup.exe

        W tym przykładzie nazwa_pliku odpowiada rzeczywistej nazwie programu instalacyjnego, a ścieżka rzeczywistej ścieżce pliku.

    4. Jeśli podklucz zawiera nazwę i dane opisane w kroku nr 3, kliknij pozycję Edycja > Usuń. W przeciwnym razie przejdź do kroku 5.

    5. Powtarzaj kroki nr 3 i 4 do czasu znalezienia i usunięcia wszystkich podkluczy, których nazwy i dane pasują do nazw i danych opisanych w kroku 3.

    6. Zamknij Edytor rejestru.

Wykonaj poniższe czynności, aby odinstalować pakiet Office, jeśli masz typ instalacji sklep Microsoft.

Opcja 1. Odinstalowywanie pakietu Office za pomocą ustawień systemu Windows

  1. Wybierz pozycję Start Ikona Start systemu Windows 10 > Ustawienia Przycisk Ustawienia w menu systemu Windows 10 > Aplikacje.

  2. W obszarze Aplikacje i funkcje wybierz wersję pakietu Office, którą chcesz odinstalować.

    Uwaga: Jeśli masz zainstalowany pakiet Office taki jak Office dla Użytkowników Domowych i Uczniów lub pakiet Office uzyskany w ramach subskrypcji, wyszukaj nazwę pakietu. Jeśli zakupiono pojedynczą aplikację pakietu Office, na przykład Word lub Visio, wyszukaj nazwę aplikacji.

  3. Wybierz pozycję Odinstaluj.

Opcja 2. Ręczne odinstalowywanie pakietu Office za pomocą programu PowerShell

Usuwanie pakietu Office

  1. Kliknij prawym przyciskiem myszy przycisk Start Ikona Start systemu Windows 10 , a następnie wybierz polecenie Uruchom.

  2. W oknie dialogowym Uruchamianie wpisz polecenie PowerShell i wybierz przycisk OK.

  3. W oknie programu Windows PowerShell wpisz następujące polecenie:

    Get-AppxPackage -name “Microsoft.Office.Desktop” | Remove-AppxPackage

  4. Naciśnij klawisz Enter.

    Potrwa to kilka minut. Po zakończeniu pojawi się nowy wiersz polecenia.

Sprawdzanie, czy pakiet Office został usunięty

  1. W oknie programu Windows PowerShell wpisz następujące polecenie:

    Get-AppxPackage -name “Microsoft.Office.Desktop”

  2. Naciśnij klawisz Enter.

    Jeśli zostanie wyświetlony tylko wiersz polecenia i nie ma żadnych dodatkowych informacji, oznacza to, że pakiet Office został pomyślnie usunięty.

Krok 1. Określanie typu używanej instalacji

Przed rozpoczęciem procedury ręcznego odinstalowywania należy określić typ instalacji pakietu Office, aby wybrać właściwy sposób odinstalowania go:

  • Szybka instalacja to nowa metoda instalowania i aktualizowania pakietu Office przez Internet, która działa podobnie do przesyłania strumieniowego wideo. Domyślnie najnowsza wersja pakietu Office, która jest dołączona do usługi Microsoft 365, i większość zakupów jednorazowych produktów pakietów Office 2016 i Office 2013 (takich jak pakiet Office 2016 dla Użytkowników Domowych i Uczniów czy Office dla Użytkowników Domowych i Małych Firm) jest instalowanych przy użyciu technologii Szybka instalacja.

  • MSI, czyli Instalator systemu Microsoft Windows, to tradycyjny sposób instalowania pakietu Office za pośrednictwem lokalnych zasobów instalacyjnych.

    Aby wybrać typ instalacji, wykonaj następujące czynności:

    1. Utwórz plik lub otwórz istniejący i wybierz kolejno pozycje Plik > Konto (lub Konto pakietu Office).

    2. W obszarze Informacje o produkcie znajdź przycisk Informacje i sprawdź następujące elementy:

      Szybka instalacja

      Zrzut ekranu przedstawiający informacje o wersji i kompilacji Szybkiej instalacji

      Instalacje Szybka instalacja mają przycisk Aktualizuj pakiet Office i zawierają frazę Szybka instalacja.

      MSI

      Zrzut ekranu przedstawiający przycisk pakiet Office — informacje dla instalacji MSI. Nie zawiera informacji o wersji i numerze kompilacji

      Instalacja MSI nie ma przycisku Aktualizuj pakiet Office i nie wyświetla wersji ani numeru kompilacji oprócz sekcji Office — informacje.

Krok 2. Wybieranie typu instalacji do odinstalowania

Zanim rozpoczniesz, upewnij się, że używasz konta administratora systemu Windows. Jeśli nie masz pewności, czy masz konto administratora, dowiedz się, jak ustalić typ konta użytkownika w systemie Windows.

Krok 1. Usunięcie pakietów Instalatora Windows

  1. Znajdź folder instalacji pakietu Office 15. Zwykle znajduje się on w folderze C:\Program Files\.

  2. Kliknij prawym przyciskiem myszy folder Microsoft Office 15, a następnie wybierz polecenie Usuń.

Krok 2. Usunięcie zaplanowanych zadań pakietu Office

  1. Otwórz okno wiersza polecenia jako administrator.

  2. W wierszu polecenia wpisz następujące polecenia, naciskając po każdym z nich klawisz Enter:

    schtasks.exe /delete /tn "\Microsoft\Office\Office 15 Subscription Heartbeat"

    schtasks.exe /delete /tn "\Microsoft\Office\Office Automatic Update"

    schtasks.exe /delete /tn "\Microsoft\Office\Office Subscription Maintenance"

Krok 3. Zakończenie zadań technologii Szybka instalacja za pomocą Menedżera zadań

  1. Otwórz Menedżera zadań.

    • Windows 10: Kliknij prawym przyciskiem myszy przycisk Start i kliknij pozycję Menedżer zadań. (Menu dostępu można również otworzyć, naciskając klawisze logo Windows + X).

    • Windows 8 lub 8.1: Wskaż prawy górny róg ekranu, przesuń wskaźnik myszy w dół, a następnie kliknij pozycję Wyszukiwanie. Wpisz tekst Menedżer zadań w polu wyszukiwania, a następnie kliknij pozycję Menedżer zadań w wynikach.

    • Windows 7: Kliknij prawym przyciskiem myszy pusty obszar na pasku zadań, a następnie kliknij polecenie Uruchom Menedżera zadań.

  2. Kliknij kartę Proces.

  3. Jeśli są uruchomione następujące procesy, wybierz każdy z nich, kliknij prawym przyciskiem myszy, a następnie kliknij polecenie Zakończ zadanie w systemie Windows 10, Zakończ zadanie w systemie Windows 8 lub 8.1 bądź Zakończ proces w systemie Windows 7.

    • Officeclicktorun.exe

    • appvshnotify.exe

    • firstrun.exe

    • setup*.exe

Krok 4. Usunięcie usługi pakietu Office

  1. Otwórz okno wiersza polecenia jako administrator, wpisz następujące polecenie i naciśnij klawisz Enter:

    • sc delete Clicktorunsvc

Krok 5. Usunięcie plików pakietu Office

  1. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  2. W polu Otwórz wpisz tekst %ProgramFiles%, a następnie kliknij przycisk OK.

  3. Usuń folder „Microsoft Office 15”.

  4. Otwórz okno dialogowe Uruchamianie, wpisz polecenie %ProgramData%\Microsoft, a następnie kliknij przycisk OK.

  5. Usuń folder ClickToRun. Jeśli ten folder nie istnieje, przejdź do następnego kroku.

  6. Otwórz okno dialogowe Uruchamianie, wpisz polecenie %ProgramData%\Microsoft\office, a następnie kliknij przycisk OK.

  7. Usuń folder FFPackageLocker.

    Jeśli nie możesz usunąć folderu lub pliku, który jest otwarty lub używany w innym programie, ponownie uruchom komputer, a następnie spróbuj jeszcze raz. Jeśli nadal nie możesz usunąć folderu, przejdź do następnego kroku.

Krok 6. Usunięcie podkluczy rejestru pakietu Office

Ważne: Wykonując czynności opisane w tej sekcji, zachowaj ostrożność. Niepoprawne zmodyfikowanie rejestru może spowodować poważne problemy. Zanim zaczniesz, wykonaj kopię zapasową rejestru, aby móc przywrócić go w przypadku wystąpienia problemów.

  1. Otwórz Edytor rejestru.

    • Windows 10: Kliknij prawym przyciskiem myszy przycisk Start, kliknij polecenie Uruchom, wpisz regedit, a następnie kliknij przycisk OK.

    • Windows 8 lub 8.1: Kliknij prawym przyciskiem myszy przycisk Start, kliknij polecenie Uruchom, wpisz regedit, a następnie kliknij przycisk OK.

    • Windows 7: Kliknij przycisk Start, wpisz tekst Uruchom w polu Rozpocznij wyszukiwanie, a następnie kliknij pozycję Uruchom w wynikach.

  2. Usuń następujące podklucze rejestru:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\15.0\ClickToRun

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\AppVISV

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Microsoft Office <wersja>15 - pl-pl

    • HKEY_CURRENT_USER\Software\Microsoft\Office

    • Następnie usuń klucz pakietu Office.

      W trzecim punkcie podklucza „Microsoft Office 15 <wersja> - pl-pl” odpowiada rzeczywistej nazwie programu. Ta nazwa zależy od wersji pakietu Office 2013 i od zainstalowanej wersji językowej.

Krok 7. Usunięcie skrótów z menu Start

  1. Otwórz okno wiersza polecenia jako administrator.

  2. Wpisz tekst %ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs, a następnie naciśnij klawisz Enter.

  3. Usuń folder Office 2013.

Krok 8. Odinstalowanie składnika lokalnego Microsoft Office Habanero i uzupełniającego składnika lokalnego Habanero

  1. Otwórz okno wiersza polecenia jako administrator.

  2. W wierszu polecenia wpisz polecenie przeznaczone dla używanego systemu operacyjnego, a następnie naciśnij klawisz Enter:

    • Jeśli korzystasz z 32-bitowej wersji pakietu Office 2013 w 64-bitowym systemie operacyjnym, uruchom następujące polecenie:

      MsiExec.exe /X{50150000-008F-0000-1000-0000000FF1CE}

    • Jeśli korzystasz z 32-bitowej wersji pakietu Office 2013 w 32-bitowym systemie operacyjnym, uruchom następujące polecenie:

      MsiExec.exe /X{50150000-007E-0000-0000-0000000FF1CE}

    • Jeśli korzystasz z 64-bitowej wersji pakietu Office 2013 w 64-bitowym systemie operacyjnym, uruchom następujące polecenie:

      MsiExec.exe /X{50150000-008C-0000-1000-0000000FF1CE}

Przed odinstalowaniem pakietu Office 2013 konieczne jest wyświetlenie ukrytych plików i folderów:

Wyświetlanie ukrytych plików i folderów

  1. Przed odinstalowaniem pakietu Office 2013 konieczne jest wyświetlenie ukrytych plików i folderów:

    • Windows 10: Kliknij prawym przyciskiem myszy przycisk Start, a następnie kliknij pozycję Panel sterowania. (Menu dostępu można również otworzyć, naciskając klawisze logo Windows + X).

    • Windows 8 lub 8.1: Naciśnij klawisze Windows + X, a następnie kliknij pozycję Panel sterowania.

    • Windows 7: Kliknij pozycję Start > Panel sterowania.

  2. Naciśnij klawisz Alt, aby wyświetlić pasek menu.

  3. Kliknij pozycję Narzędzia > Opcje folderów, a następnie kliknij kartę Widok.

  4. W okienku Ustawienia zaawansowane kliknij pozycję Pokaż ukryte pliki i foldery w obszarze Ukryte pliki i foldery.

  5. Wyczyść pole Ukryj rozszerzenia plików znanych typów.

  6. Kliknij przycisk OK, a następnie zamknij Eksploratora Windows.

Krok 1. Usunięcie wszystkich pozostałych pakietów Instalatora Windows dla pakietu Office

  1. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  2. Wpisz tekst installer, a następnie kliknij przycisk OK, aby otworzyć folder %windir%\Installer.

  3. Naciśnij klawisz Alt, aby wyświetlić pasek menu, jeśli nie jest widoczny.

    • Windows 10: Kliknij pozycję Widok, a następnie kliknij pozycję Szczegóły w grupie Układ.

    • Windows 8 lub 8.1: Kliknij pozycję Widok, a następnie kliknij pozycję Szczegóły w grupie Układ.

    • Windows 7: W menu Widok kliknij pozycję Wybierz szczegóły.

    • Windows 10: Kliknij pozycję Widok, w grupie Układ wybierz polecenie Dodaj kolumny > Wybierz kolumny, a następnie wybierz pozycję Temat i wpisz 340 w polu Szerokość wybranej kolumny (w pikselach).

    • Windows 8 lub 8.1: Kliknij pozycję Widok, a następnie w grupie Układ kliknij pozycję Szczegóły i wpisz 340 w polu Szerokość wybranej kolumny (w pikselach).

    • Windows 7: W menu Widok kliknij pozycję Wybierz szczegóły, a następnie wpisz 340 w polu Szerokość wybranej kolumny (w pikselach).

    Uwaga: Wyświetlenie tematu obok każdego pliku msi może potrwać kilka minut.

  4. Kliknij przycisk OK.

  5. Kliknij pozycję Widok > Sortuj według > Temat.

  6. Jeśli pojawi się okno dialogowe Kontrola konta użytkownika, kliknij przycisk Zezwalaj, aby kontynuować.

  7. Odszukaj i kliknij prawym przyciskiem myszy każdy plik msi, który ma temat „Microsoft Office <nazwa produktu> 2013”, a następnie kliknij polecenie Odinstaluj.

    W tym kroku <nazwa produktu> odpowiada rzeczywistej nazwie produktu pakietu Office 2013.

Krok 2. Zatrzymanie usługi Aparat źródłowy pakietu Office

  1. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  2. Wpisz tekst services.msc, a następnie kliknij przycisk OK.

  3. W oknie Usługi ustal, czy usługa Aparat źródłowy pakietu Office jest uruchomiona. (Jeśli jest uruchomiona, w kolumnie Stan widnieje wpis „Uruchomiono”). Jeśli ta usługa jest uruchomiona, kliknij prawym przyciskiem myszy pozycję Aparat źródłowy pakietu Office, a następnie kliknij polecenie Zatrzymaj.

  4. Zamknij okno Usługi.

Krok 3. Usunięcie wszelkich pozostałych folderów instalacji pakietu Office

  1. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  2. Wpisz tekst %CommonProgramFiles%\Microsoft Shared, a następnie kliknij przycisk OK.

    Uwaga: Na komputerze z 64-bitową wersją systemu Windows wpisz tekst %CommonProgramFiles(x86)%\Microsoft Shared, a następnie kliknij przycisk OK.

  3. Jeśli istnieją foldery Office15 i Source Engine, usuń je.

  4. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  5. Wpisz tekst %ProgramFiles%\Microsoft Office, a następnie kliknij przycisk OK.

    Uwaga: Na komputerze z 64-bitową wersją systemu Windows wpisz tekst %ProgramFiles(x86)%\Microsoft Office, a następnie kliknij przycisk OK.

  6. Usuń folder Office15.

  7. W folderze głównym każdego dysku twardego znajdź i otwórz folder MSOCache.

  8. Otwórz folder All Users w folderze MSOCache, a następnie usuń każdy folder mający w nazwie tekst: "0FF1CE}-.

    Uwagi: 

    • Ten tekst zawiera cyfry zero (0) i jeden (1) zamiast liter „O” i „I”. Na przykład usuń folder o tej nazwie:

    • {90150000-001B-0409-0000-0000000FF1CE}-C

Krok 4. Usunięcie wszelkich pozostałych plików instalacji pakietu Office

  1. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  2. Wpisz tekst %appdata%\microsoft\templates, a następnie kliknij przycisk OK.

  3. Usuń pliki Normal.dotm i Welcome to Word.dotx.

  4. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  5. Wpisz tekst %appdata%\microsoft\document building blocks, a następnie kliknij przycisk OK.

  6. W folderze Document Building Blocks otwórz podfolder, a następnie usuń plik Building blocks.dotx.

    Uwaga: Nazwa tego podfolderu jest czterocyfrową liczbą odpowiadającą językowi pakietu Microsoft Office.

  7. Zamknij wszystkie programy przed wykonaniem pozostałych czynności.

Krok 5. Usunięcie podkluczy rejestru systemu Office

  1. Zanim zaczniesz, wykonaj kopię zapasową rejestru, aby móc przywrócić go w przypadku wystąpienia problemów.

    Ostrzeżenie: Niepoprawne zmodyfikowanie rejestru przy użyciu Edytora rejestru lub innej metody może stać się przyczyną poważnych problemów. Ich usunięcie może wymagać ponownego zainstalowania systemu operacyjnego. Firma Microsoft nie może zagwarantować, że rozwiązanie tych problemów będzie możliwe. Użytkownik modyfikuje rejestr na własną odpowiedzialność.

Usuwanie podkluczy rejestru pakietu Office 2013

  1. Naciśnij klawisze logo Windows+R, aby otworzyć okno dialogowe Uruchamianie.

  2. Wpisz tekst regedit, a następnie kliknij przycisk OK.

  3. Kliknij następujący podklucz rejestru:

    • HKEY_CURRENT_USER\Software\Microsoft\Office\15.0

  4. Kliknij pozycję Plik > Eksportuj, wpisz tekst Usunięty_klucz_01, a następnie kliknij przycisk Zapisz.

  5. Kliknij pozycję Edytuj > Usuń, a następnie kliknij przycisk Tak w celu potwierdzenia operacji.

  6. Powtórz te czynności (od 1 do 5) dla każdego podklucza rejestru z poniższych list. Zmień nazwę eksportowanego klucza, zwiększając cyfrę w nazwie każdego podklucza o jeden.

    Na przykład: dla drugiego klucza wpisz nazwę Usunięty_klucz_02, dla trzeciego klucza wpisz nazwę Usunięty_klucz_03 itd.

    Uwaga: W podanych niżej kluczach rejestru znak gwiazdki (*) reprezentuje co najmniej jeden znak w nazwie podklucza.

    32-bitowe wersje systemu Windows

    • HKEY_CURRENT_USER\Software\Microsoft\Office\15.0

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\15.0

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\Upgrade Codes\*F01FEC

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC

    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose

    • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\Win32Assemblies\*Office15*

      64-bitowe wersje systemu Windows

      • HKEY_CURRENT_USER\Software\Microsoft\Office\15.0

      • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\15.0

      • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*

      • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*

      • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose

      • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC

      • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC

      • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC

      • HKEY_CLASSES_ROOT\Installer\Win32Asemblies\*Office15*

    Usuń też następujące podklucze rejestru:

    1. Znajdź jeden z następujących podkluczy, stosownie do używanej wersji systemu Windows:

      • Wersja 32-bitowa: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

      • Wersja 64-bitowa: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall

    2. Kliknij pozycję Plik > Eksportuj, wpisz tekst Klucz_odinstalowywania_01, a następnie kliknij przycisk Zapisz.

    3. W podkluczu Uninstall znalezionym w kroku nr 1 kliknij każdy z podkluczy i określ, czy jest do niego przypisana następująca wartość:

      • Nazwa: UninstallString

      • Dane: ścieżka nazwa_pliku ścieżka\Office Setup Controller\Setup.exe

        W tym przykładzie nazwa_pliku odpowiada rzeczywistej nazwie programu instalacyjnego, a ścieżka rzeczywistej ścieżce pliku.

    4. Jeśli podklucz zawiera nazwę i dane opisane w kroku nr 3, kliknij pozycję Edycja > Usuń. W przeciwnym razie przejdź do kroku 5.

    5. Powtarzaj kroki nr 3 i 4 do czasu znalezienia i usunięcia wszystkich podkluczy, których nazwy i dane pasują do nazw i danych opisanych w kroku 3.

    6. Zamknij Edytor rejestru.

Ręczne usuwanie pakietu Office 2010

Uwaga: Aby móc użyć tej metody, musisz zalogować się przy użyciu konta administratora. Jeśli komputer należy do sieci, może być konieczne poproszenie administratora systemu o pomoc. Jeśli nie masz pewności, czy zalogowano Cię przy użyciu konta administratora, zapoznaj się z artykułem Jak ustalić typ konta użytkownika w systemie Windows, aby uzyskać pomoc.

Ostrzeżenie: Niepoprawne zmodyfikowanie rejestru przy użyciu Edytora rejestru lub innej metody może stać się przyczyną poważnych problemów. Ich usunięcie może wymagać ponownego zainstalowania systemu operacyjnego. Firma Microsoft nie może zagwarantować, że rozwiązanie tych problemów będzie możliwe. Modyfikujesz rejestr na własną odpowiedzialność.

Ten artykuł zawiera informacje dotyczące modyfikowania rejestru. Przed rozpoczęciem modyfikacji upewnij się, że wykonano kopię zapasową rejestru. Warto wiedzieć, jak wykonać kopię zapasową rejestru i przywrócić rejestr w razie wystąpienia problemu.

Na potrzeby tej metody musisz najpierw wyświetlić ukryte pliki i foldery. W tym celu wykonaj następujące czynności:

  1. Otwórz Eksploratora Windows.

  2. W menu Narzędzia kliknij polecenie Opcje folderów. Naciśnij klawisz ALT, aby wyświetlić pasek menu.

  3. Kliknij kartę Widok.

  4. W okienku Ustawienia zaawansowane w obszarze Ukryte pliki i foldery kliknij pozycję Pokaż ukryte pliki i foldery.

  5. Wyczyść pole wyboru Ukryj rozszerzenia znanych typów plików i kliknij przycisk OK, a następnie zamknij okna.

Wiesz już, jak wyświetlić ukryte pliki i foldery. Teraz możesz zacząć ręcznie usuwać pakiet Office.

Krok 1. Usunięcie wszystkich pozostałych pakietów Instalatora Windows dla pakietu Microsoft Office 2010

  1. Kliknij pozycje Start > Wszystkie programy, a następnie otwórz folder Akcesoria.

  2. Kliknij pozycję Uruchom, a następnie kliknij w polu Otwórz.

  3. Wpisz Installer, a następnie kliknij przycisk OK.
    Spowoduje to otwarcie folderu %windir%\Installer.

  4. W menu Widok kliknij pozycję Wybierz szczegóły (naciśnij klawisz ALT, aby wyświetlić pasek menu).

  5. Kliknij, aby zaznaczyć pole wyboru Temat, wpisz 340 w polu Szerokość wybranej kolumny (w pikselach), a następnie kliknij przycisk OK.

  6. Uwaga: Wyświetlenie tematu obok każdego pliku MSI może potrwać kilka minut.

  7. W menu Widok wskaż polecenie Sortuj według, a następnie kliknij pozycję Temat.

  8. Jeśli pojawi się okno dialogowe Kontrola konta użytkownika, kliknij przycisk Zezwalaj, aby kontynuować.

  9. Odszukaj i kliknij prawym przyciskiem myszy każdy plik MSI, który ma temat „Microsoft Office <nazwa produktu> 2010”, a następnie kliknij polecenie Odinstaluj.

Uwaga: <Nazwa produktu> to symbol zastępczy dla nazwy produktu pakietu Microsoft Office 2010.

Krok 2. Zatrzymanie usługi Aparat źródłowy pakietu Office

  1. Kliknij pozycje Start > Wszystkie programy, a następnie otwórz folder Akcesoria.

  2. Kliknij pozycję Uruchom, a następnie kliknij w polu Otwórz.

  3. Wpisz services.msc, a następnie kliknij przycisk OK.

  4. W oknie Usługi przewiń listę w dół do momentu wyświetlenia pozycji Aparat źródłowy pakietu Office i sprawdź, czy usługa jest uruchomiona (w kolumnie Stan jest wyświetlany tekst „Uruchomiono”). Jeśli ta usługa jest uruchomiona, kliknij prawym przyciskiem myszy pozycję Aparat źródłowy pakietu Office, a następnie kliknij polecenie Zatrzymaj.

  5. Zamknij okno Usługi.

Krok 3. Usunięcie wszelkich pozostałych folderów instalacji pakietu Microsoft Office 2010

  1. Kliknij pozycję Start > Wszystkie programy, a następnie otwórz folder Akcesoria.

  2. Kliknij pozycję Uruchom, a następnie kliknij w polu Otwórz.

  3. Wpisz %CommonProgramFiles%\Microsoft Shared, a następnie kliknij przycisk OK.

Uwaga: na komputerze z 64-bitową wersją systemu Windows 7 wpisz %CommonProgramFiles(x86)%\Microsoft Shared, a następnie kliknij przycisk OK.

  1. Jeśli istnieją następujące foldery, usuń je:

    • Office14

    • Source Engine

  2. Kliknij pozycję Start > Wszystkie programy, a następnie otwórz folder Akcesoria.

  3. Kliknij pozycję Uruchom, a następnie kliknij w polu Otwórz.

  4. Wpisz %ProgramFiles%\Microsoft Office, a następnie kliknij przycisk OK.

Uwaga: na komputerze z 64-bitową wersją systemu Windows 7 wpisz %ProgramFiles(x86)%\Microsoft Office, a następnie kliknij przycisk OK.

  1. Usuń folder Office14.

  2. W folderze głównym każdego dysku twardego znajdź i otwórz folder MSOCache. Jeśli nie widzisz tego folderu, musisz wyświetlić ukryte pliki i foldery.

  3. Otwórz folder All Users w folderze MSOCache, a następnie usuń każdy folder mający w nazwie tekst 0FF1CE}-.

Uwaga:  W tym tekście zamiast liter „O” i „I” są wyświetlane cyfry zero i jeden.
Przykład: {90140000-001B-0409-0000-0000000FF1CE}-C

Krok 4. Usunięcie pozostałych plików instalacji pakietu Microsoft Office 2010

  1. Kliknij pozycje Start > Wszystkie programy, a następnie otwórz folder Akcesoria.

  2. Kliknij pozycję Uruchom, a następnie kliknij w polu Otwórz.

  3. Wpisz %appdata%\microsoft\templates, a następnie kliknij przycisk OK.

  4. Usuń następujące pliki:

    • Normal.dotm

    • Normalemail.dotm

  5. Kliknij pozycje Start > Wszystkie programy, a następnie otwórz folder Akcesoria.

  6. Kliknij pozycję Uruchom, a następnie kliknij w polu Otwórz.

  7. Wpisz %appdata%\microsoft\document building blocks, a następnie kliknij przycisk OK.

  8. Otwórz podfolder w folderze Document Building Blocks.

Uwaga: nazwa tego podfolderu jest czterocyfrową liczbą odpowiadającą wersji językowej pakietu Microsoft Office.

  1. Usuń plik building blocks.dotx.

  2. Zamknij wszystkie programy przed wykonaniem pozostałych czynności.

  3. Kliknij pozycje Start > Wszystkie programy, a następnie otwórz folder Akcesoria.

  4. Wpisz %temp%, a następnie kliknij przycisk OK.

  5. W menu Edycja kliknij polecenie Zaznacz wszystko.

  6. W menu Plik kliknij polecenie Usuń.

  7. Kliknij pozycję Start > Wszystkie programy, a następnie otwórz folder Akcesoria.

  8. Kliknij pozycję Uruchom, a następnie kliknij w polu Otwórz.

  9. Wpisz %AllUsersprofile%\Application Data\Microsoft\Office\Data, a następnie kliknij przycisk OK.

  10. Usuń WYŁĄCZNIE plik opa14.dat. Ten plik nie jest wyświetlany

Krok 5. Usunięcie podkluczy rejestru pakietu Microsoft Office 2010

Znajdź i usuń podklucze rejestru pakietu Office 2010, jeśli istnieją. W tym celu wykonaj następujące czynności:

32-bitowa wersja pakietu Office 2010

  1. Kliknij pozycje Start > Wszystkie programy, a następnie otwórz folder Akcesoria.

  2. Kliknij pozycję Uruchom, a następnie kliknij w polu Otwórz.

  3. Wpisz regedit, a następnie kliknij przycisk OK.

  4. Kliknij następujący podklucz rejestru:
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0

  5. W menu Plik kliknij polecenie Eksportuj, wpisz Usunięty_klucz_01, a następnie kliknij przycisk Zapisz.

  6. W menu Edycja kliknij polecenie Usuń, a następnie kliknij przycisk Tak w celu potwierdzenia operacji.

  7. Powtórz te czynności (od 1 do 7) dla każdego podklucza rejestru z poniższej listy. Zmień nazwę eksportowanego klucza, zwiększając cyfrę w nazwie każdego podklucza o jeden.

Przykład: dla drugiego klucza wpisz nazwę Usunięty_klucz_02, dla trzeciego klucza wpisz nazwę Usunięty_klucz_03 itd.

W poniższych kluczach rejestru znak gwiazdki (*) odzwierciedla co najmniej jeden znak w nazwie podklucza.

  • HKEY_CURRENT_USER\Software\Microsoft\Office\14.0

  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0

  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*

  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*

  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\Upgrade Codes\*F01FEC

  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose

  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC

  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC

  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC

  • HKEY_CLASSES_ROOT\Installer\Win32Assemblies\*Office14*

  • Znajdź następujący podklucz rejestru:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

  • W menu Plik kliknij polecenie Eksportuj, wpisz Klucz_odinstalowywania_01, a następnie kliknij przycisk Zapisz.

  • W podkluczu Uninstall znalezionym w kroku nr 1 kliknij każdy z podkluczy i określ, czy jest do niego przypisana następująca wartość:

    • Nazwa: UninstallString

    • Dane: ścieżka nazwa_pliku ścieżka\Office Setup Controller\Setup.exe

Uwaga: w tym przykładzie nazwa_pliku to symbol zastępczy nazwy programu instalacyjnego, a ścieżka to symbol zastępczy ścieżki pliku.

  1. Jeśli podklucz zawiera nazwę i dane opisane w kroku 3, kliknij polecenie Usuń w menu Edycja. W przeciwnym razie przejdź do kroku 5.

  2. Powtarzaj kroki nr 3 i 4 do czasu znalezienia i usunięcia wszystkich podkluczy, których nazwy i dane pasują do nazw i danych opisanych w kroku 3.

  3. Zamknij Edytor rejestru.

64-bitowa wersja pakietu Office 2010

  1. Kliknij pozycje Start > Wszystkie programy, a następnie otwórz folder Akcesoria.

  2. Kliknij pozycję Uruchom, a następnie kliknij w polu Otwórz.

  3. Wpisz regedit, a następnie kliknij przycisk OK.

  4. Kliknij następujący podklucz rejestru:
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0

  5. W menu Plik kliknij polecenie Eksportuj, wpisz Usunięty_klucz_01, a następnie kliknij przycisk Zapisz.

  6. W menu Edycja kliknij polecenie Usuń, a następnie kliknij przycisk Tak w celu potwierdzenia operacji.

  7. Powtórz te czynności (od 1 do 7) dla każdego podklucza rejestru z poniższej listy. Zmień nazwę eksportowanego klucza, zwiększając cyfrę w nazwie każdego podklucza o jeden.

Przykład: dla drugiego klucza wpisz nazwę Usunięty_klucz_02, dla trzeciego klucza wpisz nazwę Usunięty_klucz_03 itd.

Uwaga: w poniższych kluczach rejestru znak gwiazdki (*) odzwierciedla co najmniej jeden znak w nazwie podklucza.

  • HKEY_CURRENT_USER\Software\Microsoft\Office\14.0

  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\14.0

  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*

  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*

  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UpgradeCodes\*F01FEC

  • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose

  • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC

  • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC

  • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC

  • HKEY_CLASSES_ROOT\Installer\Win32Asemblies\*Office14*

  • Znajdź następujący podklucz rejestru:

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall

  • W menu Plik kliknij polecenie Eksportuj, wpisz Klucz_odinstalowywania_01, a następnie kliknij przycisk Zapisz.

  • W podkluczu Uninstall znalezionym w kroku nr 1 kliknij każdy z podkluczy i określ, czy jest do niego przypisana następująca wartość:

    • Nazwa: UninstallString

    • Dane: ścieżka nazwa_pliku ścieżka\Office Setup Controller\Setup.exe

Uwaga: w tym przykładzie nazwa_pliku to symbol zastępczy nazwy programu instalacyjnego, a ścieżka to symbol zastępczy ścieżki pliku.

  1. Jeśli podklucz zawiera nazwę i dane opisane w kroku 3, kliknij polecenie Usuń w menu Edycja. W przeciwnym razie przejdź do kroku 5.

  2. Powtarzaj kroki nr 3 i 4 do czasu znalezienia i usunięcia wszystkich podkluczy, których nazwy i dane pasują do nazw i danych opisanych w kroku 3.

  3. Zamknij Edytor rejestru

Krok 6. Ponowne uruchomienie komputera

Uruchom ponownie komputer i ponownie zainstaluj pakiet Microsoft Office.

Uwaga: Aby użyć tej metody, należy zalogować się przy użyciu konta administratora. Jeśli komputer należy do sieci, może być konieczne poproszenie administratora systemu o pomoc.

Na potrzeby tej metody należy najpierw wyświetlić ukryte pliki i foldery. W tym celu wykonaj następujące czynności:

  1. Otwórz Eksploratora Windows.

  2. W menu Narzędzia kliknij polecenie Opcje folderów. W systemie Windows 7 lub Vista naciśnij klawisz ALT, aby wyświetlić pasek menu.

  3. Kliknij kartę Widok.

  4. W okienku Ustawienia zaawansowane w obszarze Ukryte pliki i foldery kliknij pozycję Pokaż ukryte pliki i foldery.

  5. Wyczyść pole Ukryj rozszerzenia plików znanych typów.

  6. Kliknij przycisk OK, a następnie zamknij okna.

Krok 1. Usunięcie wszystkich pozostałych pakietów Instalatora Windows dla pakietu Microsoft Office 2007

  1. Otwórz folder %windir%\Installer. W tym celu kliknij przycisk Start i polecenie Uruchom, wpisz %windir%\Installer, a następnie kliknij przycisk OK.

  2. W menu Widok kliknij pozycję Wybierz szczegóły.

  3. Kliknij, aby zaznaczyć pole wyboru Temat, wpisz 340 w polu Szerokość wybranej kolumny (w pikselach), a następnie kliknij przycisk OK.

    Uwaga: Wyświetlenie tematu obok każdego pliku MSI może potrwać kilka minut.

  4. W menu Widok wskaż pozycję Sortuj według w systemie Windows 7 lub Vista albo pozycję Rozmieść ikony według w systemie Windows XP, a następnie kliknij pozycję Temat.

  5. Jeśli pojawi się okno dialogowe Kontrola konta użytkownika, kliknij przycisk Zezwalaj, aby kontynuować.

  6. Odszukaj i kliknij prawym przyciskiem myszy każdy plik MSI, który ma temat „Microsoft Office <nazwa produktu> 2007”, a następnie kliknij polecenie Odinstaluj.

    Uwaga: Symbol zastępczy <nazwa produktu> oznacza nazwę konkretnego produktu pakietu Microsoft Office 2007.

Krok 2. Zatrzymanie usługi Aparat źródłowy pakietu Office

  1. Otwórz okno Usługi. W tym celu kliknij przycisk Start i polecenie Uruchom, wpisz services.msc, a następnie kliknij przycisk OK.

  2. W oknie Usługi ustal, czy usługa Aparat źródłowy pakietu Office jest uruchomiona (czy w kolumnie Stan widnieje wpis „Uruchomiono”). Jeśli ta usługa jest uruchomiona, kliknij prawym przyciskiem myszy pozycję Aparat źródłowy pakietu Office, a następnie kliknij polecenie Zatrzymaj.

  3. Zamknij okno Usługi.

Krok 3. Usunięcie pozostałych folderów instalacji pakietu Microsoft Office 2007.

  1. Otwórz folder %CommonProgramFiles%\Microsoft Shared. W tym celu kliknij przycisk Start i polecenie Uruchom, wpisz %CommonProgramFiles%\Microsoft Shared, a następnie kliknij przycisk OK.

    Uwaga: Na komputerze z 64-bitową wersją systemu Windows 7 lub Vista wpisz %CommonProgramFiles(x86)%\Microsoft Shared, a następnie kliknij przycisk OK.

  2. Jeśli istnieją następujące foldery, usuń je:

    • Office12

    • Source Engine

  3. Otwórz folder %ProgramFiles%\Microsoft Office. W tym celu kliknij przycisk Start i polecenie Uruchom, wpisz %ProgramFiles%\Microsoft Office, a następnie kliknij przycisk OK.

    Uwaga: Na komputerze z 64-bitową wersją systemu Windows 7 lub Vista wpisz %ProgramFiles(x86)%\Microsoft Office, a następnie kliknij przycisk OK.

  4. Usuń folder Office12.

  5. W folderze głównym każdego dysku twardego znajdź i otwórz folder MSOCache. Jeśli nie widzisz tego folderu, musisz wyświetlić ukryte pliki.

  6. Otwórz folder All Users w folderze MSOCache, a następnie usuń każdy folder mający w nazwie tekst 0FF1CE}-.

    Uwaga: W tym tekście zamiast liter „O” i „I” są wyświetlane cyfry zero i jeden. Na przykład: {90140000-001B-0409-0000-0000000FF1CE}-C.

Krok 4. Usunięcie pozostałych plików instalacji pakietu Microsoft Office 2007

  1. Otwórz folder %AppData%\Microsoft\Templates. W tym celu kliknij przycisk Start i polecenie Uruchom, wpisz %appdata%\microsoft\templates, a następnie kliknij przycisk OK.

  2. Usuń następujące pliki:

    • Normal.dotm

    • Normalemail.dotm

  3. Otwórz folder %AppData%\Microsoft\Document Building Blocks. W tym celu kliknij przycisk Start i polecenie Uruchom, wpisz %appdata%\microsoft\document building blocks, a następnie kliknij przycisk OK.

  4. Otwórz podfolder znajdujący się w folderze Document Building Blocks.

    Uwaga:  Nazwa tego podfolderu jest czterocyfrową liczbą odpowiadającą wersji językowej pakietu Microsoft Office.

  5. Usuń plik building blocks.dotx.

  6. Zamknij wszystkie programy przed wykonaniem pozostałych czynności.

  7. Otwórz folder %Temp%. W tym celu kliknij przycisk Start i polecenie Uruchom, wpisz %temp%, a następnie kliknij przycisk OK.

  8. W menu Edycja kliknij opcję Zaznacz wszystko.

  9. W menu Plik kliknij polecenie Usuń.

  10. Otwórz folder %AllUsersprofile%\Application Data\Microsoft\Office\Data. W tym celu kliknij przycisk Start i polecenie Uruchom, wpisz %AllUsersprofile%\Application Data\Microsoft\Office\Data, a następnie kliknij przycisk OK.

  11. Usuń WYŁĄCZNIE plik opa12.dat.

Krok 5. Usunięcie podkluczy rejestru pakietu Microsoft Office 2007

Ważne: Wykonując czynności opisane w tej sekcji, zachowaj ostrożność. Niepoprawne zmodyfikowanie rejestru może spowodować poważne problemy. Zanim zaczniesz, wykonaj kopię zapasową rejestru, aby móc przywrócić go w przypadku wystąpienia problemów.

Znajdź i usuń podklucze rejestru pakietu Office 2007, jeśli istnieją. W tym celu wykonaj następujące czynności:

  1. Otwórz Edytor rejestru. W tym celu kliknij przycisk Start i polecenie Uruchom, wpisz regedit, a następnie kliknij przycisk OK.

  2. Znajdź i kliknij następujący podklucz rejestru:

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0

  3. W menu Plik kliknij polecenie Eksportuj, wpisz Usunięty_klucz_01, a następnie kliknij przycisk Zapisz.

  4. W menu Edycja kliknij polecenie Usuń, a następnie kliknij przycisk Tak w celu potwierdzenia operacji.

  5. Powtórz te czynności (od 2 do 4) dla każdego podklucza rejestru z poniższej listy. Zmień nazwę eksportowanego klucza, zwiększając cyfrę w nazwie każdego podklucza o jeden.

    Na przykład: dla drugiego klucza wpisz nazwę Usunięty_klucz_02, dla trzeciego klucza wpisz nazwę Usunięty_klucz_03 itd.

    Klucze rejestru do usunięcia w 32-bitowych wersjach systemu Microsoft Windows 

    • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\Upgrade Codes\*F01FEC

    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC

    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose

    • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\Win32Assemblies\*Office12*

    Klucze rejestru do usunięcia w 64-bitowych wersjach systemu Microsoft Windows 

    • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\12.0

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Delivery\SourceEngine\Downloads\*0FF1CE}-*

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\*0FF1CE*

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UpgradeCodes\*F01FEC

    • HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\*F01FEC

    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ose

    • HKEY_CLASSES_ROOT\Installer\Features\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\Products\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\UpgradeCodes\*F01FEC

    • HKEY_CLASSES_ROOT\Installer\Win32Asemblies\*Office12*

    Uwaga: W kluczach rejestru znak gwiazdki (*) oznacza co najmniej jeden znak w nazwie podklucza.

Kontynuuj usuwanie odpowiednich kluczy rejestru.

  1. Otwórz Edytor rejestru, znajdź następujący podklucz rejestru:

    • Wersja 32-bitowa:   HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

    • Wersja 64-bitowa:    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall

  2. W menu Plik kliknij polecenie Eksportuj, wpisz Klucz_odinstalowywania_01, a następnie kliknij przycisk Zapisz.

  3. W podkluczu Uninstall znalezionym w kroku nr 1 kliknij każdy z podkluczy i określ, czy jest do niego przypisana następująca wartość:

    • Nazwa: UninstallString

    • Dane: ścieżka nazwa_pliku ścieżka\Office Setup Controller\Setup.exe

      Uwaga: Symbol zastępczy nazwa_pliku oznacza nazwę programu instalacyjnego, a symbol zastępczy ścieżka oznacza ścieżkę pliku.

  4. Jeśli podklucz zawiera nazwę i dane opisane w kroku 3, kliknij polecenie Usuń w menu Edycja. W przeciwnym razie przejdź do kroku 5.

  5. Powtarzaj kroki nr 3 i 4 do czasu znalezienia i usunięcia wszystkich podkluczy, których nazwy i dane pasują do nazw i danych opisanych w kroku 3.

  6. Zamknij Edytor rejestru.

Krok 6. Ponowne uruchomienie komputera

Uruchom ponownie komputer. Jeśli usuwanie przebiegło pomyślnie, to koniec całej procedury. Jeśli chcesz, możesz teraz ponownie zainstalować pakiet Microsoft Office.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×