Rozwiązywanie lub usuwanie zduplikowanych kontaktów

Jeśli kontakty zostały zaimportowane z wielu źródeł lub lista kontaktów innej osoby odziedziczyła, kontakty zduplikowane mogą być przechowywane w Outlook. W przypadku importowania nowych kontaktów ze źródła zewnętrznego, takiego jak iCloud lub Gmail, program Outlook sprawdza duplikaty i umożliwia określenie, czy chcesz utworzyć nowy rekord kontaktu (duplikat), czy scalić zduplikowane kontakty. Niestety, po zduplikowanych kontaktach w folderach kontaktów nie ma automatycznego procesu ich usuwania. Można jednak wyeksportować wszystkie kontakty do pliku, a następnie ponownie zaimportować je do programu Outlook i skorzystać z wbudowanych funkcji sprawdzania duplikatów. Jeśli masz tylko kilka zduplikowanych kontaktów, możesz posortować listę kontaktów i usunąć je ręcznie.

Usuwanie zduplikowanych kontaktów po jednym na raz

  1. Kliknij pozycję Osoby.

    Wybierz ikonę Kontakty, aby wyświetlić swoje kontakty.

  2. Na Wstążce w grupie Widok bieżący kliknij prawy dolny róg pola widoków, a następnie kliknij pozycję Telefon . Jest to najprostszy widok do zeskanowania listy kontaktów i wyświetlenia duplikatów.

    Grupa Widok bieżący na karcie Narzędzia główne

  3. Na liście kontaktów przytrzymaj naciśnięty klawisz Ctrl i klikaj poszczególne kontakty, które chcesz usunąć.

    Przytrzymywanie klawisza CTRL i klikanie kontaktów do usunięcia

  4. Po wybraniu wszystkich duplikatów naciśnij klawisz Delete lub klawisze Ctrl+D.

Usuwanie dużej liczby zduplikowanych kontaktów za pomocą eksportowania i importowania

W przypadku dużej liczby zduplikowanych kontaktów usunięcie ich po jednym może być pracochłonne i czasochłonne. Najszybszym sposobem na usunięcie dużej liczby zduplikowanych kontaktów jest wyeksportowanie ich do pliku, a następnie zaimportowanie ich do nowego folderu. Aby korzystać z funkcji wykrywania duplikatów w Outlook importowania, zrób tak:

  1. Kliknij pozycję Osoby.

    Wybierz ikonę Kontakty, aby wyświetlić swoje kontakty.

  2. Kliknij prawym przyciskiem myszy bieżący folder Kontakty i wybierz pozycję Nowy folder.

    Utwórz nowy folder kontaktów.
  3. Nadaj nazwę noweowi folderowi, na przykład Duplicates.

  4. Kliknij ponownie w głównym folderze Kontakty.

  5. Naciśnij klawisze Ctrl+A, aby zaznaczyć wszystkie kontakty.

  6. Przeciągnij kontakty i upuść je w folderze Duplikaty lub użyj klawiszy Ctrl+Shift+V, aby otworzyć okno dialogowe Przenieś do folderu i wybierz folder Duplikaty.

    Przenieś kontakty do innego folderu.
  7. Podstawowy folder kontaktów powinien być teraz pusty.

  8. Wybierz pozycję Plik > Otwórz i eksportuj > Importuj/Eksportuj.

    Uwaga: W Outlook 2010 wybierz pozycję Plik >Otwórz > Eksportuj i przejdź do kroku 10.

    Wybierz Import/Export.
  9. Wybierz pozycję Eksportuj do pliku.

  10. Wybierz pozycję Wartości oddzielone przecinkami (Windows).

  11. Wybierz folder Duplikaty utworzony w kroku 3.

    Eksportowanie z folderu Duplikaty.
  12. Zapisz plik w innym miejscu, gdzie będzie można go znaleźć.

  13. Kliknij przycisk Zakończ.

Importowanie kontaktów z powrotem do Outlook

  1. Wybierz pozycję Plik > Otwórz i eksportuj > Importuj/Eksportuj.

    Uwaga: W Outlook 2010 wybierz pozycję Plik >Otwórz > Importowanie i przejdź do kroku 3.

    Wybierz Import/Export.
  2. Wybierz pozycję Importuj z innego programu lub pliku.

  3. Wybierz pozycję Wartości oddzielone przecinkami (Windows).

  4. Przeglądaj w celu znalezienia pliku utworzonego w powyższej procedurze.

    Wybierz plik do zaimportowania.
  5. Zaznacz opcję Nie importuj zduplikowanych elementów.

  6. Wybierz główny folder kontaktów jako folder docelowy. Jest to folder, który jest obecnie pusty.

  7. Wybierz pozycję Zakończ.

Skopiowanie kontaktów z folderu Duplikaty z powrotem do głównego folderu Kontakty

  1. Wybierz folder kontaktów Duplikaty.

  2. Kliknij jeden kontakt w folderze, a następnie naciśnij klawisze Ctrl+A, aby zaznaczyć wszystkie kontakty.

  3. Przenieś zaznaczone kontakty do głównego folderu Kontakty. Możesz je przeciągać i upuszczać lub naciskać klawisze Ctrl+Shift+V, aby użyć okna dialogowego Przenieś do folderu.

  4. Za każdym Outlook wystąpi zduplikowany kontakt, zostanie wyświetlony monit z dwiema możliwościami.

    • Wybierz pozycję Dodaj nowy kontakt, jeśli kontakt nie jest duplikatem.

    • Jeśli kontakt jest duplikatem, zaznacz pole wyboru Aktualizuj informacje o zaznaczonym kontakcie.

    Po wybraniu opcji wybierz pozycję Aktualizuj. Jeśli chcesz powtórzyć tę samą czynność dla wszystkich zduplikowanych kontaktów, wybierz pozycję Aktualizuj wszystko.

    Wybierz, co chcesz zrobić ze zduplikowanymi kontaktami.
  5. Po procesie przenoszenia do folderu możesz usunąć folder Duplikaty.

W oknie dialogowym Zduplikowane kontakty wykryte kontakty są dostępne dwie opcje rozwiązywania problemów ze zduplikowanymi kontaktami:

Dodawanie duplikatu jako nowego kontaktu     Nowy kontakt zostanie dodany do folderu Kontakty. Jeśli na przykład utworzysz kontakt o nazwie Anny Lew, a w folderze Kontakty istnieje już kontakt o tej nazwie, w folderze Kontakty będą dwa kontakty o nazwie Anny Lew. Aby odróżnić te dwie osoby, możesz dodać inicjał środkowy do pierwszego.

Porada: Wyświetlanie kontaktów jako wizytówek elektronicznych to dobry wybór widoków, w których należy wyświetlać informacje wystarczające do rozróżniania kontaktów ze zduplikowanymi nazwami.

Aktualizowanie nowych informacji ze zduplikowanego kontaktu do istniejącego    Outlook zostaną porównane wszystkie pola, które zawierają dane zarówno w kontaktach zduplikowanych, jak i w istniejących, i skopiuje dane z zduplikowanego kontaktu do wszystkich pól istniejącego kontaktu, które zawierają dane powodujące konflikt. Jeśli na przykład masz kontakt o nazwie Anny Lew o numerze telefonu 555-0112 i otrzymasz kontakt zduplikowany z nowym numerem telefonu, program Outlook skopiuje nowy numer do odpowiedniego pola w istniejącym kontakcie i pozostawi te same wszystkie pozostałe pola.

Kategorie kolorów, które przypiszesz do nowego kontaktu i tekst w wiadomości od nowego kontaktu, nie zostaną skopiowane do istniejącego kontaktu. Jeśli chcesz skopiować te informacje, musisz zrobić to ręcznie. Certyfikaty i linki do kontaktów na karcie Działania zostaną skopiowane z zduplikowanego kontaktu i dodane do istniejącego kontaktu bez zastępowania oryginalnych informacji. Jednak linki na karcie Działania do elementów innych niż kontakty, takich jak zadania i terminy, nie zostaną skopiowane.

Gdy Outlook danych w kontakcie, kopia oryginalnego kontaktu jest przechowywana w folderze Elementy usunięte. Tej kopii można użyć, aby przywrócić informacje z pierwotnego kontaktu.

Jeśli kontakty zostały zaimportowane do programu Outlook przy użyciu tych samych nazw lub adresów e-mail, które już znajdują się w folderze Kontakty, i została wybrana opcja Zezwalaj na duplikowanie w Kreatorze importu i eksportu, mogą istnieć niepożądane duplikaty kilku lub wszystkich zaimportowanych kontaktów.

Usuwanie niechcianych zduplikowanych kontaktów jest procesem ręcznym, ale najłatwiej jest wykonać poniższe czynności.

  1. W folderzeKontakty wybierz folder kontaktów zawierający zduplikowane kontakty.

  2. Na liście okienko nawigacjiw obszarze Widok bieżącykliknij pozycję Telefon widok. Jest to najlepszy widok do skanowania listy kontaktów i wyświetlania zduplikowanych kontaktów. Teraz możesz posortować listę według zmodyfikowanej daty i zgrupować duplikaty.

  3. W menu Widok wskaż polecenie Widok bieżący, a następnie kliknij pozycję Dostosuj widok bieżący.

  4. Kliknij pozycję Pola,wybierz pozycję Zmodyfikowano na liście Dostępne pola, a następnie kliknij przycisk Dodaj.

  5. Kliknij pozycję Przenieś w górę do chwili zmodyfikowania u góry listy Pokaż te pola na tej liście zamówień.

  6. Kliknij przycisk OK dwa razy.

  7. Na liście kontaktów przytrzymaj naciśnięty klawisz CTRL podczas zaznaczania każdego ze zduplikowanych kontaktów.

  8. Po wybraniu wszystkich zduplikowanych kontaktów naciśnij klawisz DELETE.

Uwaga: Jeśli nie chcesz duplikować kontaktów podczas importowania kontaktów do programu Outlook, zaznacz opcję Nie importuj duplikatów lub Zamień duplikaty na elementy importowane w Kreatorze importu i eksportu.

  • Nie importuj duplikatów Istniejące dane zostaną zachowane, a zduplikowane informacje w plik folderów osobistych (pst) nie zostaną skopiowane do folderu Kontakty.

  • Zamień duplikaty na elementy importowane Istniejące dane w folderze Kontakty zostaną zastąpione informacjami z importowanego pliku pst.

Jeśli zapisywanych jest wiele kontaktów w Outlook, proces ten może być szybszy, jeśli funkcja wykrywania duplikatów nie zostanie użycia. Aby wyłączyć tę funkcję, wykonaj następujące czynności:

  1. W menu Narzędzia kliknij pozycję Opcje.

  2. Kliknij pozycję Opcje kontaktu,a następnie wyczyść pole wyboru Sprawdź zduplikowane kontakty.

Potrzebna dalsza pomoc?

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

×