Tworzenie diagramu komunikacji UML

Diagram komunikacji UML można utworzyć w celu pokazania interakcji między sieciami życia, które używają sekwencji wiadomości w układzie swobodnym. Najpierw otwórz szablon UML Communication i wybierz jedną z czterech opcji szablonu. Pojawi się wzornik UML Communication wraz z kształtami zgodnymi ze standardem UML 2.5.

Przykładowy diagram komunikacji UML.

Uwaga: Wzornik UML Communication jest dostępny tylko dla subskrybentów usługi Visio (plan 2) użytkowników. Jeśli masz subskrypcję, upewnij się, że masz najnowszą wersję pakietu Visio.

  1. Uruchom program Visio. Jeśli plik jest już otwarty, kliknij pozycję Plik > Nowy.

  2. Przejdź do categories > Software and Database > UML Communication.

  3. Wybierz pusty szablon lub jeden z trzech diagramów startowych. Jeśli chcesz reprezentować współpracę linii życia przez pokazywanie interakcji między sieciami życia, wybierz diagram startowy w lewym dolnym rogu.

  4. Kliknij przycisk Utwórz.

  5. Obok diagramu powinno zostać otwarte okno Kształty. Jeśli nie widzisz tej opcji, przejdź do strony Widok > zadań i upewnij się, że jest zaznaczona opcja Kształty. Jeśli nadal jej nie widzisz, kliknij przycisk Rozwiń okno Kształty Przycisk Rozwiń okno Kształty po lewej stronie.

  6. Upewnij się, że na karcie Widok jest zaznaczone pole wyboru obok przycisku Punkty połączeń. Dzięki temu punkty połączeń będą wyświetlane po rozpoczęciu łączenia kształtów.

  7. Teraz przeciągnij na stronę kształty, które chcesz uwzględnić w diagramie, z okna Kształty. Aby zmienić nazwę etykiet tekstowych, kliknij je dwukrotnie.

Kiedy używać

  1. Przeciągnij kształt Actor (Aktor) na stronę, aby reprezentować rolę użytkownika lub systemu zewnętrznego.

  2. Przeciągnij kształt Linia życia na stronę każdego nazwanego elementu reprezentującego pojedynczego uczestnika.

1: Actor shape with "Somebody" text 2: Lifeline shape with ":Coupon" text

Krok 1

Przeciągnij kształt wiadomości na stronę i przyklej jeden koniec do punktu połączenia na innym kształcie. Gdy wokół punktu połączenia znajduje się zielony kwadrat, wiadomo, że jest przyklejona.

Message shape with one end highlight in green and connected to lifeline shape

Krok 2

Zrób to samo dla drugiego końca wiadomości, tak aby była również przyklejona do punktu połączenia. Wiemy, że przykleja się ona, gdy wokół punktu znajduje się zielone wyróżnienie.

Message shape with end highlighted in green and connected to another lifeline shape

Krok 3

Jeśli komunikat ma być asynchroniczny, kliknij prawym przyciskiem myszy i wybierz pozycję Asynchroniczne. Spowoduje to zmianę zamkniętego grotu strzałki w otwarty.

Message shape, right-click menu, asynchronous command selected

Omówienie

  1. Najpierw połącz linie życia za pomocą narzędzia Łącznik.

  2. Następnie użyj kształtów Wiadomość iZwracanie wiadomości, aby pokazać interakcje między lifelines.

1 pointing to gray connector line, 2 pointing to message line with text, "4: Execute()"

Krok 1

Na karcie Narzędzia główne kliknij narzędzie Łącznik (1). Umieść wskaźnik myszy na jednym z punktów połączeń kształtu linii życia, aż zobaczysz zielone wyróżnienie (2).

1 pointing to Connector tool, 2 pointing to cursor hovering over green highlighted connection point on lifeline shape

Krok 2

Kliknij i przeciągnij od zielonego wyróżnienia do punktu połączenia na innym kształcie linii życia, aż zobaczysz takie wyróżnienie.

Koniec linii łącznika przeciągnięty do innego kształtu linii życia z zielonym wyróżnieniem wokół punktu połączenia

Krok 3

Po połączeniu kształtów linii życia kliknij narzędzie Wskaźnik.

"Click here when you done" pointing to Pointer Tool command

Krok 4

Przeciągnij kolejny kształt wiadomości, aby był równoległy do drugiego wiersza.

Cursor positioning message shape into place next to connector line

Prostowanie łączników

Jeśli łącznik obraca się zbyt wiele, kliknij go prawym przyciskiem myszy, a następnie kliknij pozycję Straight Connector.

Zmienianie typu łącznika

Typ łącznika można zmienić. Na przykład możesz zmienić skojarzenie na Skojarzenie kierowane. Kliknij łącznik prawym przyciskiem myszy, a następnie kliknij polecenie Ustaw typ łącznika.

Make dynamic connections instead instead point connections

Jeśli przewidujesz przenoszenie kształtów, warto rozważyć połączenie dynamiczne zamiast połączenia punktowego.

Przenoszenie lub obracanie tekstu w łącznikach

Prawdopodobnie będzie konieczne obrócenie lub przeniesienie tekstu na liniach łączników. Oto jak to zrobić:

  1. Kliknij pusty obszar strony, aby usunąć zaznaczenie wszystkich zaznaczonych obszarów.

  2. Na karcie Narzędzia główne w grupie Narzędzia kliknij narzędzie Blok tekstu, aby Przycisk bloku tekstu

  3. Kliknij łącznik z tekstem, który chcesz obrócić lub przenieść.

  4. Przeciągnij blok tekstu, aby go przenieść, lub obróć go za pomocą uchwytu obrotu Uchwyt obrotu podczas przeciągania

  5. Po kliknięciu przycisku Wskaźnik w narzędziu kliknij przycisk Przycisk wskaźnika

    Po powrocie do przycisku Wskaźnik narzędzie Przycisk wskaźnika tekst zachowuje tę samą pozycję względem kształtu. Użycie narzędzia Wskaźnik do Przycisk wskaźnika tekstu spowoduje przeniesienie również kształtu. Aby przenieść tekst niezależnie od kształtu, wróć do narzędzia Blok tekstu i Przycisk bloku tekstu .

Zobacz też

Diagramy UML w programie Visio

Tworzenie diagramu składników UML

Tworzenie diagramu wdrożenia UML

Tworzenie diagramu sekwencji UML

Potrzebna dalsza pomoc?

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×