Możesz utworzyć diagram wdrożenia UML w celu pokazania architektury wdrożenia artefaktów oprogramowania w węzłach. Najpierw otwórz szablon wdrażania UML i wybierz jedną z czterech opcji szablonów. Następnie zostanie wyświetlony wzornik wdrażania UML wraz z kształtami zgodnymi ze standardem UML 2.5.

Wzornik wdrażania UML, przykładowe kształty na stronie

Uruchamianie diagramu wdrażania UML

  1. Uruchom program Visio. Jeśli plik jest już otwarty, kliknij pozycję Plik > Nowy.

  2. Przejdź do kategorii > oprogramowania i bazy danych >wdrażania UML.

  3. Wybierz pusty szablon lub jeden z trzech diagramów startowych. Po wybierz szablon, kliknij pozycję Utwórz.

  4. Obok diagramu powinno zostać otwarte okno Kształty. Jeśli nie widzisz tej opcji, przejdź do > Zadań i upewnij się, że jest zaznaczona opcja Kształty. Jeśli nadal jej nie widzisz, kliknij przycisk Rozwiń okno Kształty Przycisk Rozwiń okno Kształty po lewej stronie.

  5. Upewnij się, że na karcie Widok jest zaznaczone pole wyboru obok przycisku Punkty połączeń. Dzięki temu punkty połączeń będą wyświetlane po rozpoczęciu łączenia kształtów.

  6. Teraz przeciągnij na stronę kształty, które chcesz uwzględnić w diagramie, z okna Kształty. Aby zmienić nazwę etykiet tekstowych, kliknij je dwukrotnie.

Uwaga: Do tworzenia i edytowania diagramów UML na Visio dla sieci Web wymagana jest licencja produktu Visio (plan 1) lub Visio (plan 2), która jest kupowana oddzielnie od firmy Microsoft 365. Aby uzyskać więcej informacji, skontaktuj się z Microsoft 365 administratorem. Jeśli administrator włączył "zakup samoobsługowy", możesz kupić licencję dla Visio siebie. Aby uzyskać więcej informacji, zobacz Często zadawane pytania dotyczące zakupu samoobsługi.

Uruchamianie diagramu wdrażania UML

  1. Otwórz Visio dla sieci Web. W prawym górnym rogu wybierz pozycję Więcej szablonów.

  2. W galerii przewiń w dół do wiersza Wdrożenie UML w dół strony.

    Pierwszy element wiersza reprezentuje pusty szablon oraz wzornik towarzyszący. Pozostałe elementy w wierszu to przykładowe diagramy, które mają już narysowane kształty, aby ułatwić szybkie rozpoczynanie pracy.

  3. Kliknij dowolny element, aby wyświetlić większy podgląd.

  4. Gdy znajdziesz diagram, którego chcesz użyć, kliknij jego przycisk Utwórz.

    W przeglądarce zostanie otwarty nowy diagram z powiązanym wzornikem.

Wystąpienia węzła i artefakty

Kiedy używać

  1. Użyj kształtów wystąpienie węzła, jeśli chcesz określić wystąpienie obliczenia czasu wykonywania lub urządzenia fizycznego.

  2. Umieść kształty wystąpienia artefaktu wewnątrz kształtów wystąpień węzła, aby wdrożyć artefakty.

1 pointing to Node Instance shape "<<cloud machine>> :MachineInstance" ; 2 z punktem kształtu Artefakt: "<<Artefakt>> Liczba Cruncher.py"

Krok 1

Przeciągnij kształt Wystąpienie węzła na stronę, a następnie go powiększyć, przeciągając uchwyty kształtu.

Node Instance shape resized to larger

Krok 2

Przeciągnij kształt Wystąpienie artefaktu i umieść go wewnątrz większego kształtu węzła. Gdy pojawi się zielone wyróżnienie, oznacza to, że mniejszy kształt będzie się znajdował w większym kształcie węzła. Od tego miejsca, gdy kształt węzła zostanie przeniesiony, artefakt wewnątrz również zostanie przeniesiony.

Kształt Artefakt przeciągnięty na wierzch kształtu Wystąpienie węzła z zielonym wyróżnieniem

Inne kształty kontenerów

We wzorniku wdrażania UML są dostępne inne kształty kontenerów. Działają one jak kształt Wystąpienie węzła. Oznacza to, że po upuszczenia kształtów na nie kształty są przyklejone i są przesuwane razem z kontenerem. Oto niektóre z najpopularniejszych kształtów kontenerów na diagramy wdrożeniowe:

Węzły hierarchiczne

Zagnieżdżaj kształty węzła wewnątrz siebie, jeśli chcesz je wyświetlać hierarchicznie.

Węzeł UserClient zawierający węzeł Przeglądarka zawierający artefakt HTML5

Spakowanie kształtów

Kształty można spakować, aby przedstawiać elementy, takie jak folder.

Kształt Spakowanie zawierający inne kształty wystąpienia węzła i artefaktu

Omówienie diagramu

Kształt Przegląd diagramu umożliwia otaczanie wszystkich kształtów ramką.

Diagram overview shape containing other node instance and artifact shapes

Wskazówki łączników

Prostowanie łączników

Jeśli łącznik obraca się zbyt wiele, kliknij go prawym przyciskiem myszy, a następnie kliknij pozycję Straight Connector.

Pokaż liczebność

W razie potrzeby kliknij łącznik prawym przyciskiem myszy i wybierz polecenie Pokaż liczebność. Gdy to zrobisz, zostaną wyświetlone cztery pola tekstowe, w których możesz dodać szczegóły. Jeśli nie potrzebujesz wszystkich pól tekstowych, usuń te, których nie potrzebujesz.

Zmienianie typu łącznika

Typ łącznika można zmienić. Na przykład możesz zmienić skojarzenie z Skojarzenia na Skojarzenie kierowane. Kliknij łącznik prawym przyciskiem myszy, a następnie kliknij polecenie Ustaw typ łącznika.

Make dynamic connections instead instead point connections

Jeśli przewidujesz przenoszenie kształtów, warto rozważyć połączenie dynamiczne zamiast połączenia punktowego.

Przenoszenie lub obracanie tekstu w łącznikach

Prawdopodobnie będzie konieczne obrócenie lub przeniesienie tekstu na liniach łączników. Oto jak to zrobić:

  1. Kliknij pusty obszar strony, aby usunąć zaznaczenie wszystkich zaznaczonych obszarów.

  2. Na karcie Narzędzia główne w grupie Narzędzia kliknij narzędzie Blok tekstu, aby Przycisk bloku tekstu

  3. Kliknij łącznik z tekstem, który chcesz obrócić lub przenieść.

  4. Przeciągnij blok tekstu, aby go przenieść, lub obróć go za pomocą uchwytu obrotu Uchwyt obrotu podczas przeciągania

  5. Po kliknięciu przycisku Wskaźnik w narzędziu kliknij przycisk Przycisk wskaźnika

    Po powrocie do przycisku Wskaźnik narzędzie Przycisk wskaźnika, tekst zachowuje tę samą pozycję względem kształtu. Użycie narzędzia Wskaźnik do Przycisk wskaźnika tekstu spowoduje przeniesienie również kształtu. Aby przenieść tekst niezależnie od kształtu, wróć do narzędzia Blok tekstu i Przycisk bloku tekstu .

Kształty składników

Kiedy używać

Użyj kształtów składników dla każdej jednostki funkcjonalnej w systemie lub aplikacji.

Kształt składnika "Przechowywanie"

Pokaż lub ukryj ukrycie

Kliknij kształt prawym przyciskiem myszy, aby wyświetlić lub ukryć etykietę etykiety.

Menu wyświetlane po kliknięciu prawym przyciskiem myszy, polecenie Pokaż <<polecenie>> etykiety tekstowej

Kształty interfejsu

Kiedy używać

  1. Użyj kształtu Dostarczony interfejs, jeśli chcesz określić zdać klasę/interfejs.

  2. Użyj interfejsu Wymagane, jeśli chcesz określić zależność od klasy/interfejsu.

Two interfaces connected, 1: Provided Interface shape ending with circle, 2: Required Interface shape ending with socket

Krok 1

Przeciągnij kształt Dostarczony interfejs na stronę i przypnij kwadrat portu do punktu połączenia. Wiadomo, że jest podłączona, gdy wokół punktu połączenia jest widać zielone wyróżnienie.

Provided Interface shape glued to Component shape

Krok 2

Przeciągnij kształt Wymagany interfejs na stronę i przypnij go do kwadratu portu również z punktem połączenia. Wiadomo, że jest podłączona, gdy wokół punktu połączenia jest widać zielone wyróżnienie.

Kształt Wymagany interfejs przyklejony do kształtu Składnik

Krok 3

Aby połączyć zarówno interfejs Dostarczony, jak i Wymagany, najpierw zaznacz kształt Wymagany interfejs. Następnie poszukaj żółtego uchwytu.

Żółty uchwyt kształtu Wymagany interfejs

Krok 4

Przeciągnij żółty uchwyt, aby połączyć się z dostarczonym interfejsem.

Wymagany kształt interfejsu połączony z dostarczonym interfejsem

Zobacz też

Diagramy UML w programie Visio

Tworzenie diagramu składników UML

Tworzenie diagramu komunikacji UML

Tworzenie diagramu sekwencji UML

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów firmy Microsoft

Czy te informacje były pomocne?

Jak zadowalająca jest jakość tłumaczenia?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×