Wdrażanie aplikacji programu Access

Access udostępnia platformę o bogatych funkcjach do tworzenia aplikacji baz danych. Aplikacja bazy danych to program komputerowy zapewniający zarówno sposób przechowywania danych i zarządzania nimi oraz interfejs użytkownika zgodny z logiką zadań biznesowych (logiką aplikacji). W tym artykule omówiono podstawowe planowanie wdrażania, pakowanie i podpisywanie, wdrażanie aplikacji baz danych oraz środowisko Access środowiska uruchomieniowego.

Co chcesz zrobić?

Zaplanować wdrożenie

Zanim zaczniesz zadaj sobie następujące pytania dotyczące sposobu wdrażania aplikacji.

Czy należy rozdzielić dane i logikę?

Możesz utworzyć aplikację Access, która łączy zarządzanie danymi i logikę aplikacji w jednym pliku. Jest to domyślna struktura aplikacji w Access. Łączenie zarządzania danymi i logiki aplikacji w jednym pliku zapewnia najprostszą metodę wdrażania, ale ta metoda działa najlepiej tylko wtedy, gdy kilka osób korzysta z aplikacji w tym samym czasie i wiąże się to z pewnym ryzykiem. Na przykład użytkownik może spowodować utratę danych przez nieumyślnie usunięcie lub uszkodzenie pliku aplikacji. W większości przypadków należy rozdzielić zarządzanie danymi i logikę aplikacji. Pomaga to zwiększyć wydajność i niezawodność.

Jednym ze sposobów separacji danych i logiki jest użycie polecenia Baza danych programu Access (na karcie Narzędzia bazy danych w grupie Przenoszenie danych). To polecenie dzieli aplikację bazy danych na dwa pliki programu Access: jeden na logikę (front end) i jeden na dane (back-end). Na przykład baza danych o nazwie MySolution.accdb jest dzielona na dwa pliki o nazwach MySolution_fe.accdb i MySolution_be.accdb. Bazę danych można umieścić w lokalizacji udostępnionej, takiej jak folder sieciowy. Rozpowszechniasz plik frontonie —jedną kopię dla każdego użytkownika — na ich komputerach. Możesz nawet rozpowszechniać różne pliki frontoronu u różnych użytkowników. Aby uzyskać więcej informacji, zobacz Dzielenie bazy danych programu Access.

Innym sposobem separacji zarządzania danymi i logiki aplikacji jest użycie programu serwera bazy danych (takiego jak Microsoft SQL Server) do zarządzania danymi, a programu Access do logiki aplikacji. Aby uzyskać więcej informacji, zobacz Migrowanie bazy danych programu Access do programu SQL Server.

Oto dodatkowe przyczyny wyodrębniania danych i logiki:

  • Integralność i zabezpieczenie danych     Jeśli połączysz dane i logikę w jednym pliku, dane są narażone na te same zagrożenia, co logika aplikacji. Aplikacja Access, która korzysta z osobnych plików logiki i danych, może chronić integralność i bezpieczeństwo danych, korzystając z funkcji zabezpieczeń systemu PLIKÓW NTFS w folderach sieciowych.

    Access użytkownicy muszą mieć uprawnienia do odczytu, zapisu, tworzenia i usuwania w folderze, w którym znajduje się plik frontoronu. Można jednak przypisać różne uprawnienia do samego pliku frontonu. Na przykład możesz zechcieć przypisać niektórym użytkownikom uprawnienia tylko do odczytu i zapisu.

    Twoja aplikacja może wymagać dodatkowych opcji zabezpieczeń, takich jak możliwość kontrolowania, którzy użytkownicy mają dostęp do konkretnych danych. W takim przypadku możesz użyć programu SQL Server lub SharePoint do przechowywania danych aplikacji i zarządzania nimi, a także użyć programu Access w celu zapewnienia logiki aplikacji.

  • Skalowalność    Plik Access może mieć maksymalny rozmiar 2 gigabajtów (GB). Chociaż 2 GB to znaczna ilość danych tekstowych, może być ona niewystarczająca w niektórych aplikacjach, szczególnie w aplikacjach zapisujących załączniki w rekordach bazy danych. Jeśli rozdzielisz dane i logikę, Twoja aplikacja może zmieścić więcej danych. Jeśli oczekujesz, że użytkownicy będą przechowywać duże ilości danych, warto rozważyć zastosowanie kilku plików danych Access.

    Aby uzyskać inne informacje o skalowalności, zapoznaj się ze specyfikacjami programu Access. Aby dowiedzieć się więcej Access specyfikacji programu Access,zobacz artykuł Specyfikacje programu Access.

  • Wydajność sieci    Jeśli wielu użytkowników będzie jednocześnie używać aplikacji w sieci, najprawdopodobniej wystąpi uszkodzenie danych, gdy dane i logika są połączone w jeden plik. Ponadto, jeśli połączysz dane i logikę w jednym pliku programu Access, nie możesz zoptymalizować ruchu sieciowego generowanego przez program Access. Jeśli wielu użytkowników będzie jednocześnie używać Twojej aplikacji w sieci, należy rozdzielić dane i wartość logiczną, stosując przynajmniej dwa pliki programu Access albo stosując produkt serwera bazy danych dla danych a programu Access do logiki aplikacji.

Do czego będzie podobne środowisko sieciowe?

Wybranie odpowiedniego rozwiązania bazy danych programu Access dla środowiska sieciowego jest kluczowym krokiem w kierunku jego sukcesu. Poniższe wskazówki pomogą Ci w wyborze najlepszej opcji do Twoich potrzeb.

Sieć domowa

Jeśli masz tylko kilku użytkowników do udostępnienia bazy danych programu Access, możesz użyć jednej bazy danych, z której każda osoba będzie korzystać w sieci domowej. Aby uzyskać więcej informacji, zobacz Udostępnianie plików przez sieć w systemie Windows 10.

Sieć lokalna (LAN)

Sieć LAN to sieć wewnętrzna o wysokiej wydajności, ale ograniczona do niewielkiego obszaru geograficznego, takiego jak pojedynczy pokój, budynek lub grupa budynków. Jeśli baza danych jest udostępniana przez kilku użytkowników w sieci LAN, najlepiej jest podzielić bazę danych, zapisać bazę danych w folderze sieciowym i wdrożyć kopię frontodanowej bazy danych dla każdego użytkownika.

Wide Area Network (WAN)

Istnieje wiele możliwych konfiguracji sieci WAN, która obejmuje obszerny obszar geograficzny. W mieście może być podłączonych wiele biur z siecią publiczną, dzierżawioną linią, a nawet z satelitarnym. Często wirtualna sieć prywatna (VPN) jest używana do bezpiecznego dostępu zdalnego z domu lub w podróży. Prostą sposobem zrozumienia sieci WAN jest to, że zawsze, gdy znajdujesz się poza siecią LAN, ale jest dołączona do sieci, używasz sieci WAN.

Ostrzeżenie    Unikaj używania podzielonej bazy danych programu Access w sieci WAN, ponieważ wydajność może być niska, a bazy danych mogą ulec uszkodzeniu.

Istnieją trzy obsługiwane sposoby korzystania z programu Access w sieci WAN:

  • Baza danych programu Access z tabelami połączonymi z listami programu SharePoint.

  • A front-end Access database connection to a backend SQL Server database or Azure SQL.

  • Usługi pulpitu zdalnego (RDS, Remote Desktop Services) (wcześniej nazwane jako serwer terminali), które tworzą wirtualne środowisko pulpitu systemu Windows na kliencie użytkownika. Rds ma kilka zalet:

    • Instalacja programu Access ani bazy danych programu Access nie jest wymagana, ponieważ użytkownicy uruchamiają klienta pulpitu zdalnego (RD), który jest dostępny na wielu urządzeniach.

    • Transfer danych między klientem a serwerem jest zminimalizowany, ponieważ RD to cienki klient, który wydajnie przesyła strumienie tylko do interfejsu użytkownika.

    • Użytkownicy nadal mogą kopiować i wklejać dane oraz drukować raporty lokalnie z komputera klienckiego.

    • Aplikacja RemoteApp może uruchamiać tylko jeden program, na przykład aplikację pod klucz dla dostawców lub pracowników pierwszej linii.

    Aby uzyskać więcej informacji, zobacz Usługi pulpitu zdalnego ( Zapraszamy!

Czy użytkownicy będą mieli Access?

Jeśli wszyscy Twoi użytkownicy zainstalują Access na swoich komputerach, będą mogli otworzyć i używać aplikacji, jak dowolnego pliku bazy danych Access.

Jeśli niektórzy lub wszyscy użytkownicy nie będą mieć zainstalowanych Access na swoich komputerach, możesz również wdrożyć oprogramowanie środowiska uruchomieniowego Access u tych użytkowników podczas wdrażania aplikacji. Aby uzyskać więcej informacji, zobacz Opis i pobieranie środowiska uruchomieniowego programu Access.

Początek strony

Wdrażanie aplikacji Access

Aby wdrożyć aplikację Access, należy wykonać następujące zadania.

Przygotowywanie bazy danych jako rozwiązania aplikacji

Aby zablokować rozwiązanie, sterować nawigacją i uruchamianiem oraz ustawić inne ważne opcje, wykonaj następujące czynności:

Zadanie

Więcej informacji

Zdecyduj, jak użytkownicy nawigują po interfejsie użytkownika: użyj formularza domyślnego, utwórz panel przełączania, użyj formularza nawigacji lub użyj hiperlinków i przycisków poleceń.

Ustawianie formularza domyślnego wyświetlanego po otwarciu bazy danych programu Access

Tworzenie formularza nawigacji

Dostosowywanie okienka nawigacji

Pokazywanie lub ukrywanie kart obiektów

Polecane szablony programu Access

Co się stało z panelami przełączania?

Zdecyduj, czy chcesz dostosować wstążkę pakietu Office i menu poleceń

Tworzenie niestandardowej wstążki w programie Access

Tworzenie menu niestandardowych i menu skrótów za pomocą makr

Używanie niestandardowych pasków narzędzi i ustawień uruchamiania z wcześniejszych wersji programu Access

Stosowanie spójnego motywu i tła pakietu Office

Dodawanie tła pakietu Office

Zmienianie motywu pakietu Office

Sterowanie uruchamianiem bazy danych

Dodawanie niestandardowego tytułu lub niestandardowej ikony do bazy danych

Pomijanie opcji uruchamiania podczas otwierania bazy danych

Tworzenie makra uruchamianego podczas otwierania bazy danych

Przełączniki wiersza polecenia dla produktów pakietu Microsoft Office

Ustawianie ważnych właściwości i opcji

Ustawianie właściwości i opcji uruchamiania w okniehttps://docs.microsoft.com/en-us/office/vba/access/concepts/settings/set-startup-properties-and-options-in-code

Wyświetlanie lub zmienianie właściwości pliku pakietu Office

Modyfikowanie ustawień regionalnych

Zmienianie ustawień regionalnych systemu Windows w celu zmodyfikowania wyglądu niektórych typów danych

Porada    Aby uzyskać dokładne informacje, przejrzyj okno dialogowe opcji programu Access(Opcje > pliku), a następnie kliknij pomoc dla każdej karty. Mogą być dostępne dodatkowe opcje, które chcesz kontrolować dla swojego rozwiązania aplikacji.

Przed wdrożeniem

Przed wdrożeniem frontoronowej bazy danych warto rozważyć następujące najlepsze rozwiązania:

Określanie używanego formatu pliku

Istnieją cztery formaty pliku Access, których możesz użyć podczas wdrażania aplikacji:

  • accdb    Jest to domyślny format pliku dla Access. Gdy wdrożysz aplikację w tym formacie, użytkownicy mają większość opcji do dostosowywania i nawigowania w aplikacji w dowolny wybrany przez nich sposób. Jeśli chcesz mieć pewność, że użytkownicy nie zmienią projektu Twojej aplikacji, należy użyć formatu pliku accde. Ponadto użytkownik nie może łatwo ustalić, czy plik accdb został zmieniony po opakowaniu go — aby było to oczywiste, użyj formatu pliku accdc.

  • accdc    Ten format jest również znany jako plik wdrożenia programu Access. Plik wdrożenia programu Access zawiera plik aplikacji i skojarzony z tym plikiem podpis cyfrowy. Ten format pliku gwarantuje użytkownikom, że nikt nie zmienił pliku aplikacji po jego opakowaniu. Ten format możesz zastosować do formatu domyślnego pliku Access (accdb) lub do skompilowanego pliku binarnego Access (accde). Aby uzyskać więcej informacji, zobacz Pokazywanie zaufania przez dodanie podpisu cyfrowego.

    W pliku wdrożenia programu Access można umieścić tylko jeden plik aplikacji. Jeśli Twoja aplikacja ma oddzielne pliki danych i logiki, możesz je opakować oddzielnie.

  • accde    Ten format jest również znany jako skompilowany plik binarny. W Access skompilowany plik binarny jest plikiem aplikacji bazy danych, który został zapisany z całym skompilowanym kodem języka VBA. Żaden kod źródłowy języka VBA nie pozostaje w skompilowanym pliku binarnym programu Access. Plik accde zapobiega zmianom projektu i kodu, zmniejsza rozmiar bazy danych i zwiększa wydajność. Aby uzyskać więcej informacji, zobacz Ukrywanie kodu VBA przed użytkownikami.

    Środowisko uruchomieniowe Access może służyć do otwierania skompilowanego pliku binarnego Access. Jeśli środowisko uruchomieniowe nie rozpoznaje rozszerzenia nazwy pliku accde, otwórz plik binarny, tworząc skrót, który wskazuje środowisko uruchomieniowe, i dołącz ścieżkę do skompilowanego pliku binarnego, który ma zostać otwarty przez ten skrót.

    Ważne   Użytkownicy nie mogą otworzyć skompilowanego pliku binarnego przy użyciu wcześniejszej wersji programu Access niż wersja, w której został skompilowany, jeśli wcześniejsza wersja nie obsługuje funkcji dodanej w nowszej wersji. Aby rozwiązać ten problem, skompilowanie pliku binarnego w wersji programu Access zainstalowanej przez użytkowników.

  • accdr    Ten format umożliwia wdrożenie aplikacji, która będzie otwierana w trybie środowiska uruchomieniowego. Wdrażanie aplikacji środowiska uruchomieniowego może pomóc kontrolować sposób jego używania, chociaż nie jest to środek zabezpieczania aplikacji. Aby uzyskać więcej informacji o trybie środowiska uruchomieniowego, zobacz sekcję Poznawanie środowiska uruchomieniowego programu Access.

Instalowanie i uaktualnianie frontodanowej bazy danych programu Access

W przypadku przyjęcia dzielonego projektu bazy danych należy rozpowszechnić frontową bazę danych u każdego użytkownika. Aby ułatwić sobie życie, warto rozważyć następujące najlepsze rozwiązania:

  • Upewnij się, że każdy użytkownik ma właściwą wersję programu Access i że fronto endowa baza danych zostanie otwarta we właściwej wersji. Program Access ma również wersje 32-bitowe i 64-bitowe. Uruchomienie nieprawidłowej "bitness" może mieć wpływ na wywołania interfejsu API systemu Windows, odwołania do bibliotek DLL i kontrolki ActiveX. Aby uzyskać więcej informacji, zobacz Wybór 64-bitowej lub 32-bitowej wersji pakietu Office.

  • Utwórz pakiet instalacyjny dla innych plików, które mogą być wymagane, w tym sterowników baz danych, plików wsadowych do instalacji i konfiguracji oraz plików związanych z aplikacją. Aby uzyskać więcej informacji, zobacz Tworzenie pakietu instalacyjnego.

  • Udostępnij skrót pulpitu systemu Windows, aby użytkownik może szybko uruchomić rozwiązanie programu Access. Dołącz do lokalizacji folderu skrótu opisową nazwę skrótu, opis i ikonę. Aby uzyskać więcej informacji, zobacz Tworzenie skrótu do programu lub pliku pakietu Office na pulpicie.

    Porada    Poinstruuj użytkowników, jak przypinać aplikacje do menu Start.

  • Określ skuteczny sposób ponownego rozsyłania i zamieniania frontonu bazy danych, gdy są wymagane aktualizacje, i przechowuj wersje plików w celu śledzenia zmian. Na przykład możesz dodać kod VBA, aby sprawdzać nowe wersje i automatycznie uaktualniać nawet przed uruchomieniem aplikacji przez użytkowników.

  • Gdy tworzysz połączenie ODBC przy użyciu pliku DSN zawierającego ciąg połączenia, ten plik DSN musi być również zainstalowany na każdym komputerze klienckim. Innym rozwiązaniem jest utworzenie połączenia "dsn-less" w kodzie VBA w celu wyeliminowania konieczności tworzenia pliku DSN. Aby uzyskać więcej informacji, zobacz korzystanie z usługi DSN-Less Connections.

Początek strony

Opis i pobieranie środowiska Access Runtime

Aby wdrożyć Access, które mogą działać bez instalacji programu Access na komputerze użytkownika, możesz je rozpowszechnić razem ze środowiskiem Access Runtime, które jest dostępne bezpłatnie w Centrum pobierania Microsoft. Po otwarciu bazy danych Access za pomocą środowiska uruchomieniowego Access baza danych jest otwierana w trybie środowiska uruchomieniowego.

Tryb środowiska uruchomieniowego to tryb pracy Access, w którym pewne funkcje Access nie są domyślnie dostępne. Jednak niektóre z tych niedostępnych funkcji można udostępnić w trybie środowiska uruchomieniowego.

Jakie funkcje nie są dostępne w trybie środowiska uruchomieniowego?

Poniższe funkcje Access nie są dostępne w trybie środowiska uruchomieniowego:

  • Klawisze specjalne    Klawisze Ctrl+Break, Ctrl+G i shift, które pomijają opcje uruchamiania w bazie danych.

  • Okienko nawigacji    Okienko nawigacji nie jest dostępne w trybie środowiska uruchomieniowego. Dzięki temu użytkownicy nie mogą uzyskiwać dostępu do dowolnych obiektów w Twojej aplikacji bazy danych. W trybie środowiska uruchomieniowego można otwierać tylko te obiekty, które są ujawniane użytkownikom — na przykład przez udostępnienie formularza nawigacji. Nie można udostępnić okienka nawigacji w trybie środowiska uruchomieniowego.

  • Wstążka    Domyślnie wstążka nie jest dostępna w trybie środowiska uruchomieniowego. Zapobiega to tworzeniu lub modyfikowaniu przez użytkowników obiektów bazy danych i wykonywaniu innych potencjalnie niebezpiecznych akcji, takich jak łączenie się z nowymi źródłami danych lub eksportowanie danych w sposób, który nie został przewidziany. Nie możesz udostępnić domyślnych kart wstążki w trybie środowiska uruchomieniowego. Można jednak utworzyć niestandardową Wstążkę, a następnie skojarzyć ją z formularzem lub raportem. Aby uzyskać więcej informacji, zobacz Tworzenie niestandardowej wstążki w programie Access.

  • Widok projektu i widoku układu    W trybie środowiska uruchomieniowego widok projektu i widok układu nie są dostępne dla dowolnego obiektu bazy danych. Dzięki temu użytkownicy nie mogą modyfikować projektu obiektów w aplikacji bazy danych. Widoku projektu lub układu nie można włączyć w trybie środowiska uruchomieniowego.

  • Pomoc    Zintegrowana pomoc nie jest domyślnie dostępna w trybie środowiska uruchomieniowego. Ponieważ kontrolujesz, jakie funkcje są dostępne w aplikacji w trybie środowiska uruchomieniowego, niektóre zintegrowane elementy standardowej pomocy Access mogą być nieodpowiednie dla osób używających aplikacji i potencjalnie mogą je mylić lub frustrować. Możesz utworzyć własny niestandardowy plik Pomocy w celu uzupełnienia aplikacji w trybie środowiska uruchomieniowego.

Jak mogę symulować tryb środowiska uruchomieniowego?

W trybie środowiska uruchomieniowego możesz uruchomić dowolną bazę danych Access na komputerze, który ma zainstalowaną pełną wersję Access. Aby uruchomić bazę danych Access w trybie środowiska uruchomieniowego, wykonaj jedną z następujących czynności:

  • Zmień rozszerzenie nazwy pliku bazy danych z accdb na accdr.

  • Utwórz skrót do bazy danych za pomocą przełącznika wiersza polecenia /Runtime.

    1. Na komputerze z systemem Windows kliknij prawym przyciskiem myszy i wybierz pozycję Nowy > skrót.

    2. Wprowadź lokalizację MSAccess.exe, lokalizację bazy danych i kwalifikator poleceń /runtime. Przykład:

      "C:\Program Files\Microsoft Office\MSACCESS.EXE" "C:\MyDB.accdb" /runtime

    Aby uzyskać więcej informacji, zobacz Tworzenie skrótu do programu lub pliku pakietu Office na pulpicie.

Czy tryb środowiska uruchomieniowego powoduje, że moja baza danych jest bezpieczniejsza?

Chociaż tryb środowiska uruchomieniowego ogranicza dostępność do funkcji nawigacji i projektowania, nie należy używać trybu środowiska uruchomieniowego jako podstawowego środka ochrony aplikacji bazy danych. Na komputerze mającym zainstalowaną pełną wersję Access użytkownik może mieć możliwość otwarcia aplikacji bazy danych w środowisku uruchomieniowym jak zwykłej aplikacji bazy danych (czyli z dostępem do wszystkich funkcji), a następnie zmiany projektu lub wykonania innych niepożądanych akcji.

Nawet jeśli wdrożysz aplikację bazy danych tylko na komputerach, które nie mają zainstalowanej pełnej wersji Access, użytkownik nadal może przesłać aplikację na komputer, który ma zainstalowaną pełną wersję Access, a następnie otworzyć aplikację bazy danych w środowisku uruchomieniowym jako zwykłą aplikację bazy danych.

Początek strony

Pobieranie środowiska uruchomieniowego Access

Uwaga: W przypadku programu Access 2019 Enterprise nie pobieraj ani nie instaluj środowiska uruchomieniowego — to spowoduje zastąpienie Pełnej wersji programu Access tylko środowiskiem uruchomieniowym. Zamiast tego użyj Narzędzia wdrażania pakietu Office, aby określić, że produkt AccessRuntimeRetail jest zainstalowany.

Aby pobrać środowisko uruchomieniowe Access z Centrum pobierania Microsoft, kliknij link odpowiedni dla Twojej wersji. 

Zakup nie jest konieczny do pobrania, używania lub redystrybucji środowiska uruchomieniowego Access i nie ma ograniczenia liczby użytkowników, do których możesz dystrybuować środowisko uruchomieniowe.

Początek strony

Tworzenie pakietu instalacyjnego

Istnieje kilka sposobów, które możesz podjąć w zależności od wersji programu Access.

Używanie ogólnego pakietu instalacyjnego (program Access 2013 lub nowszy)

w przypadku programu Access w wersji 2013 lub nowszej możesz użyć programu Instalator Windows lub wyszukać program innej firmy, który tworzy pakiety instalacyjne.

Spakować i podpisać Access bazy danych (Access 2007 i 2010)

W programie Access 2007 lub 2010 podpisywanie i rozpowszechnianie bazy danych jest łatwiejsze i szybsze. Po utworzeniu pliku accdb lub accde można go spakować, opatrzyć podpisem cyfrowym, a następnie rozpowszechnić w celu udostępnienia innym użytkownikom. Funkcja Spakuj i podpisz umieszcza bazę danych w pliku wdrażania programu Access (accdc), podpisuje plik, a następnie umieszcza pakiet z podpisanym kodem w wybranej lokalizacji na komputerze użytkownika. Użytkownicy mogą następnie wyodrębniać bazę danych z pakietu i pracować bezpośrednio w bazie danych (nie w pliku pakietu). Aby uzyskać więcej informacji, zobacz Omówienie Kreatora pakietu rozwiązania.

Uwaga: Funkcja opisana w tej sekcji pakuje plik Access i dodaje do pakietu podpis cyfrowy, który pomaga wskazać użytkownikom, że plik jest godny zaufania.

Podczas kontynuowania tworzenia i podpisywania pakietu pamiętaj o następujących kwestiach:

  • Pakowanie bazy danych i podpisywanie pakietu to sposoby przekazywania informacji o zaufaniu. Gdy Ty lub Twoi użytkownicy otrzymają pakiet, podpis potwierdza, że baza danych nie została naruszona. Jeśli ufasz autorowi, możesz włączyć zawartość.

  • Funkcja Spakuj i podpisz ma zastosowanie tylko do baz danych zapisanych w formacie pliku accdb.

  • Do pakietu można dodać tylko jeden plik bazy danych.

  • Podczas pakowania i tworzenia bazy danych wszystkie obiekty w bazie danych mają podpisany kod, a nie tylko makra lub moduły kodu. Proces pakowania i podpisywania również kompresuje plik pakietu, pomagając skrócić czasy pobierania.

  • Po wyodrębnieniu bazy danych z pakietu nie ma już połączenia między podpisanym pakietem i wyodrębnioną bazą danych.

  • Jeśli podpiszesz pakiet bazy danych za pomocą certyfikatu z podpisem własnym, a następnie podczas otwierania tego pakietu klikniesz pozycję Zawsze ufaj zawartości od tego wydawcy, to pakiety podpisane za pomocą certyfikatów z podpisami własnymi zawsze będą zaufane.

  • Jeśli wyodrębnisz bazę danych do zaufanej lokalizacji, jej zawartość będzie automatycznie włączana przy każdym otwarciu. Jeśli wybierzesz lokalizację, która nie jest zaufana, pewna część zawartości bazy danych może zostać domyślnie wyłączona.

W poniższych sekcjach wyjaśniono, jak utworzyć podpisany plik pakietu oraz jak korzystać z bazy danych w podpisanym pliku pakietu. Aby wykonać te kroki, musisz mieć dostępny co najmniej jeden certyfikat zabezpieczeń. Jeśli nie masz zainstalowanego certyfikatu na komputerze, możesz go utworzyć za pomocą narzędzia SelfCert lub uzyskać certyfikat komercyjny. Aby uzyskać informacje na temat certyfikatów zabezpieczeń, zobacz Pokazywanie zaufania przez dodanie podpisu cyfrowego.

Tworzenie podpisanego pakietu

  1. Otwórz bazę danych, którą chcesz spakować i podpisać.

  2. Kliknij kartę Plik, a następnie kliknij pozycję Zapisz jako.

  3. W obszarze Typy plików bazy danych kliknij pozycję Spakuj i podpisz, a następnie kliknij pozycję Zapisz jako.

  4. W oknie dialogowym Wybierz certyfikat wybierz certyfikat cyfrowy, a następnie kliknij przycisk OK.

    Zostanie wyświetlone okno dialogowe Tworzenie podpisanego pakietu programu Microsoft Office Access.

  5. Na liście Zapisz w wybierz lokalizację, w której chcesz umieścić podpisany pakiet bazy danych.

  6. W polu Nazwa pliku wprowadź nazwę dla podpisanego pakietu, a następnie kliknij pozycję Utwórz.

    Program Access utworzy plik accdc i umieści go w wybranej lokalizacji.

Wyodrębnianie i używanie podpisanego pakietu

  1. Kliknij pozycję Plik > Otwórz.

  2. W oknie dialogowym Otwieranie wybierz pozycję Podpisane pakiety programu Access pakietu Microsoft Office (*.accdc) jako typ pliku.

  3. Na liście Szukaj w znajdź folder zawierający Twój plik accdc, zaznacz ten plik, a następnie kliknij przycisk Otwórz.

  4. Wykonaj jedną z następujących czynności:

    • Jeśli certyfikat cyfrowy, który został zastosowany do pakietu wdrożenia, został uznany za zaufany, zostanie wyświetlone okno dialogowe Wyodrębnianie bazy danych do. Przejdź do kroku 5.

    • Jeśli jeszcze nie ufasz certyfikatowi cyfrowemu, zostanie wyświetlona wskazówka.

      Wskazówka

      Jeśli baza danych jest zaufana, kliknij pozycję Otwórz. Jeśli wszystkie certyfikaty od tego dostawcy są zaufane, kliknij pozycję Zawsze ufaj zawartości od tego wydawcy. Zostanie wyświetlone okno dialogowe Wyodrębnianie bazy danych do.

  5. Opcjonalnie na liście Zapisz w wybierz lokalizację, w której chcesz umieścić wyodrębnioną bazę danych, a następnie w polu Nazwa pliku wprowadź inną nazwę dla wyodrębnionej bazy danych.

Początek strony

Ace nie wymaga już osobnej instalacji do współdziałania z aplikacjami niebędacymi pakietem Office

DO OPRACOWANIA PÓŹNIEJ

Początek strony

Space

Space

Space

Space

Space

Space

Space

Space

Kosmos

Potrzebna dalsza pomoc?

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

×