Zliczanie znaków w komórkach

Jeśli chcesz zliczyć znaki w komórkach, użyj funkcji DŁ,która zlicza litery, cyfry, znaki i wszystkie spacje. Na przykład długość tekstu „Dziś jest 25 stopni, więc pójdę popływać” (bez znaków cudzysłowu) wynosi 40 znaków — 31 liter, 2 cyfry, 6 spacji i 1 przecinek.

Aby użyć tej funkcji, wprowadź formułę =DŁ(komórka) na pasku formuły, a następnie naciśnij klawisz Enter na klawiaturze.

Wiele komórek: Aby zastosować tę samą formułę do wielu komórek, wprowadź formułę w pierwszej komórce, a następnie przeciągnij uchwyt wypełniania w dół (lub przez) zakres komórek.

Wprowadzanie wielu funkcji DŁ w arkuszu

Aby uzyskać całkowitą liczbę wszystkich znaków w kilku komórkach, użyj funkcji SUMA razem z funkcjami DŁ. W tym przykładzie funkcja DŁ zlicza znaki w każdej komórce, a funkcja SUMA dodaje je do siebie:

=SUMA((DŁ(komórka1);DŁ( komórka2 );(DŁ( komórka3 )) )).

Spróbuj użyć tej funkcji

Oto kilka przykładów, które pokazują, jak używać funkcji DŁ.

Skopiuj tabelę poniżej i wklej ją w komórce A1 w Excel arkusza. Przeciągnij formułę z komórki B2 do komórki B4, aby zobaczyć długość tekstu we wszystkich komórkach w kolumnie A.

Ciągi tekstowe

Formuły

Szybki brązowy lis.

=DŁ(A2)

Szybki brązowy lis przeskoczył.

Szybki brązowy lis przeskoczył leniwego psa.

Zliczanie znaków w jednej komórce

  1. Kliknij komórkę B2.

  2. Wprowadź =DŁ(A2).

Formuła zlicza znaki w komórce A2, czyli łącznie do 27 (co obejmuje wszystkie spacje i okres na końcu zdania).

UWAGA: Zlicza wszystkie spacje po ostatnim znaku.
 

Zliczanie znaków w wielu komórkach

  1. Kliknij komórkę B2.

  2. Naciśnij klawisze Ctrl+C, aby skopiować komórkę B2, zaznacz komórki B3 i B4, a następnie naciśnij klawisze Ctrl+V, aby wkleić tę formułę do komórek B3:B4.

Formuła jest kopiowana do komórek B3 i B4, a funkcja zlicza znaki w poszczególnych komórkach (20, 27 i 45).

Zliczanie całkowitej liczby znaków

  1. W przykładowym skoroszycie kliknij komórkę B6.

  2. W komórce wprowadź formułę =SUMA(DŁ(A2);DŁ(A3);DŁ(A4)) i naciśnij klawisz Enter.

Ta wartość zlicza znaki w każdej z trzech komórek i sumuje je (92).

Potrzebna dalsza pomoc?

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

×