Tworzenie wykazu seryjnego

Dotyczy
Publisher dla Microsoft 365 Publisher 2021 Publisher 2019 Publisher 2016 Publisher 2013 Publisher 2010

Program Publisher umożliwia połączenie się ze źródłem danych, takim jak baza danych, arkusz kalkulacyjny czy nawet plik tekstowy, i używanie tych danych do łatwego tworzenia katalogu produktów i usług. Wykazu seryjnego można również użyć do tworzenia katalogów, albumów fotograficznych lub innych publikacji, w których jeden lub więcej elementów jest wyświetlanych na każdej stronie.

Jak działa wykaz seryjny

Wykaz seryjny jest podobny do korespondencji seryjnej. Wykaz seryjny polega na utworzeniu publikacji szablonu wykazu seryjnego, a następnie połączeniu szablonu z informacjami ze źródła danych w celu wygenerowania scalonych stron.

Źródło danych łączone z szablonem scalania w celu wygenerowania stron wykazu

1 Źródło danych z informacjami o rekordach, takimi jak nazwy i opisy elementów.

2 Publikacja szablonu wykazu seryjnego z obszarem wykazu seryjnego i polami korespondencji seryjnej będącymi symbolami zastępczymi dla informacji o rekordzie.

3 Wynikowe scalone strony z wyświetlonymi wieloma rekordami na stronę.

Wykaz seryjny można zapisać jako nową publikację lub dodać go na końcu istniejącej publikacji. Możesz również zapisać szablon wykazu seryjnego i używać go ponownie po zaktualizowaniu informacji w źródle danych, aby utworzyć dodatkowe zestawy scalonych stron.

Przed rozpoczęciem

Poniższe porady ułatwią utworzenie udanego wykazu seryjnego:

  • Rozpoczynanie wykazu seryjnego w nowej publikacji.

  • Oprócz stron, takich jak strona tytułowa, spis treści czy formularze zamówienia, należy przeznaczyć jedną stronę na pola korespondencji seryjnej, nawet wykaz, który prawdopodobnie będzie zawierał wiele stron po utworzeniu scalonego dokumentu.

  • Skonfiguruj szablon wykazu seryjnego, używając odpowiednich wymiarów stron dla końcowych scalonych stron.

  • Jeśli zamierzasz dodać utworzone scalone strony na końcu istniejącej publikacji, upewnij się, że szablon wykazu seryjnego jest zgodny z istniejącą publikacją pod następującymi względami:

    • Rozmiar stron (wysokość i szerokość)
    • Widok strony (widok jednej strony lub widok dwóch stron)
    • Typ publikacji (sieć Web lub druk)
    • Kolejność stron (od lewej do prawej lub od prawej do lewej)

Początek strony

Planowanie katalogu

Przed rozpoczęciem tworzenia wykazu seryjnego zastanów się, jakie informacje mają się znaleźć na końcowych scalonych stronach.

  • Chcesz wyświetlić listę nazw i cen przedmiotów?
  • Czy chcesz dołączyć opis każdego elementu?
  • Czy chcesz dołączyć obraz każdego elementu?

Planowanie źródła danych

Po podjęciu decyzji dotyczącej rodzaju informacji zawartych w wykazie można utworzyć źródło danych, które będzie używane w wykazie seryjnym. Jeśli masz już źródło danych, możesz się upewnić, że zawiera ono wszystkie informacje, które mają zostać uwzględnione w korespondencji seryjnej.

W wykazie seryjnym programu Publisher można używać różnych formatów źródeł danych. Jeśli nie masz jeszcze źródła danych do użycia na potrzeby korespondencji seryjnej, możesz je wygenerować w programie Publisher. Źródło danych można również utworzyć w arkuszu programu Microsoft Office Excel lub w tabeli programu Microsoft Office Word.

Pola danych zawarte w źródle danych odpowiadają polom korespondencji seryjnej wstawionym do szablonu wykazu seryjnego.

Po skonfigurowaniu źródła danych utwórz kolumnę dla każdego typu informacji, takiego jak nazwa towaru, numer magazynowy i cena. Każdy wiersz, czyli rekord, odpowiada informacjom dotyczącym jednego elementu.

Ważne Upewnij się, że źródło danych zawiera pole lub kolumnę danych dla każdego rodzaju informacji do scalenia. W zależności od typu źródła danych po połączeniu się z nim w programie Publisher może być możliwe wprowadzenie pewnych zmian w danych, ale lepiej jest sfinalizować informacje przed rozpoczęciem.

Jeśli zamierzasz scalić fotografie ze stronami katalogu, musisz uwzględnić kolumnę ze ścieżką do każdego pliku obrazu, którego zamierzasz użyć. Nie umieszczaj w źródle danych obrazów lub ilustracji jako takich.

Jeśli planujesz utworzenie źródła danych w programie Publisher, możesz to zrobić po utworzeniu szablonu publikacji.

Początek strony

Tworzenie szablonu publikacji

Teraz możesz utworzyć publikację szablonu wykazu seryjnego, w której zaprojektujesz układ ostatecznych scalonych stron. Po zakończeniu korespondencji seryjnej można za pomocą tego szablonu wykazu seryjnego wygenerować scalone strony, które można zapisać jako nową publikację lub dodać na końcu istniejącej publikacji.

Szablon wykazu seryjnego powinien mieć taki sam układ (rozmiar i orientację) jak w przypadku stron korespondencji seryjnej. Powinna również zawierać tekst lub grafikę, które mają być wyświetlane na każdej stronie końcowej publikacji, na przykład obraz tła lub nazwę i numer telefonu firmy. Najlepszym rozwiązaniem jest użycie strony wzorcowej dla tych elementów szablonu korespondencji seryjnej.

Jeśli zamierzasz dodać scalone strony na końcu istniejącej publikacji, upewnij się, że szablon wykazu seryjnego jest zgodny z istniejącą publikacją pod następującymi względami:

  • Rozmiar stron (wysokość i szerokość)
  • Widok strony (widok jednej strony lub widok dwóch stron)
  • Typ publikacji (sieć Web lub druk)
  • Kolejność stron (od lewej do prawej lub od prawej do lewej)

Tworzenie szablonu wykazu seryjnego

  1. Wybierz szablon publikacji odpowiedni dla danego katalogu.
  2. Na karcie Wstawianie kliknij pozycję Strony wykazu.
    Rozpoczynanie scalania stron wykazu
  3. Strony wykazu zostaną utworzone z domyślnym obszarem wykazu seryjnego, a na wstążce pojawi się karta Narzędzia wykazu. W tej chwili możesz dowolnie umieścić obszar wykazu seryjnegona stronie i dodać dowolny tekst lub obrazy, które mają być wyświetlane na każdej stronie katalogu. Im mniejszy obszar scalania, tym więcej elementów wykazu można scalić ze stroną. Na przykład obszar scalania 2"x2" będzie powtarzany więcej razy niż obszar scalania 4"x4". Nie martw się zbytnio o to, aby wszystko było w porządku, ponieważ w dowolnym momencie możesz wrócić i edytować te elementy.
    Porada Nie konfiguruj w tym momencie obszaru wykazu seryjnego. Poczekaj, aż nadejdzie czas na wstawienie pól korespondencji seryjnej, i użyj jednego z gotowych projektów z galerii układów.

Początek strony

Nawiązywanie połączenia ze źródłem danych

Kolejnym krokiem po sformatowaniu strony szablonu wykazu seryjnego jest utworzenie lub zlokalizowanie źródła danych i nawiązanie z nim połączenia. To, którą opcję należy wybrać w następnej kolejności, zależy od tego, czy masz już źródło danych, czy też chcesz utworzyć nową listę w programie Publisher.

  1. Na karcie Narzędzia wykazu kliknij pozycję Dodaj listę i wykonaj jedną z następujących czynności:

    • Wybierz pozycję Wpisz nową listę, jeśli chcesz utworzyć źródło danych dla korespondencji seryjnej.
    • Kliknij pozycję Użyj istniejącej listy, jeśli masz już źródło danych, którego chcesz użyć.
    • Kliknij pozycję Wybierz z kontaktów programu Outlook, jeśli chcesz utworzyć katalog kontaktów.

Wpisywanie nowej listy

  1. W oknie dialogowym Nowa lista produktów wpisz informacje dotyczące pierwszego elementu lub rekordu, który chcesz umieścić w katalogu.
    Jeśli chcesz dodać lub usunąć kolumny — na przykład jeśli nie widzisz obrazów — kliknij pozycję Dostosuj kolumny, a następnie wprowadź odpowiednie zmiany.
  2. Po wpisaniu wszystkich informacji dotyczących pierwszego rekordu kliknij przycisk Nowa pozycja, a następnie wpisz informacje dotyczące następnego rekordu. Powtarzaj te czynności do momentu wpisania informacji dotyczących wszystkich rekordów, które mają zostać dołączone.
  3. Po zakończeniu tworzenia nowej listy kliknij przycisk OK.
  4. W oknie dialogowym Zapisywanie listy adresów wpisz nazwę nowej listy, a następnie kliknij przycisk Zapisz.

Użycie istniejącej listy

  1. W oknie dialogowym Wybieranie źródła danych zlokalizuj i kliknij odpowiednie źródło danych.
    Program Publisher domyślnie zapisuje źródła danych w folderze Moje źródła danych. W celu znalezienia źródła danych może być konieczne przejście do folderu Moje źródła danych.
  2. Kliknij przycisk Otwórz.
    W zależności od wybranego typu źródła danych mogą zostać wyświetlone inne okna dialogowe z monitami o podanie konkretnych informacji. Jeśli na przykład źródłem danych jest arkusz programu Excel zawierający informacje o wielu kartach, wybierz kartę zawierającą żądane informacje, a następnie kliknij przycisk OK.

Wybieranie danych z kontaktów programu Outlook

  1. Wykonaj jedną z następujących czynności:

    • W oknie dialogowym Wybieranie kontaktów kliknij listę kontaktów, których chcesz użyć.
    • W oknie dialogowym Wybieranie profilu wybierz profil kontaktów, których chcesz użyć.
  2. Kliknij przycisk OK.

Dodawanie kolejnych list

Jeśli w wykazie seryjnym chcesz użyć więcej niż jednej listy, możesz dodać listy.

  1. Kliknij przycisk Edytuj listę, a następnie na liście produktów w wykazie seryjnym w obszarze Dodaj do listy produktów kliknij pozycję Wybierz istniejącą listę, Wybierz z kontaktów programu Outlook lub Wpisz nową listę.
    Program Publisher wyświetli monit o skorygowanie niezgodności między polami na różnych listach źródłowych po otwarciu okna dialogowego Dodaj do listy produktów.
  2. W oknie dialogowym Dodaj do listy produktów zaznacz pole, które nie jest zaznaczone w kolumnie Dopasowane, wybierz pole, któremu ma ono odpowiadać, na liście Pola listy produktów z dopasowanymi polami, a następnie kliknij przycisk Podaj.
  3. W oknie dialogowym Dopasowywanie pola sprawdź, czy wybrane pole znajduje się na liście pozycji Dopasuj do pola listy produktów lub wybierz inne pole, a następnie kliknij przycisk OK.
  4. Jeśli chcesz dodać nowe pole do listy adresatów w celu dopasowania, zaznacz pole, które chcesz dodać do nowej listy (lista po lewej w oknie dialogowym Dodaj do listy adresatów), kliknij przycisk Dodaj, a następnie kliknij przycisk OK.
    Dodane pola są wyświetlane w obszarze Nowe pola do dodania do listy adresatów

Wybierz rekordy, które chcesz uwzględnić

  1. Kliknij przycisk Edytuj listę.

  2. W oknie dialogowym Wykaz seryjny lista produktów wykonaj jedną z następujących czynności:

    • Zaznacz pola wyboru obok rekordów, które chcesz uwzględnić, i wyczyść pola wyboru obok rekordów, które chcesz wykluczyć.
      Porada Aby uwzględnić tylko kilka rekordów listy, kliknij przycisk Wyczyść wszystko, a następnie zaznacz odpowiednie rekordy.

    • Przefiltruj listę według określonego kryterium, klikając strzałkę obok nagłówka kolumny elementu, według którego chcesz filtrować listę, a następnie klikając wartość, która ma być używana jako filtr.

      • (Puste)wyświetla wszystkie rekordy, w których odpowiednie pole jest puste.
      • (Niepuste) — wyświetla wszystkie rekordy, w których odpowiednie pole zawiera jakieś informacje.
        Wskazówka Jeśli źródło danych zawiera rekordy, w których znajdują się te same informacje, a kolumna zawiera najwyżej dziesięć unikatowych wartości, możesz filtrować dane według konkretnych informacji. Jeśli na przykład źródłem danych jest lista nieruchomości na sprzedaż i istnieje wiele rekordów nieruchomości, które wskazują miasto lub lokalizację Buffalo, możesz filtrować według miasta lub lokalizacji.
        W oknie dialogowym Lista produktów wykazu seryjnego zostaną wyświetlone tylko wskazane rekordy. Aby wyświetlić ponownie wszystkie rekordy, kliknij pozycję (Wszystkie).
    • Posortuj elementy na liście, klikając nagłówek kolumny elementu, według którego chcesz sortować. Jeśli na przykład chcesz wyświetlić listę sortowaną alfabetycznie według miasta/lokalizacji, kliknij nagłówek kolumny Miasto/Lokalizacja.

  3. Kliknij przycisk OK.

Początek strony

Wstawianie pól korespondencji seryjnej

Nadszedł czas na rozmieszczenie informacji, które mają być wyświetlane w publikacji. Aby określić układ strony, dodaj pola korespondencji seryjnej do obszaru wykazu seryjnego. Każde pole korespondencji seryjnej reprezentuje kolumnę w źródle danych, a w obszarze wykazu seryjnego jest wyświetlany sposób wyświetlania informacji zawartych w pojedynczym rekordzie.

Obszar wykazu seryjnego można rozmieścić w odpowiedni sposób, a następnie określić liczbę powtórzeń tego obszaru na każdej stronie. Możesz na przykład wyświetlić cztery elementy na każdej stronie. Każdy element zostanie wyświetlony w ten sam sposób, w zależności od sposobu rozmieszczenia obszaru wykazu seryjnego. Możesz dostosować rozmiar każdego elementu oraz zmienić rozmiar obszaru wykazu seryjnego.

Ważne Jeśli pola korespondencji seryjnej zostaną wstawione poza obszarem wykazu seryjnego, nie będą one powtarzane po ukończeniu korespondencji seryjnej.

Wybieranie układu obszaru korespondencji seryjnej

  1. W grupie Układ wykonaj jedną z następujących czynności:

    • Wybierz z jednej z galerii gotowych projektów.
      Opcje układu wykazu seryjnego
    • Wybierz liczbę wierszy i kolumn na każdej stronie z listy rozwijanej Wiersze i kolumny.
      Wiersze i kolumny w układzie strony wykazu

Wstawianie tekstu pól korespondencji seryjnej w obszarze wykazu seryjnego

  1. Kliknij przycisk Pole tekstowe, a następnie kliknij pierwsze pole korespondencji seryjnej, które chcesz wstawić.
    Wstawianie pól tekstowych w wykazie seryjnym

  2. W obszarze wykazu seryjnego zaznacz pole korespondencji seryjnej, a następnie przenieś to pole korespondencji seryjnej i zmień jego rozmiar, wykonując następujące czynności:

    • Aby przenieść pole korespondencji seryjnej, umieść wskaźnik myszy na polu korespondencji seryjnej, aż wskaźnik zmieni się we wskaźnik przenoszenia Wskaźnik przenoszenia , a następnie przeciągnij pole korespondencji seryjnej w nowe miejsce.
    • Aby zmienić rozmiar pola korespondencji seryjnej, umieść wskaźnik myszy na jednym z uchwytów zmiany rozmiaru w polu tekstowym lub ramce obrazu, aż wskaźnik zmieni się we wskaźnik zmiany rozmiaru Przesuwanie wskaźników linijki , a następnie przeciągaj myszą do momentu uzyskania odpowiedniego rozmiaru ramki pola tekstowego lub obrazu.
  3. Kliknij poza polem korespondencji seryjnej, aby nie było już zaznaczone.

  4. Powtarzaj kroki od 1 do 3 do momentu wstawienia wszystkich potrzebnych pól ze źródła danych.

Ważne Pola są wstawiane w bieżącym punkcie wstawiania (migający kursor punktu wstawiania). Jeśli nie ma punktu wstawiania, zostanie utworzone nowe pole tekstowe, a pole korespondencji seryjnej zostanie umieszczone w tym nowym polu tekstowym.

Formatowanie tekstu pól korespondencji seryjnej

Dane scalonego wykazu można sformatować, formatując pola korespondencji seryjnej w szablonie wykazu seryjnego. Te pola mogą być traktowane jak pola tekstowe i można uwzględniać niescalony tekst i formatowanie również scalone elementy.

  1. W szablonie wykazu seryjnego zaznacz pole zawierające informacje, które chcesz sformatować, łącznie z otaczającymi je znakami pól korespondencji seryjnej («« »»).
  2. Na karcie Narzędzia pól tekstowych wybierz odpowiednie opcje.

Wstawianie pól korespondencji seryjnej obrazów w obszarze wykazu seryjnego

  1. Kliknij przycisk Pole obrazu i kliknij pierwsze pole korespondencji seryjnej, które chcesz wstawić.

  2. W obszarze wykazu seryjnego zaznacz pole korespondencji seryjnej, a następnie przenieś to pole korespondencji seryjnej i zmień jego rozmiar, wykonując następujące czynności:

    • Aby przenieść pole korespondencji seryjnej, umieść wskaźnik myszy na polu korespondencji seryjnej, aż wskaźnik zmieni się we wskaźnik przenoszenia Przenieś kursor , a następnie przeciągnij pole korespondencji seryjnej w nowe miejsce.
    • Aby zmienić rozmiar pola korespondencji seryjnej, umieść wskaźnik myszy na jednym z uchwytów pola tekstowego lub ramki obrazu i poczekaj, aż wskaźnik zmieni się we wskaźnik zmianyrozmiaru Kursor zmiany rozmiaru , a następnie przeciągaj myszą do momentu uzyskania odpowiedniego rozmiaru ramki pola tekstowego lub obrazu.
  3. Kliknij poza polem korespondencji seryjnej, aby nie było już zaznaczone.

  4. Powtarzaj kroki od 1 do 3 do momentu wstawienia wszystkich potrzebnych pól ze źródła danych.

Ważne Pola są wstawiane w bieżącym punkcie wstawiania (migający kursor punktu wstawiania). Jeśli nie ma punktu wstawiania, zostanie utworzone nowe pole tekstowe, a pole korespondencji seryjnej zostanie umieszczone w tym nowym polu tekstowym.

Przenoszenie lub zmienianie rozmiaru obszaru wykazu seryjnego

Jeśli sformatowane pola korespondencji seryjnej nie mieszczą się już w obszarze wykazu seryjnego, możesz zmienić jego rozmiar.

Wskazówka W przypadku zwiększenia rozmiaru może być konieczne zmieszczenie mniejszej liczby elementów lub rekordów na każdej stronie.

  1. Kliknij obszar wykazu seryjnego, aby go zaznaczyć.
  2. Umieść wskaźnik myszy na jednym z uchwytów w obszarze wykazu seryjnego, a następnie przeciągnij myszą.
  3. Określ, ile elementów ma się znaleźć na każdej stronie, wpisując odpowiednie liczby elementów wzdłuż i w poprzek strony na pasku narzędzi Układ wykazu seryjnego.

Kończenie i wyświetlanie podglądu szablonu

  1. Kliknij przycisk Podgląd wyników.
  2. Kliknij strzałki, aby wyświetlić poszczególne strony scalonych danych.
    Grupa podglądu wykazu
    Jeśli nie chcesz uwzględniać elementu, kliknij element, którego podgląd został wyświetlony, a następnie kliknij pozycję Wyklucz wpis w grupie Strona podglądu.

Początek strony

Complete, print and save your catalog publication

Dostępne są trzy opcje ukończenia scalania:

  • Scaloną publikację można wydrukować bezpośrednio.
  • Możesz utworzyć i wydrukować nową publikację zawierającą scaloną zawartość. Zawartość tej publikacji można zmieniać w taki sam sposób jak każdą inną publikację w programie Publisher.

Porada Jeśli chcesz uwzględnić w publikacji wiele wykazów seryjnych, musisz utworzyć nową publikację dla scalonych stron, ponieważ publikacja może mieć tylko jeden zestaw stron wykazu.

  • Scaloną zawartość można dodać do istniejącej publikacji.

Jeśli chcesz dodać przednią i tylną okładkę do publikacji lub jeśli chcesz dodać inne strony, musisz utworzyć nową publikację lub dodać zawartość do istniejącej publikacji.

Scalanie z nową publikacją

Jeśli chcesz edytować scalone strony, zapisać je do późniejszego użytku lub wydrukować je później, możesz zebrać wszystkie scalone strony i zapisać je jako jedną nową scaloną publikację zawierającą rzeczywiste dane — na przykład nazwy produktów i ceny — zamiast pól scalania.

  1. W grupie Scalanie kliknij przycisk Scal z nowym.
    Dołączanie wykazu seryjnego do nowej publikacji
    Program Publisher utworzy nową publikację, którą można zapisać i edytować. Możesz nawet dodać przednią i tylną stronę tytułową.
     Uwaga Jeśli zamierzasz wydrukować katalog jako broszurę, upewnij się, że całkowita liczba stron jest wielokrotnością czterech.
  2. W okienku zadań Wykaz seryjny kliknij pozycję Zapisz publikację.
  3. W polu Nazwa pliku wpisz nazwę nowej publikacji, a następnie kliknij przycisk Zapisz.
  4. W razie potrzeby zapisz też wszelkie zmiany wprowadzone w szablonie wykazu seryjnego. Przy każdej aktualizacji informacji w źródle danych można ponownie użyć tego szablonu wykazu seryjnego do tworzenia dodatkowych scalonych stron.

Dodawanie do istniejącej publikacji

Jeśli masz już skonfigurowane okładki w osobnej publikacji lub jeśli chcesz umieścić katalog na końcu dłuższej publikacji, możesz dodać scaloną zawartość bezpośrednio.

Przed dodaniem scalonych stron na końcu istniejącej publikacji upewnij się, że szablon wykazu seryjnego jest zgodny z istniejącą publikacją pod następującymi względami:

  • Rozmiar stron (wysokość i szerokość)
  • Widok strony (widok jednej strony lub widok dwóch stron)
  • Typ publikacji (sieć Web lub druk)
  • Kolejność stron (od lewej do prawej lub od prawej do lewej)

Wskazówka Program Publisher nie może dodawać scalonych stron do otwartej publikacji. Jeśli pracujesz nad publikacją, z którą chcesz scalić publikację, zapisz ją i zamknij przed zakończeniem pracy z korespondencją seryjną.

  1. W grupie Scalanie kliknij pozycję Dodaj do istniejących.
    Dołączanie wykazu seryjnego do istniejącej publikacji
  2. W oknie dialogowym Otwieranie publikacji znajdź i wybierz publikację, do której chcesz dodać scalone strony, a następnie kliknij przycisk Otwórz.
    Program Publisher dodaje scalone strony na końcu istniejącej publikacji.
    Porada Aby zmienić rozmieszczenie stron w zaktualizowanej publikacji, w okienku nawigacji między stronami kliknij dowolną stronę, którą chcesz przenieść, a następnie przeciągnij ją do odpowiedniej lokalizacji.
  3. W istniejącej publikacji kliknij pozycję Zapisz, aby zapisać zmiany.
  4. W razie potrzeby zapisz też wszelkie zmiany wprowadzone w szablonie wykazu seryjnego. Przy każdej aktualizacji informacji w źródle danych można ponownie użyć tego szablonu wykazu seryjnego do tworzenia dodatkowych scalonych stron.
  • W grupie Scalanie kliknij przycisk Drukuj.
    Drukowanie wykazu seryjnego
    Program Publisher otworzy stronę drukowania w widoku Backstage.

Początek strony