Objawy
Rozważmy następujący scenariusz:
- Masz zawsze włączoną bazę danych grupy dostępności w systemie Microsoft SQL Server 2016.
- Ponownie uruchom usługę koordynatorów transakcji rozproszonych (DTC) firmy Microsoft.
- Załóżmy, że wykonywana jest transakcja rozproszona w bazie danych z włączoną usługą AG. W takiej sytuacji można zauważyć, że transakcja kończy się niepowodzeniem z błędami, które przypominają następujące:
Uwaga
Komunikat 8510, Poziom 20, Stan 3, Numer wiersza
Operacja rejestrowania nie powiodła się: 0x8004d01c(XACT_E_CONNECTION_DOWN). Program SQL Server nie może zarejestrować się u koordynatora transakcji rozproszonych firmy Microsoft (MS DTC) jako menedżera zasobów dla tej transakcji. Transakcja mogła zostać zatrzymana przez klienta lub menedżera zasobów.
Wiadomość 596, Poziom 21, Stan 1, Numer wiersza
Nie można kontynuować wykonywania, ponieważ sesja jest w stanie zabicia.
Wiadomość 0, Poziom 20, Stan 0, Numer wiersza
Wystąpił poważny błąd bieżącego polecenia. Ewentualne wyniki należy odrzucić.
Obejście
Obejściem tego problemu jest ponowne uruchomienie usługi SQL Server, wtedy błąd może nie zostać wyświetlony.
Rozwiązanie
Ten problem został rozwiązany w następującej aktualizacji zbiorczej dla programu SQL Server:
Aktualizacja zbiorcza 6 dla programu SQL Server 2016 z dodatkiem SP1
Informacje o aktualizacjach zbiorczych programu SQL Server:
Każda nowa aktualizacja zbiorcza programu SQL Server zawiera wszystkie poprawki zabezpieczeń uwzględnione w poprzedniej aktualizacji skumulowanej. Sprawdź najnowsze aktualizacje zbiorcze dla programu SQL Server:
Najnowsze aktualizacje zbiorcze dla programu SQL Server 2016
Stan
Firma Microsoft potwierdziła, że jest to problem dotyczący produktów firmy Microsoft wymienionych w sekcji „Dotyczy”.
Źródła informacji
Dowiedz się więcej o terminologii używanej przez firmę Microsoft do opisywania aktualizacji oprogramowania.