Błąd "Error.AspNetInstallPath.Exception0" podczas konfigurowania Microsoft Dynamics CRM dla programu Microsoft Office Outlook

Ten artykuł ułatwia rozwiązanie problemu występującego podczas próby skonfigurowania Microsoft Dynamics CRM dla programu Microsoft Office Outlook.

Dotyczy: Microsoft Dynamics CRM 2016, Dynamics CRM 2015, Dynamics CRM 2013, Microsoft Dynamics CRM 2011
Oryginalny numer KB: 3183901

Symptomy

Podczas próby skonfigurowania Microsoft Dynamics CRM dla programu Microsoft Office Outlook występuje następujący błąd:

Wystąpił problem podczas komunikacji z serwerem Microsoft Dynamics CRM. Serwer może być niedostępny. Spróbuj ponownie później. Jeśli problem będzie się powtarzać, skontaktuj się z administratorem systemu.

Error.AspNetInstallPath.Exception w Microsoft.Crm.Application.Outlook.Config. ConfigInfo.GetAspDotNetPath() w Microsoft.Crm.Application.Outlook.Config. GlobalRepositoryConfigurator.SetLaptopClientRegistryValues() w Microsoft.Crm.Application.Outlook.Config. GlobalRepositoryConfigurator.SetConfigurationRegistryValuesAction() w Microsoft.Crm.Application.Outlook.Config. GlobalRepositoryConfigurator.Configure(IProgressEventHandler progressEventHandler) w Microsoft.Crm.Application.Outlook.Config. ConfigEngine.Configure(Object stateInfo)

Przyczyna

Ten błąd może wystąpić, jeśli wystąpił problem z instalacją .NET Framework firmy Microsoft.

Rozwiązanie

  • Opcja 1

    Pobierz i uruchom narzędzie microsoft .NET Framework Repair Tool.

  • Opcja 2 (Windows 8 lub nowsza)

    Odinstaluj i ponownie zainstaluj .NET Framework.

    Uwaga

    Program CRM 2013 dla programu Outlook używa .NET Framework 4 lub nowszego. Program CRM 2015 dla programu Outlook używa .NET Framework 4.5 lub nowszej. Program CRM 2016 dla programu Outlook używa .NET Framework 4.5.2 lub nowszej.

    1. Uzyskaj dostęp do Panel sterowania, a następnie otwórz polecenie Odinstaluj program (programy i funkcje).
    2. Kliknij pozycję Włącz lub wyłącz funkcje systemu Windows.
    3. Usuń zaznaczenie .NET Framework, a następnie kliknij przycisk OK.
    4. Kliknij przycisk Zamknij.
    5. Kliknij pozycję Włącz lub wyłącz funkcje systemu Windows.
    6. Włącz .NET Framework, a także opcję ASP.NET poniżej.
    7. Kliknij przycisk OK.
  • Opcja 3 (Windows 7)

    Napraw .NET Framework w obszarze Dodawanie/usuwanie programów.

    1. Uzyskaj dostęp do Panel sterowania, a następnie otwórz polecenie Odinstaluj program (programy i funkcje).
    2. Wybierz .NET Framework Firmy Microsoft, a następnie kliknij przycisk Odinstaluj/Zmień.
    3. Wybierz opcję Napraw, a następnie kliknij przycisk Dalej.