Symptom

Podczas próby importowania rozwiązania w Dynamics 365, wystąpić następujący błąd:

"Importowanie rozwiązania: < nazwa rozwiązania > nie powiodło się."

Widoczny może również odniesienie do kodu błędu 80044327.

Podczas przeglądania szczegółowego błędów w siatce, kolumny szczegółów zostanie wyświetlony następujący komunikat:

"Nieprawidłowa wartości kolejności wyświetlania. Kolejność wyświetlania musi być większy lub równy 10000."

Jeśli kliknij opcję Pobierz plik dziennika i otworzyć plik w programie Excel, na karcie components znajduje się komunikat jak na poniższej ilustracji:

"0x80044327

Okienko nawigacji kolejności 0 nie jest dozwolone - musi być co najmniej tak duży jak 10 000 dla entityRelationshipId < relationshipId >"

Przyczyna

Ten błąd występuje, jeśli rozwiązanie zawiera relację z jednego obiektu do drugiego, a kolejność wyświetlania (NavPaneOrder) jest skonfigurowany jako liczbę mniejszą niż 10000. Ustawienie tej wartości na liczbę mniejszą niż 10000 nie jest dozwolone podczas wykonywania dostosowań w Dynamics 365, ale może być wynikiem modyfikowanie customizations.xml bezpośrednio.

Rozwiązanie

  1. Wyodrębnij plik .zip rozwiązania, którą próbujesz zaimportować.

  2. Otwieranie pliku customizations.xml w edytorze tekstów.

  3. Wyszukaj następującą sekcję: < NavPaneOrder > 0 < / NavPaneOrder > Uwaga: Jest to możliwe, numer w Twoim przykładzie może być czymś innym niż 0, ale niektóre inne liczbę mniejszą niż 10 000. Jak wspomniano w sekcji Symptomy, może dotyczyć wiadomość w pliku dziennika, aby potwierdzić wartość zamówienia okienka nawigacji, który spowodował błąd.

  4. Po znalezieniu nieprawidłowy sekcji NavPaneOrder, aktualizacji numeru niepoprawne wartości większe niż lub równe do 10000. Uwaga: Nie należy dołączać przecinek.

  5. Zaznacz wszystkie pliki z roztworu wyodrębnione i wysłać je do pliku zip.

  6. Próba zaimportowania Aktualizacja rozwiązania.

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów firmy Microsoft

Czy te informacje były pomocne?

Jak zadowalająca jest jakość tłumaczenia?

Co wpłynęło na Twoje wrażenia?

Czy chcesz przekazać jakieś inne uwagi? (Opcjonalnie)

Dziękujemy za opinię!

×