Dane programu Excel nie zachowuje swoje formatowanie w operacji korespondencji seryjnej w programie Word

Objawy

Jeśli używasz arkusza programu Microsoft Excel jako źródła danych dla listy adresatów tworzenia korespondencji seryjnej w programie Microsoft Word, niektóre dane liczbowe nie może zachować formatowanie podczas scalania.

To zachowanie dotyczy sformatowane wartości procentowych, wartości walutowych i kody pocztowe, jak pokazano w poniższej tabeli:
Format In Excel data In Word MergeField
----------------------------------------------------
Percentage 50% .5
Currency $12.50 12.5
Postal Code 07865 7895

Przyczyna

To zachowanie występuje, ponieważ dane na liście adresatów w programie Word pojawi się w formacie macierzystym, w które sklepy Excel, bez inne, które są stosowane do komórek arkusza, które przechowują dane.

Rozwiązanie

Aby rozwiązać ten problem, użyj jednej z następujących metod.

Metoda 1

Umożliwia łączenie z arkuszem programu Excel, która zawiera dane, których chcesz użyć dynamicznej wymiany danych (DDE, Dynamic Data Exchange). Aby to zrobić, wykonaj następujące kroki.

Program Word 2002 i Word 2003

  1. Uruchom program Word, a następnie otwórz nowy pusty dokument.

  2. W menu Narzędzia kliknij polecenie Opcje, a następnie kliknij kartę Ogólne .

  3. Kliknij, aby zaznaczyć pole wyboru Potwierdzanie konwersji przy otwieraniu pliku , a następnie kliknij przycisk OK.

  4. W menu Narzędzia wskaż polecenie listy i dokumenty wysyłkowe, a następnie kliknij polecenie Kreator korespondencji seryjnej.

  5. W okienko zadań Korespondencja seryjna wybierz typ dokumentu, z którym chcesz pracować na, a następnie kliknij przycisk Dalej.

  6. W obszarze Wybierz dokument początkowywybierz dokument początkowy, którego chcesz używać, a następnie kliknij przycisk Dalej.

  7. W obszarze Wybierz adresatówkliknij przycisk Użyj istniejącej listy, a następnie kliknij przycisk Przeglądaj.

  8. W oknie dialogowym Wybierz źródło danych zlokalizuj folder zawierający skoroszyt programu Excel, którego chcesz użyć jako źródła danych, wybierz skoroszyt, a następnie kliknij Otwórz.

  9. W oknie dialogowym Potwierdzanie źródła danych kliknij Skoroszyty programu MS Excel przez DDE (*.xls), a następnie kliknij przycisk OK.

  10. W programie Microsoft Excel, okno dialogowe, w obszarze Nazwa lub zakres komórekzaznacz zakres komórek lub arkusz zawierający dane, które chcesz użyć, a następnie kliknij przycisk OK.

    Uwaga: dane pojawi się teraz w Adresaci korespondencji seryjnej okno dialogowe o tym samym formatowaniu pojawiający się w arkuszu programu Excel.

Program Word 2007 i Word 2010

  1. Uruchom program Word, a następnie otwórz nowy pusty dokument.

  2. Przejdź do opcji programu Word

    • W programie Word 2007 kliknij Przycisk pakietu Office, a następnie kliknij przycisk Opcje programu Word.

    • W programie Word 2010 kliknij plik, a następnie kliknij przycisk Opcje.

  3. Na karcie Zaawansowane przejdź do sekcji Ogólne .

  4. Kliknij, aby zaznaczyć pole wyboru Potwierdź konwersję formatu podczas otwierania pliku , a następnie kliknij przycisk OK.

  5. Na karcie Korespondencje kliknij przycisk Rozpocznij korespondencję seryjną, a następnie wybierz polecenie Kreator korespondencji seryjnej krok po kroku.

  6. W okienko zadań Korespondencja seryjna wybierz typ dokumentu, z którym chcesz pracować na, a następnie kliknij przycisk Dalej.

  7. W obszarze Wybierz dokument początkowywybierz dokument początkowy, którego chcesz używać, a następnie kliknij przycisk Dalej.

  8. W obszarze Wybierz adresatówkliknij przycisk Użyj istniejącej listy, a następnie kliknij przycisk Przeglądaj.

  9. W oknie dialogowym Wybierz źródło danych zlokalizuj folder zawierający skoroszyt programu Excel, którego chcesz użyć jako źródła danych, wybierz skoroszyt, a następnie kliknij Otwórz.

  10. W oknie dialogowym Potwierdzanie źródła danych kliknij, aby zaznaczyć pole wyboru Pokaż wszystko . Kliknij Skoroszyty programu MS Excel przez DDE (*.xls), a następnie kliknij przycisk OK.

  11. W programie Microsoft Excel, okno dialogowe, w obszarze Nazwa lub zakres komórekzaznacz zakres komórek lub arkusz zawierający dane, które chcesz użyć, a następnie kliknij przycisk OK.

    Uwaga: dane pojawi się teraz w Adresaci korespondencji seryjnej okno dialogowe o tym samym formatowaniu pojawiający się w arkuszu programu Excel.

Metoda 2

Format pola arkusza Excel, który zawiera kod pocztowy jako tekst. Aby to zrobić, wykonaj następujące kroki.

Program Word 2002 i Word 2003

  1. W programie Excel zaznacz kolumnę, która zawiera pola Kod pocztowy.

  2. W Format menu kliknij polecenie komórki.

  3. Kliknij kartę liczby .

  4. W obszarze kategoriikliknij tekst, a następnie kliknij przycisk OK.

  5. Zapisz źródło danych. Następnie należy kontynuować operację korespondencji seryjnej w programie Word.

Program Word 2007 i Word 2010

  1. W programie Excel zaznacz kolumnę, która zawiera pola Kod pocztowy.

  2. Na karcie Strona główna przejdź do grupy komórek . Następnie kliknij Format, a następnie kliknij Formatowanie komórek.

  3. Kliknij kartę liczby .

  4. W obszarze kategoriikliknij tekst, a następnie kliknij przycisk OK.

  5. Zapisz źródło danych. Następnie należy kontynuować operację korespondencji seryjnej w programie Word.

Powiązane artykuły

Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

304387 Data, numer telefonu i pola Waluta są scalane niepoprawnie w przypadku użyć źródła danych programu Access lub Excel w programie Word 2002 lub Word 2003

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów firmy Microsoft

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×