Obniżenie wydajności w Microsoft Dynamics CRM z powodu dużej liczby plików tymczasowych

Ten artykuł zawiera rozwiązanie problemu z wydajnością obniżania wydajności w Microsoft Dynamics CRM z powodu dużej liczby plików tymczasowych.

Dotyczy: Microsoft Dynamics CRM 2011 r.
Oryginalny numer KB: 2877070

Symptomy

Może wystąpić spadek wydajności, który może wystąpić, ponieważ w rozwiązaniu zestawu SDK brakuje dostępnych nazw plików lub program antywirusowy przeprowadza skanowanie podczas tworzenia plików.

Przyczyna

Istnieje limit 65 335 plików, które można utworzyć w katalogu tymczasowym systemu Windows, a po osiągnięciu tego limitu procesy, które muszą tworzyć te pliki, nie są w stanie tego zrobić, co wpływa na wydajność lub sprawia, że aplikacja nie odpowiada.

Rozwiązanie

Najlepszym rozwiązaniem dla katalogu tymczasowego jest regularne czyszczenie go na serwerze w ramach normalnej procedury konserwacji. Istnieje wiele narzędzi i narzędzi, które mogą wykonywać zautomatyzowane oczyszczanie.