Komunikat o błędzie "Komunikat systemowy 5045" w różnych lokalizacjach w usłudze Microsoft Dynamics SL
Ten artykuł zawiera rozwiązanie błędu występującego w różnych lokalizacjach w usłudze Microsoft Dynamics SL.
Dotyczy: Microsoft Dynamics SL
Oryginalny numer KB: 875699
Symptomy
Rozważmy następujące scenariusze w różnych lokalizacjach w usłudze Microsoft Dynamics SL.
- Próbujesz zalogować się do usługi Microsoft Dynamics SL. Zobacz Przyczyna 1, 2 lub 3.
- Możesz też wykonać dowolną akcję, która tworzy dziennik zdarzeń microsoft Dynamics SL. Zobacz wszystkie przyczyny.
- Możesz też wybrać pozycję Rozpocznij na ekranie Sprawdzanie integralności fizycznej bazy danych (95.500.00 ). Zobacz Przyczyna 5.
W tych scenariuszach zostanie wyświetlony następujący komunikat o błędzie:
Komunikat systemowy 5045 — błąd pliku podczas próby otwarcia pliku stanu procesu
Przyczyna
Ten problem występuje z co najmniej jednej z następujących przyczyn.
Przyczyna 1
Identyfikator użytkownika systemu Windows nie ma wystarczających uprawnień do operacji. Zobacz Rozwiązanie 1.
Przyczyna 2
Dysk logiczny zamapowany na instalację programu Microsoft Dynamics SL jest nieprawidłowy. Zobacz Rozwiązanie 2.
Przyczyna 3
Plik Solomon.ini na komputerze stacji roboczej jest uszkodzony. Zobacz Rozwiązanie 3.
Przyczyna 4
Pliki dziennika zdarzeń są uszkodzone. Zobacz Rozwiązanie 4.
Przyczyna 5
Tabela PSTATUS jest uszkodzona. Zobacz Rozwiązanie 5.
Rozwiązanie
Aby rozwiązać ten problem, użyj odpowiedniego rozwiązania.
Uchwała 1
Przypisz odpowiednie uprawnienia użytkownikom usługi Microsoft Dynamics SL.
- Skontaktuj się z administratorem sieci, aby sprawdzić, czy identyfikator użytkownika systemu Windows ma wystarczające uprawnienia.
- Upewnij się, że wszyscy użytkownicy usługi Microsoft Dynamics SL mają pełną kontrolę nad katalogiem, w którym zainstalowano usługę Microsoft Dynamics SL. Domyślna lokalizacja instalacji jest następująca:
- Microsoft Dynamics SL 7.0 i nowsze wersje:
DriveLetter:\Program Files\Microsoft Dynamics\SL\Applications
- Microsoft Dynamics SL 6.5 i starsze wersje:
DriveLetter:\Program Files\Solomon\
- Microsoft Dynamics SL 7.0 i nowsze wersje:
Uchwała 2
Udostępnij i zamapuj dysk na poprawnie. Domyślna lokalizacja instalacji microsoft Dynamics SL jest następująca:
- Microsoft Dynamics SL 7.0 i nowsze wersje:
DriveLetter:\Program Files\Microsoft Dynamics\SL\Applications
- Microsoft Dynamics SL 6.5 i starsze wersje:
DriveLetter:\Program Files\Solomon
W takim przypadku dyski ze stacji roboczej powinny być mapowane do katalogu głównego woluminu lub do jednej z następujących lokalizacji, w zależności od wersji:
- Microsoft Dynamics SL 7.0 i nowsze wersje:
DriveLetter:\Program Files\Microsoft Dynamics SL\
- Microsoft Dynamics SL 6.5 i starsze wersje:
DriveLetter:\Program Files\
Oznacza to, że należy udostępnić katalog główny woluminu lub jedną z lokalizacji, które zostały omówione wcześniej. Na komputerach stacji roboczej właściwości ikony programu głównego powinny być następujące:
- Microsoft Dynamics SL 7.0 i nowsze wersje:
DriveLetter:\SL\Applications\MSDynamicsSL.exe
lubDriveLetter:\Applications\MSDynamicsSL.exe
- Microsoft Dynamics SL 6.5 lub starsze wersje:
DriveLetter:\Program Files\Solomon\Parent.exe
lubDriveLetter:\Solomon\Parent.exe
Uwaga
Właściwości ikony nie powinny być jedną z następujących lokalizacji (co wskazuje katalog główny mapy):
- Microsoft Dynamics SL 7.0 i nowsze wersje:
DriveLetter:\MSDynamicsSL.exe
- Microsoft Dynamics SL 6.5 i starsze wersje:
DriveLetter:\Parent.exe
Właściwości ikony nie powinny być jedną z następujących lokalizacji (co wskazuje ścieżkę UNC):
- Microsoft Dynamics SL 7.0 i nowsze wersje:
\\Servername\sharename\Applications\MSDynamicsSL.exe
- Microsoft Dynamics SL 6.5 i starsze wersje:
\\Servername\sharename\Solomon\Parent.exe
Ścieżki UNC nie są obsługiwane w ramach programu Microsoft Dynamics SL ani Microsoft Business Solutions — Solomon.
Uchwała 3
Zmień nazwę wszystkich plików Solomon.ini na komputerze stacji roboczej na Solomon.old.
Uchwała 4
Usuń wszystkie pliki dziennika zdarzeń w następujących lokalizacjach:
- Microsoft Dynamics SL 7.0 i nowsze wersje:
DriveLetter:\Program Files\Microsoft Dynamics\SL\Applications\Eventlog\
- Microsoft Dynamics SL 6.5 i starsze wersje:
DriveLetter:\Program Files\Solomon\Eventlog\
Uchwała 5
Usuń uszkodzone rekordy w tabeli PSTATUS.
Uwaga
Przed wykonaniem instrukcji opisanych w tym artykule upewnij się, że masz pełną kopię zapasową bazy danych, którą można przywrócić w przypadku wystąpienia problemu.
Korzystając z SQL Server Management Studio lub SQL Query Analyzer, uruchom następującą instrukcję dla bazy danych aplikacji Microsoft Dynamics SL lub bazy danych aplikacji Microsoft Business Solutions — Solomon:
Delete from PSTATUS