Importowanie rozwiązania kończy się niepowodzeniem z powodu braku składników

Ten artykuł zawiera rozwiązanie problemu Błędu niepowodzenia importowania rozwiązania [nazwa rozwiązania], który może wystąpić podczas próby zaimportowania rozwiązania w usłudze Microsoft Dynamics 365.

Dotyczy: Microsoft Dynamics 365
Oryginalny numer KB: 4346030

Symptomy

Podczas próby zaimportowania rozwiązania w usłudze Microsoft Dynamics 365 import kończy się niepowodzeniem z następującym komunikatem:

Importowanie rozwiązania [nazwa rozwiązania] nie powiodło się. W systemie brakuje następujących składników i nie są one uwzględnione w rozwiązaniu. Zaimportuj rozwiązania zarządzane zawierające te składniki ([nazwa brakującego rozwiązania] ([wersja rozwiązania]),a następnie spróbuj ponownie zaimportować rozwiązanie.

Może również zostać wyświetlone odwołanie do kodu błędu 8004801d.

Przyczyna

Ten błąd występuje, jeśli próbujesz zaimportować rozwiązanie, które zależy od innych składników, które nie należą do organizacji Dynamics 365 firmy Microsoft.

Przykład: Masz środowisko deweloperskie, w którym utworzono rozwiązanie (Rozwiązanie A), które zawiera jednostkę niestandardową (widżet). Utworzono inne rozwiązanie (rozwiązanie B), które zależy od składnika w rozwiązaniu A (np. do jednostki widgetu zostało dodane nowe pole). Jeśli spróbujesz zaimportować rozwiązanie B do innej organizacji (na przykład organizacji produkcyjnej), która nie ma jeszcze zainstalowanego rozwiązania A, wystąpi ten błąd.

Rozwiązanie

Przejrzyj szczegóły brakującego składnika wyświetlane w oknie dialogowym importowania. Jeśli na liście znajdują się inne rozwiązania, które nie zostały jeszcze zaimportowane w organizacji, w której próbujesz zaimportować to rozwiązanie, najpierw zaimportuj te rozwiązania przed próbą zaimportowania tego rozwiązania.

Przykład: Kontynuując przykład z powyższej sekcji Przyczyna, może się okazać, że na liście brakujących składników jest wyświetlany co najmniej jeden wiersz, w którym kolumna Rozwiązanie zarządzane odwołuje się do rozwiązania A. Oznacza to, że należy zaimportować wspomnianą wersję rozwiązania A, zanim będzie można pomyślnie zaimportować rozwiązanie B.

Więcej informacji

Jeśli komunikat o błędzie odnosi się do rozwiązania firmy Microsoft, zapoznaj się z następującą listą rozwiązań i gdzie można je znaleźć, jeśli nie są zainstalowane w organizacji docelowej:

LinkedIn Sales Navigator dla Dynamics 365

Nazwy rozwiązań:

  • LinkedInSalesNavigatorControlsForUnifiedClient

  • LinkedIn

  • msdyn_LinkedInSalesNavigatorAnchor

    Uwaga

    Jeśli chcesz odinstalować te rozwiązania, należy je odinstalować w kolejności powyższej listy.