Wystąpił błąd podczas synchronizowania programu Microsoft Office Outlook z serwerem Microsoft Dynamics CRM

Ten artykuł zawiera rozwiązanie problemu, który nie może zsynchronizować programu Microsoft Office Outlook z klientem Microsoft Dynamics CRM dla programu Outlook z powodu błędu Klient Microsoft CRM dla programu Outlook zainstalowany na innym komputerze.

Dotyczy: Microsoft Dynamics CRM 2011 r.
Oryginalny numer KB: 953774

Symptomy

Klient Microsoft Dynamics CRM programu Microsoft Office Outlook jest instalowany przy użyciu równoważenia obciążenia i profilu roamingu. Następnie połączysz klienta z serwerem i zdefiniujesz go jako klienta synchronizacji. Następnie połączysz klienta z innym serwerem jako ten sam użytkownik. Podczas próby zsynchronizowania programu Outlook z klientem Microsoft Dynamics CRM dla programu Outlook zostanie wyświetlony następujący komunikat o błędzie:

Na innym komputerze zainstalowano już Microsoft CRM Client for Outlook. Tylko jeden komputer kliencki na użytkownika może uruchomić automatyczny proces, który wykonuje zbiorcze aktualizacje elementów programu Outlook przy użyciu mikrofonu. Dane CRM. Ten klient powinien być komputerem najczęściej w trybie online (na przykład komputerem stacjonarnym) lub komputerem podstawowym użytkownika. Aby zmienić klienta synchronizacji, w menu CRM kliknij pozycję Opcje, a następnie kliknij kartę synchronizacji.

Przyczyna

Ten problem występuje, ponieważ HKEY_CURRENT_USER (HKCU) klucz rejestru nie jest poprawnie kopiowany podczas nawiązywania połączenia z nowym serwerem w scenariuszu profilu roamingu.

Klient synchronizacji jest określany outlooksyncsubscriptionid przez wpis rejestru i outlooksyncclientid wpis rejestru. Jeśli wpisy rejestru nie są obecne w kluczu HKCU rejestru, klient nie jest traktowany jako klient synchronizacji.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj następujące czynności:

  1. Sprawdź, outlooksyncsubscriptionid czy wpis rejestru i outlooksyncclientid wpis rejestru znajdują się w kluczu HKCU\software\microsoft\mscrmclient rejestru podczas nawiązywania połączenia z nowym serwerem.
  2. Jeśli wpisy rejestru nie znajdują się w kluczu HKCU\software\microsoft\mscrmclient rejestru, sprawdź, czy którekolwiek z następujących ustawień obiektu zasady grupy (GPO) jest włączone.
    • Zapobieganie propagacji zmian profilu roamingu na serwer
    • Zezwalaj tylko na lokalne profile użytkowników
  3. Jeśli ustawienia obiektu zasad grupy są włączone, wyłącz je.