Objawy

Rozważ następujący scenariusz:

  • Rola punktu stanu powrotu jest włączona na serwerze lokacji, w którym działa program Microsoft System Center Menedżer konfiguracji 2007 Service Pack 1 (SP1).

  • Niektórzy klienci są przypisane do tego punktu stanu powrotu.

  • Wiele kart sieciowych, są instalowane na jednego lub więcej klientów.

W tym scenariuszu punkt stanu powrotu może przestać przetwarzania plików stanu wiadomości od klientów. Ponadto komunikaty o stanie, które mają długie nazwy plików mogą zostać zatrzymane w jednym z następujących folderów: na przykład, następujący plik wiadomości Państwo ma długą nazwę pliku:

State_1000.smx komunikacji 00-04-23-D8-D1-DD00-04-23-D8-D1-DC00-04-75-E7-4D-8D00-06-5b-AB-5e-F400-04-23-D8-C4-0300-04-23-a6-87-2200-04-23-a6-87-2300-04-23-D8-C4-02_CCM FrameworkUwaga Jeśli pliki są zablokowane w folderze SMS_CCM\FSPStaging, zablokowane są tylko te pliki, które mają długie nazwy. Stan wiadomości, które mają krótszy nazwy pliku są przetwarzane.

Jeśli stan wiadomości pliki, które mają długie nazwy plików są zatrzymane w folderze Statesys.box\Incoming, wszystkie przetwarzania pliku wiadomości Państwo jest zablokowany.

Ponadto następujące błędy są rejestrowane w Statesys.log:

Przyczyna

Ten problem występuje, ponieważ identyfikator klienta, aby zdefiniować nazwę pliku komunikat stanu kwerendy punktu stanu powrotu. Jeśli brakuje Identyfikatora klienta punktu stanu powrotu kwerendy wszystkie adresy MAC tego klienta, aby zdefiniować nazwę pliku komunikat stanu.

Jeśli zainstalowano wiele kart sieciowych na tym kliencie, całkowita długość stanu powrotu punkt przychodzące nazwę folderu wraz z nazwą pliku komunikat stanu (klienci wszystkich adresów MAC) może przekroczyć ograniczenie długości ścieżki maksymalną 255 znaków.

Rozwiązanie

Informacje dodatku Service Pack

Aby rozwiązać ten problem, należy uzyskać najnowszy dodatek service pack dla programu Microsoft System Center Menedżer konfiguracji 2007, dostępne w witrynie sieci web firmy Microsoft: http://www.microsoft.com/downloads/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
Aby uzyskać listę problemy rozwiązane w tym dodatku service pack kliknij następujący numer artykułu z bazy wiedzy Microsoft Knowledgebase:

971348 Lista poprawek i aktualizacji, które są zawarte w dodatku Service Pack 2 dla programu System Center Menedżer konfiguracji 2007

Informacje o poprawce

Obsługiwana poprawka jest udostępniana przez firmę Microsoft. Jednak ta poprawka jest przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Zastosuj poprawkę tylko w systemach, w których występuje problem opisany w tym artykule. Ta poprawka może być wciąż w fazie testowania. Jeśli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następną aktualizację oprogramowania zawierającą tę poprawkę.

Jeśli poprawka jest dostępna do pobrania, pojawi się sekcja "Poprawka dostępna do pobrania" na początku tego artykułu z bazy wiedzy Knowledge Base. Jeśli nie ma tej sekcji, skontaktuj się z Obsługą i Wsparciem Klienta Microsoft w celu uzyskania poprawki.

Uwaga Jeśli wystąpią dodatkowe błędy lub konieczność rozwiązania problemu, być może trzeba będzie utworzyć osobne zlecenie usługi. Zwykłe koszty obsługi będą zastosowane do dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu określonej poprawki. Aby uzyskać pełną listę numerów telefonów pomocy technicznej i obsługi klienta firmy Microsoft lub utworzyć osobne zlecenie usługi, odwiedź następującą witrynę firmy Microsoft w sieci Web:

http://support.microsoft.com/contactus/?ws=supportUwaga "Poprawka dostępna do pobrania" zawiera listę języków, dla których dostępna jest poprawka. Jeśli odpowiedni język nie jest widoczny, to dlatego, że poprawka nie jest dostępna dla danego języka.

Wymagania wstępne

Musi mieć System Center Menedżer konfiguracji 2007 Service Pack 1 zainstalowany, aby można było zastosować tę poprawkę.

Wymagania dotyczące ponownego uruchomienia

Nie musisz ponownie uruchomiać komputera po zastosowaniu tej poprawki.

Informacje dotyczące zastępowania poprawek

Ta poprawka nie zastępuje żadnych wcześniej wydanych poprawek.

Informacje o plikach

Wersja anglojęzyczna tej poprawki ma atrybuty plików (lub nowsze) wymienione w poniższej tabeli. Daty i godziny odpowiadające tym plikom zostały podane w formacie uniwersalnego czasu koordynowanego (UTC, Coordinated Universal Time). Po wyświetleniu informacji o pliku są konwertowane na czas lokalny. Aby zobaczyć różnicę między czasem UTC i czasem lokalnym, należy użyć z karty Strefa czasowa w aplecie Data i godzina w Panelu sterowania.

Program System Center Menedżer konfiguracji 2007 z dodatkiem Service Pack 1

Nazwa pliku

Wersja pliku

Rozmiar pliku

Data

Godzina

Platforma

Fsp.msi

Nie dotyczy

2,766,336

30-Nov-2008

22:00

Nie dotyczy

Fspisapi.dll

4.0.6221.1149

64,864

30-Nov-2008

22:00

x86

Fspisapi.dll

4.0.6221.1149

395,104

30-Nov-2008

22:00

IA-64

Fspisapi.dll

4.0.6221.1149

168,800

30-Nov-2008

22:00

x64

Obejście problemu

Aby obejść ten problem, Usuń pliki wiadomości Państwo, które mają długie nazwy plików z folderu Statesys.box\Incoming lub folderu \SMS_CCM\FSPStaging.

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Dotyczy”.

Więcej informacji

Aby uzyskać więcej informacji na temat punktu stanu powrotu System Center Menedżer konfiguracji 2007 odwiedź następującą witrynę firmy Microsoft w sieci Web:

http://technet.microsoft.com/en-us/library/bb694178.aspxAby uzyskać więcej informacji dotyczących terminologii aktualizacji oprogramowania, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

824684 Opis standardowej terminologii używanej do opisywania aktualizacji oprogramowania firmy Microsoft

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów firmy Microsoft

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×