Objawy

Gdy konto lokalnej usługi Active Directory jest dostarczana z powrotem do zakresu Azure Połącz AD, skrzynki pocztowej nieaktywne jest nie są ponownie połączone automatycznie w programie Exchange Online. Dodatkowo nowo zakładanej utworzenia skrzynki pocztowej w programie Exchange Online.

Uwaga Dla klientów dedykowane ITAR usługi Microsoft Office 365 Microsoft zarządzanych usług Usługa inicjowania obsługi administracyjnej dostawcy (MMSSPP) zapisze atrybutów ExchangeGUID i msExchMailboxGUID z dedykowanym środowiska klienta lokalne usługi Active Directory podczas fazy współistnienia. Włączona poczta użytkownika jest tworzony zamiast nowo zakładanej skrzynki pocztowej w programie Exchange Online. Aby uzyskać więcej informacji zobacz temat użytkownik nie może uzyskać dostęp do skrzynki pocztowej, która jest zaopatrzona w usłudze Office 365 dedykowane ITAR (vNext).

Przyczyna

Po usunięciu skrzynki pocztowej obiektów z zakresu Azure AD Connect, pozostają one w Azure AD Recycle Bin przez 30 dni. Będziesz musiał podjąć dodatkowe kroki w celu ponownego połączenia lokalnego konta AD ze skrzynką pocztową nieaktywne, gdy konto jest wydzielany z Kosza.

Rozwiązanie

Aby rozwiązać ten problem, użyj następujących procesów.

Przeniesienie zawartości z oryginalnej skrzynki pocztowej

Przywrócić zawartość z nieaktywnych skrzynki pocztowej do nowo zakładanej skrzynki pocztowej za pomocą apletu polecenia New-MailboxRestoreRequest . Dzięki temu można nadal używać nowej skrzynki pocztowej i kopiowanie oryginalnej zawartości.

Ponownie oryginalny pocztowej nieaktywne

Uwaga Ten proces działa również w przypadku soft usunięte skrzynki pocztowe Jeśli łączą się z nowego lokalnego konta AD. Parametr SoftDeletedMailbox należy zastąpić parametr InactiveMailboxOnly .

  1. Uruchom następujące polecenie, aby uzyskać atrybutów nieaktywnej skrzynki pocztowej z programu Exchange: $InactiveMailbox = Get-Mailbox -InactiveMailboxOnly -Identity <identity of inactive mailbox>

  2. Uruchom następujące polecenie, aby tymczasowo skojarzyć nieaktywnej skrzynki pocztowej z kontem w chmurze. Konta zostaną zsynchronizowane powrót do Azure AD: New-Mailbox -InactiveMailbox $InactiveMailbox.DistinguishedName -Name "<name of inactive mailbox>" -DisplayName "<DisplayName of inactive mailbox>" -MicrosoftOnlineServicesID <alias@*.onmicrosoft.com> - Password (ConvertTo-SecureString -String <PasswordString> -AsPlainText -Force) -ResetPasswordOnNextLogon $true

  3. Uzyskać wartość parametru ImmutableID . Domyślnie jest to atrybut ObjectGUID lokalnego jako ciągu base-64. Można przekonwertować ObjectGUID przy użyciu następującego polecenia programu Windows PowerShell: [system.convert]::ToBase64String(([GUID]"<ObjectGUID>").tobytearray())

  4. W Azure AD uzyskać wartość parametru ObjectID Azure nowe konto Reklamowe, zsynchronizowane z usługą Exchange Online. Aby to zrobić, uruchom następujące polecenie:  Get-MsolUser -UserPrincipalName <UPN> | fl objectID

  5. Ustaw parametr ImmutableID w Azure AD: Set-MsolUser -ObjectId  <ObjectId>  -ImmutableId <ImmutableId>

  6. Dostosowania oryginalne konto usługi Azure AD do zakresu Azure AD Connect.

  7. Sprawdź obiektu skrzynki pocztowej i upewnij się, że podstawowy adres SMTP są aktualizowane na podstawie wartości nazwy główne (UPN) tymczasowe użytkownika na poprawny adres podstawowy. Uwaga Nowa skrzynka pocztowa nie jest włączona dla sądowym. Ponadto pojawić następujący komunikat ostrzegawczy:

    Ostrzeżenie: Został odzyskany nieaktywnej skrzynki pocztowej. Aby zachować dane, aż do uzyskania prawidłowej licencji, mamy włączone odzyskiwania pojedynczego elementu przez 30 dni. Dodatkowo możemy również włączono przechowywania przez 30 dni. Po przypisaniu ważnej licencji dla tej skrzynki pocztowej, można wyłączyć te ustawienia i używać zamiast niego postępowania sądowego lub w miejscu przechowywania zachować dane.

  8. Zastosowanie licencja Exchange Server oraz ustawienia blokady odpowiednie do nowej skrzynki pocztowej.

Więcej informacji

Kroki opisane w sekcji "Rozwiązanie" są zaczerpnięte z instrukcjami Skrzynka pocztowa chmury w przywrócić nieaktywnej skrzynki pocztowej w usłudze Office 365.

Nadal potrzebujesz pomocy? Przejdź do Witryny Microsoft Community.

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów firmy Microsoft

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×