PROBLEM
Exchange Online użytkowników, którzy korzystają z programu Outlook do iOS i Android i kto również korzystać z reguł dostępu do urządzenia (ABQ) znaleźć, że one już został nieoczekiwanie kwarantannie. Ten problem występuje w następującej sytuacji:
-
Właściwość l DefaultAccessLevenajemcy, która jest skonfigurowany za pomocą Zestawu ActiveSyncOrganizationSettings ustawiono wartość kwarantanny lub bloku.
-
Administrator dzierżawy wcześniej dozwolone przez stemplowanie DeviceID we właściwości ActiveSyncAllowedDeviceIDs skrzynki pocztowej programu Outlook dla iOS i Android.
-
Urządzenia nie są zarządzane przez program Microsoft Intune.
PRZYCZYNA
Zmiana protokołu back-end w sposób danych skrzynki pocztowej usługi Office 365 jest dostępna za pośrednictwem programu Outlook dla aplikacji iOS oraz Android zmienia DeviceID, że aplikacja używa do łączenia się z usługą Exchange Online. Ekwestii zachowanie jest, że nowy identyfikator urządzenia zostaną automatycznie dodane do ActiveSyncAllowedDeviceID dla użytkownika. Jednak w niektórych scenariuszach urządzenia mogą być poddane kwarantannie. W takich przypadkach należy wykonać kroki opisane w sekcji "Rozwiązanie". Ten problem nie może występować wielokrotnie.
ROZWIĄZANIE
Skontaktuj się z obsługą i zapytaj klienta, przedstawiciel działu obsługi ułatwiające odblokowywania urządzenia.
Lub użyj jednej z następujących metod odblokowywania urządzenia:
-
Centrum administracyjnego programu Exchange umożliwia odblokowanie poszczególnych urządzeń. Aby to zrobić, wykonaj następujące kroki:
-
Zaloguj się do Centrum administracyjnego programu Exchange. Aby uzyskać więcej informacji zobacz Administrator programu Exchange w programie Exchange wyśrodkować Online.
-
Kliknij przycisk mobilnych, a następnie w obszarze Urządzenia poddane kwarantannie, wybierz przycisk Zezwalaj dla każdego programu Outlook dla iOS i urządzenia androida, która musi zostać odblokowane.
-
-
Sesje zdalne programu PowerShell, aby odblokować wszystkie urządzenia. Aby to zrobić, wykonaj następujące kroki:
-
Połączyć się Exchange Online przy użyciu zdalnego programu PowerShell. Aby uzyskać więcej informacji zobacz temat Nawiązywanie połączenia z programem Exchange Online PowerShell.
-
Skopiuj i wklej następujący kod do zdalnej sesji środowiska PowerShell:
function FixUnblock { $Mbxs = Get-CASMailbox -ResultSize 10000 | ?{$_.ActiveSyncAllowedDeviceIDs -ne $null } foreach($Mbx in $Mbxs) { write-host $Mbx.Id $IdList = Get-MobileDevice -Mailbox $Mbx.Id | where {$_.DeviceModel -eq "Outlook for iOS and Android" -and $_.ClientType -eq "REST" -and $_.DeviceAccessState -ne "Allowed" -and $_.FirstSyncTime -ge "9/13/2016"} $CasDevice = Get-CasMailbox $Mbx.Id foreach( $Id in $IdList) { $CasDevice.ActiveSyncAllowedDeviceIDs += $Id.DeviceId } Set-CasMailbox $Mbx.Id -ActiveSyncAllowedDeviceIDs $CasDevice.ActiveSyncAllowedDeviceIDs } }
-
W sesji zdalnej programu PowerShell należy uruchomić funkcję. Aby to zrobić, wpisz FixUnblock, a następnie naciśnij klawisz Enter.
-
WIĘCEJ INFORMACJI
Nadal potrzebujesz pomocy? Przejdź do Witryny Microsoft Community.