Zalogowany użytkownik nie ma odpowiedniego błędu uprawnień zabezpieczeń po uaktualnieniu do Microsoft Dynamics CRM 2011 r.

Ten artykuł zawiera rozwiązanie problemu, który nie może zostać uaktualniony do Microsoft Dynamics CRM 2011 r., ponieważ zalogowany użytkownik nie ma odpowiednich uprawnień zabezpieczeń do wyświetlania tych rekordów lub wykonywania określonej akcji tego błędu.

Dotyczy: Microsoft Dynamics CRM 2011 r.
Oryginalny numer KB: 953962

Symptomy

Po uaktualnieniu do Microsoft Dynamics CRM 2011 r. użytkownik może napotkać poniższy błąd podczas próby wykonania akcji w Microsoft Dynamics CRM:

Zalogowany użytkownik nie ma odpowiednich uprawnień zabezpieczeń do wyświetlania tych rekordów ani wykonywania określonej akcji.

Jeśli śledzenie platformy Microsoft Dynamics CRM jest włączone, ślad platformy zawiera następujące informacje o błędzie:

Raport o błędach MSCRM:

--------------------------------------------------------------------------------------------------------
Błąd: Serwer nie może przetworzyć żądania.
Numer błędu: 0x80040220
Komunikat o błędzie: SecLib::CrmCheckPrivilege nie powiodło się. Zwrócona liczba godzin = -2147220960 identyfikatora użytkownika: <identyfikator> i identyfikator privilegeid: <identyfikator>

Uwaga

W tych przykładowych informacjach wartość UserId i wartość PrivilegeId są symbolami zastępczymi dla wartości rzeczywistych.

Przyczyna

Podczas uaktualniania do wersji Microsoft Dynamics CRM 2011 r. niestandardowe role zabezpieczeń nie są automatycznie przyznawane wszystkim nowym funkcjom. Tylko role out-of-the-box zostaną przyznane uprawnienia domyślne.

Ten problem może również wystąpić, jeśli roli użytkownika nie przyznano uprawnienia wymaganego do wykonania akcji. Taka sytuacja może wystąpić, jeśli spełniony jest jeden z następujących warunków:

  • Rola została utworzona od podstaw.
  • Rola została skopiowana z roli standardowej. Następnie rola była szeroko edytowana.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj następujące kroki.

Uwaga

Te kroki wymagają posiadania informacji ze śledzenia platformy Microsoft Dynamics CRM.

  1. W informacjach o błędzie wyświetlanych w śledzenia platformy Microsoft Dynamics CRM znajdź wartość PrivilegeId.

  2. Określ brakujące uprawnienie, uruchamiając zapytanie SQL, które używa wartości PrivilegeId. Na przykład uruchom zapytanie SQL podobne do następującego względem bazy danych OrganizationName_MSCRM:

    select Name, * from PrivilegeBase where PrivilegeId = 'a8ecac53-09e8-4a13-b598-8d8c87bc3d33'
    
  3. Aby przyznać użytkownikowi brakujące uprawnienia, wykonaj następujące kroki:

    1. Rozpocznij Microsoft Dynamics CRM 2011 r.
    2. Wybierz pozycję Ustawienia, wybierz pozycję Administracja w obszarze Ustawienia, a następnie wybierz pozycję Role zabezpieczeń.
    3. Kliknij dwukrotnie rolę przypisaną do użytkownika.
    4. Przyznaj brakujące uprawnienia roli użytkownika. Aby na przykład przyznać uprawnienie prvReadLead roli użytkownika, wybierz kartę Rekordy podstawowe , a następnie w wierszu Potencjalny klient wybierz odpowiednie uprawnienie Odczyt.
    5. Wybierz pozycję Zapisz i zamknij.