Przejdź do głównej zawartości
Pomoc techniczna
Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Objawy

W programie Microsoft Commerce Server 2007 lub Microsoft Commerce Server 2009 wybierz typ importu Zamień , aby wykonać importu katalogu. Jeśli istnieją dane katalogu, przywóz zajmuje bardzo dużo czasu do uzupełnienia. Na przykład po zaimportowaniu nowy katalog importu zajmie około 10 minut. Jeśli używasz Zamień typ importu do zaimportowania tego samego pliku wykazu ponownie po pierwszym imporcie importu trwa godzinę do uzupełnienia.

Przyczyna

Ten problem występuje, ponieważ ctlg_RepairCatalogsAfterImport wybiera planu kwerend nieefektywne dla procesu importowania katalogu.

Rozwiązanie

Informacje o poprawce

Obsługiwana poprawka jest udostępniana przez firmę Microsoft. Jednak ta poprawka jest przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Zastosuj poprawkę tylko w systemach, w których występuje problem opisany w tym artykule. Ta poprawka może być wciąż w fazie testowania. Jeśli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następną aktualizację oprogramowania zawierającą tę poprawkę. Jeśli poprawka jest dostępna do pobrania, pojawi się sekcja "Poprawka dostępna do pobrania" na początku tego artykułu z bazy wiedzy Knowledge Base. Jeśli nie ma tej sekcji, skontaktuj się z Obsługą i Wsparciem Klienta Microsoft w celu uzyskania poprawki. Uwaga Jeśli wystąpią dodatkowe błędy lub konieczność rozwiązania problemu, być może trzeba będzie utworzyć osobne zlecenie usługi. Zwykłe koszty obsługi będą zastosowane do dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu określonej poprawki. Aby uzyskać pełną listę numerów telefonów działu obsługi klienta firmy Microsoft lub utworzyć osobne zlecenie usługi odwiedź następujące witryny firmy Microsoft:

http://support.microsoft.com/contactus/?ws=supportUwaga "Poprawka dostępna do pobrania" zawiera listę języków, dla których dostępna jest poprawka. Jeśli odpowiedni język nie jest widoczny, to dlatego, że poprawka nie jest dostępna dla danego języka.

Wymagania wstępne

Musi mieć jedną z następujących wersji zainstalowane:

  • Microsoft Commerce Server 2007 z dodatkiem SP2

  • Microsoft Commerce Server 2009

Wymagania dotyczące ponownego uruchamiania

Nie trzeba ponownie uruchomić komputer. Jednakże należy ponownie uruchomić usługi Internet Information Services (IIS) i aplikacji Commerce Server Catalog importu hosta COM + po zastosowaniu tej poprawki. Aby ponownie uruchomić usługi IIS, w wierszu polecenia, wpisz następujące polecenie i naciśnij klawisz ENTER:

POLECENIE IISRESET/RESTART Uwaga Ta opcja zatrzymuje i ponownie uruchamia wszystkie usługi IIS są uruchomione.

Informacje o zastępowaniu

Ta poprawka nie zastępuje wcześniej wydanej poprawki.

Informacje dotyczące pliku

Wersja globalna tej poprawki używa pakietu Instalator systemu Microsoft Windows, aby zainstalować poprawkę. Daty i godziny odpowiadające tym plikom są wymienione w formacie uniwersalnego czasu koordynowanego (UTC, Coordinated Universal Time) w poniższej tabeli. Po wyświetleniu informacji dotyczących plików są one konwertowane na czas lokalny. Aby zobaczyć różnicę między czasem UTC i czasem lokalnym, należy użyć karty Strefa czasowa w elemencie Data i godzina w Panelu sterowania.

Microsoft Commerce Server 2007

Nazwa pliku

Wersja pliku

Rozmiar pliku

Data

Godzina

Platforma

Catalogcreate.sql

Nie dotyczy

1,153,421

25-Feb-2011

10:38

Nie dotyczy

Microsoft Commerce Server 2009

Nazwa pliku

Wersja pliku

Rozmiar pliku

Data

Godzina

Platforma

Catalogcreate.sql

Nie dotyczy

1,157,103

25-Feb-2011

10:38

Nie dotyczy

Cs2009hotfixhelper.exe

6.0.4171.40

13,080

28-Feb-2011

08:01

x86

Informacje dotyczące instalowania poprawki

Po wyodrębnieniu pakietu poprawek, można uzyskać następujące pliki:

  • Commerce Server 2007:

    • CommerceServer2007SP2-KB2513798-ENU.exe

    • KB2513798.sql

    Zainstaluj plik CommerceServer2007SP2-KB2513798-ENU.exe, aby zaktualizować pliku Catalogcreate.sql.

  • Commerce Server 2009:

    • CommerceServer2007SP3-KB2513798-ENU.exe

    • KB2513798.sql

    Zainstaluj plik CommerceServer2007SP3-KB2513798-ENU.exe, aby zaktualizować pliku Catalogcreate.sql.

Trzeba zainstalować odpowiednie poprawki, aby upewnić się, że ten problem nie występuje dla nowych baz danych wykazu. Dodatkowo należy uruchomić plik KB2513798.sql z istniejących baz danych wykazu, aby zaktualizować ich procedur przechowywanych.

Więcej informacji

Aby uzyskać więcej informacji na temat importowania katalogów Commerce Server odwiedź następującą stronę MSDN w sieci Web:

Jak zaimportować katalog

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.

Społeczności pomagają zadawać i odpowiadać na pytania, przekazywać opinie i słuchać ekspertów z bogatą wiedzą.

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?
Jeśli naciśniesz pozycję „Wyślij”, Twoja opinia zostanie użyta do ulepszania produktów i usług firmy Microsoft. Twój administrator IT będzie mógł gromadzić te dane. Oświadczenie o ochronie prywatności.

Dziękujemy za opinię!

×