Streszczenie

Format pliku MPX 4.0 jest format pliku ASCII, który można używać do transferowania informacji o projekcie między różnymi wersjami programu Microsoft Project, a także programów innych firm, które obsługują format pliku MPX, takich jak terminarza projektu Primavera i Timberline Precision szacowania.

Plik Mpxfile.wri (Windows) i plik formatu pliku MPX (Macintosh) opisują format MPX 4.0 pliki utworzone w programie Microsoft Project w wersji 4.0, 4.1 i 98. Te pliki można znaleźć w folderze, w którym zainstalowany jest program Microsoft Project version 4.0 lub 4.1. Sekcja "Więcej informacji" tego artykułu zawiera pełny tekst pliku Mpxfile.wri. (Uwaga: plik Mpxfile.wri nie jest dołączone do programu Microsoft Project 2000 lub Microsoft Project 98.)

W następującej tabeli podsumowano wersji programu Microsoft Project, które można utworzyć lub odczytać w formacie MPX 4.0:


Create Read
----------------
Microsoft Project 4.0 Yes Yes
Microsoft Project 4.1 Yes Yes
Microsoft Project 98 Yes Yes
Microsoft Project 2000 No Yes
Microsoft Project 2002 No Yes
Microsoft Project 2003 No Yes
Microsoft Project 2007 No Yes
Microsoft Project 2010 No Yes
Konwerter Microsoft Project to program opartych na systemie Windows, który służy do konwersji plików utworzonych w oprogramowanie do zarządzania projektami firm do formatu MPX 4.0. Aby uzyskać więcej informacji kliknij numery artykułów poniżej w celu wyświetlenia tych artykułów z bazy wiedzy Microsoft Knowledge Base:

130206 PRJ: konwerter programu Microsoft Project dla projektu 4.0 i 4.1

221256 PRJ: zaktualizowany konwerter projektu dla ABT projektu Workbench 4.x
Aby uzyskać informacje dotyczące rozwiązywania problemów z komunikatów o błędach, które występują podczas otwierania pliku MPX, który zawiera nieprawidłowe dane, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:

141261 PRJ: jak interpretować wiadomości odebrane podczas otwierania pliku .mpx

Więcej informacji

Oto pełny tekst pliku Mpxfile.wri.

Przy użyciu formatu pliku MPX

Informacje w formacie MPX

Format pliku MPX jest format pliku ASCII, które służy do przesyłania informacji o projekcie między programu Microsoft Project i innych aplikacjach obsługujących format pliku MPX, takich jak terminarza projektu Primavera i Timberline dokładność szacowania. Format pliku MPX umożliwia transfer informacji projektu nie pojawiają się w tabeli, na przykład informacji o przydziałach zasobów szczegółowe informacje kalendarza lub informacji w oknie dialogowym informacje o projekcie.

Przed zapisaniem pliku programu Microsoft Project w formacie MPX, sprawdź, czy aplikację, do której chcesz przenieść informacje o projekcie można zinterpretować formatu MPX. W niektórych przypadkach może być konieczne uruchomienie programu konwersji przed użyciem pliku w innej aplikacji.

Program Microsoft Project można również otwierać pliki zapisane w formacie MPX. Pliki MPX programu Microsoft Project wersja 4.1 dla systemu Windows 95 może Otwórz i Zapisz w programie Microsoft Project version 1.0, 3.0, 4.0 i 4.1.

Otwórz plik MPX, podobnie jak każdy inny plik programu Microsoft Project. Po otwarciu pliku MPX, można scalić plik aktywnego projektu lub umieszczaj je w nowym projekcie. Jeśli wybierz pliki należy połączyć i używasz unikatowych identyfikatorów, informacje w nowym pliku spowoduje zastąpienie informacji w pasujący rekord. Można tworzyć pliki MPX, zawierające tylko te informacje, które chcesz scalić istniejącego projektu plus przydziałów zasobów. Na przykład można utworzyć plik MPX, który zawiera tylko informacje o kosztach który uległ zmianie. Przy tym Unikatowy identyfikator i nowy koszt dla tego zestawu zasobów, tylko te informacje, jest zastępowany w projekcie.

Aby zapisać plik w formacie MPX, zobacz Eksportowanie projektu pliku w formacie MPX temat w Pomocy online. Podczas eksportowania pliku MPX nie określisz tabeli ponieważ używane są automatycznie tabel eksportu zadań i zasobów. Jeśli usuniesz tabel eksportu z GLOBAL. MPT, nie można wyeksportować pliku MPX, chyba że Kopiowanie tabel eksportu z kopii zapasowej pliku globalnego Global. MPT lub bieżącego projektu.

Można zmienić tabel eksportu Wybieranie tabel z menu Widok, wybierając więcej tabel, wybierając Eksportuj i klikając przycisk Edytuj; Jednakże należy robisz to tylko wtedy, gdy zalecił aplikacji, do którego będzie przeniesienie eksportowane dane. Tabele eksportu dostarczane z programem Microsoft Project są tabele standardowe używane przez większość aplikacji, które obsługują format pliku MPX.

Jeśli przychodzące zadania lub zasoby obejmują unikatowy identyfikator w pierwszym lub drugim miejscu oraz scalania dwóch plików, program Microsoft Project scala informacje pasujący rekord; Jeśli nie znaleziono, nowy rekord jest tworzony na koniec zadań lub zasobów. Jeśli nie są scalane plik otwierany i przychodzące zadania lub zasoby obejmują numer identyfikacyjny jako pierwszego pola, program Microsoft Project wstawia każdego zadania lub zasobu w wierszu z numerami Identyfikacyjnymi, aby numer identyfikacyjny każdego zadania lub zasobu w Microsof t projektu jest taki sam, jak oryginalny numer identyfikacyjny. Jeśli importowanego pliku Pomija numer identyfikacyjny, wiersz zadania lub zasobu z tego numeru Identyfikatora pozostaje puste, tak aby można było zaimportować pustych wierszy między zadań lub zasobów.

Istnieją następujące różnice między pliki MPX programu Microsoft Project version 3.0 i pliki MPX w wersji 4.0 i 4.1:

-Po otwarciu pliku MPX programu Microsoft Project, masz już wierszu polecenia, aby scalić plik istniejący projekt domyślnie. Jeśli chcesz scalić informacje w pliku MPX do bieżącego pliku należy określić to na liście parametrów polecenia FileOpen. Aby uzyskać instrukcje, jak to zrobić Wyszukaj w Pomocy temat scalania Format pliku MPX.

-Nowy rekord dodano do przechowywania informacji, używane przez funkcje grup roboczych.

-Nowy rekord dodano do przechowywania informacji o powtarzających się zadań.

-Położenie symbolu ustawienie w rekordzie ustawienia waluty teraz obsługuje jedną spację między symbol waluty i numer.

-Uwaga: nie ma żadnych różnic w formacie MPX programu Microsoft Project 4.1 version dla systemu Windows 95 i format pliku MPX programu Microsoft Project version 4.0.

Specyfikacje formatu pliku MPX

Ta sekcja jest przeznaczona dla deweloperów, którzy tworzą programy narzędziowe do przenoszenia informacji między innej aplikacji i program Microsoft Project. Jeśli przekazujesz pliki MPX między programu Microsoft Project i innej aplikacji, która już obsługuje pliki w formacie MPX nie trzeba przeczytaj tę sekcję.

Plik MPX składa się z rekordów oddzielone znaki powrotu karetki i wiersz źródła danych. W każdym rekordzie są pola, które zawierają informacje dotyczące projektu. Typy rekordów i kolejność tych rekordów są ustawione. Poniższa lista zawiera wszystkie typy rekordów, numer rekordu używany do identyfikowania każdego typu rekordu i liczba rekordów każdego typu, które mogą być zawarte w pliku MPX. Plik MPX nie musi zawierać wszystkich typów rekordów; wymagany tylko rekord jest rekordem Tworzenie pliku. Wszystkie rekordy uwzględnione w pliku MPX musi być w kolejności przedstawionej w tabeli, chyba że rekordy komentarza można wstawiać w dowolnym miejscu w pliku.

Record name Record number Maximum number of Records
----------------------------------------------------------------------------
File Creation (required) none 1
Currency Settings 10 1
Default Settings 11 1
Date and Time Settings 12 1
Base Calendar Definition 20 250
Base Calendar Hours 25 7 per Base Calendar
Definition record
Base Calendar Exception 26 250 per Base Calendar
Definition record
Project Header 30 1
Text Resource Table Definition 40 1
(Or you can use the Numeric Resource Table Definition record)
Numeric Resource Table Definition 41 1
Resource 50 9,999
Resource Notes 51 1 per Resource record
Resource Calendar Definition 55 1 per Resource record
Resource Calendar Hours 56 7 per Resource Calendar
Definition record
Resource Calendar Exception 57 250 per Resource Calendar
Definition record
Text Task Table Definition 60 1
(Or you can use the Numeric Task Table Definition record)
Numeric Task Table Definition 61 1
Task 70 9,999
Task Notes 71 1 per Task record
Recurring Task 72 1 per Task record
Resource Assignment 75 100 per Task record
Assignment Workgroup fields 76 1 per Assignment record
Project Names 80 500
DDE and OLE Client Links 81 500
Comments 0 unlimited
UWAGA:
Niektóre rekordy w pliku, należy wykonać inne rekordy. Rekordy w powyższej tabeli, które wymieniono maksymalną liczbę "na" poprzedni rekord musi znajdować się bezpośrednio po tym rekordem. Na przykład do 100 zasobów przypisania można wystawić na jeden rekord zadania. Jeśli zadanie ma 10 przydziałów zasobów, tych 10 rekordów przydziału zasobu musi znajdować się bezpośrednio po tym rekord zadania i przed następnym zadaniem rejestrowania.

Plik MPX zawsze zaczyna się od rekordu Tworzenie pliku; Ten rekord określa format pliku (MPX), znak separatora listy, używany do oddzielania pól w rekordach, aplikacji i numer wersji użyty do utworzenia MPX pliku, wersja formatu MPX, który używa pliku i strona kodowa używana do tworzenia pliku. Każdy rekord, z wyjątkiem rekordu Tworzenie pliku rozpoczyna się od numeru rekordu. Numer rekordu następuje znak separatora listy i informacje dla każdego z pól; Każde pole jest oddzielone znakiem separatora listy.

Ogólne zasady dotyczące zawartości pola są:

-Pola obliczeniowe nie trzeba można zaimportować, ponieważ będą one ignorowane.

-Jeśli znak separatora listy, zwykle przecinek lub średnik, znajduje się w polu, na przykład, aby oddzielić poprzedników, pole jest ujęty w znaki cudzysłowu.

-Jeśli pole zawiera znak cudzysłowu, dwa znaki cudzysłowu są używane.

-Znak separatora listy nie muszą być uwzględniane dla pustych pól na koniec rekordu.

-Znak separatora listy musi być włączona dla pustych pól między polami, które zawierają informacje.

-Podczas eksportowania pliku programu Microsoft Project w formacie MPX, daty i godziny są zapisywane w domyślnym formacie daty dla tabeli eksportu. Program Microsoft Project, można zaimportować daty wprowadzane w dowolnym z formatów dat podanych w oknie dialogowym Opcje. Informacji na temat formatów daty i godziny wyszukiwania Microsoft Project-Pomoc dla dat i przejdź do tematu daty.

-Microsoft Project ignoruje puste miejsce (spacje i tabulatory) na początku i na końcu pola podczas importowania pliku MPX.

-Puste importowanych pól nie zamieniaj istniejących informacji, scalając pliki MPX.

Zamówienia i dokładną zawartość pola w każdym rekordzie są opisane w poniższych definicjach rekordu. Numer rekordu, używany do identyfikacji typu rekordu następuje nazwa rekordu. W przykładzie w każdej definicji rekordu użyto przecinka jako znaku separatora listy.

Tworzenie pliku - żaden numer rekordu   Jest to wymagany rekord, który identyfikuje format pliku (MPX), znak separatora listy, używany w pliku, program i numer wersji użyty do utworzenia pliku, numer wersji formatu pliku MPX w pliku i strona kodowa używana do utworzenia pliku. Musi to być pierwszy rekord w pliku. Podczas eksportowania z programu Microsoft Project, znak separatora listy jest określony w aplecie Ustawienia regionalne w Panelu sterowania systemu Windows.

Pola zawarte w tym rekordzie są:
-MPX natychmiast następuje znak separatora listy
-Identyfikator nazwy program
-Wersja numer pliku
-Strona kodowa (850, 437, MAC, ANSI)

Przykład: MPX programu Microsoft Project, 3.0

W tym przykładzie określa się, że przecinek jest używany jako znaku separatora listy w tym pliku MPX i wersja formatu MPX w pliku są eksportowane z programu Microsoft Project version 3.0.

Ustawienia waluty - 10   Ten rekord określa ustawienia opcji waluty w oknie dialogowym Opcje. Jeśli wartości walutowych w pliku importu, określ ustawienia waluty w tym miejscu, tak aby dane zostaną zaimportowane prawidłowo. Jeżeli nie dołączono tego rekordu, są używane bieżące ustawienia w oknie dialogowym Opcje. Aby uzyskać informacji na temat ustawień waluty wyszukiwania Microsoft Project-Pomoc ustawienia domyślnej waluty. Separatory tysięcy i dziesiętne są określone w aplecie Ustawienia regionalne w Panelu sterowania systemu Windows.

Pola zawarte w tym rekordzie są:
-Symbol waluty
— Symbol pozycji (0 = po 1 = przed, 2 = po, ze spacją, 3 = przed, ze spacją)
-Cyfry waluty (0,1,2)
-Tysięcy separatora
-Separator części ułamkowej liczby

Przykład: 10, $, 1,2, ",".

W tym przykładzie określa, że wartości waluty zawierać znak dolara ($) przed nimi, że dwie cyfry są uwzględniane po przecinku, że przecinek jest używany jako separatory tysięcy i że okres jest używany jako przecinka dziesiętnego. Ponieważ znak separatora listy jest uwzględniony w polu Separator tysięcy, pole jest ujęte w znaki cudzysłowu.

Domyślne ustawienia - 11   Ten rekord określa ustawienia domyślne opcje w oknie dialogowym Opcje. Jeśli czas trwania, który importujesz nie zawiera skróconą nazwę czasu trwania, należy określić długość Jednostka domyślna w tym polu, aby jednostki czasu trwania są poprawne. Jeżeli nie dołączono tego rekordu, są używane bieżące ustawienia w oknie dialogowym Opcje. Aby uzyskać informacji na temat opcji domyślnych Wyszukaj Microsoft Project-Pomoc długość wartości domyślne.

Pola zawarte w tym rekordzie są:
-Domyślnymi jednostkami czasu trwania (0 = minuty, 1 = 2 godziny, dni, = 3 = tygodni)
-Domyślnego typu czasu trwania (0 = nie ustalona, 1 = stałej)
-Domyślne jednostki pracy (0 = minuty, 1 = 2 godziny, dni = 3 = tygodni)
-Domyślne godziny dziennie
-Domyślnych godzin w tygodniu
-Domyślna stawka zasadnicza
-Domyślna stawka za pracę w nadgodzinach
-Aktualizacja stanu zadania aktualizuje stan zasobów (0 = nie, 1 = yes)
-Podziel zadania w trakcie wykonywania (0 = nie, 1 = yes)

Przykład: 11,2,0,1,8,40, 10 zł/h, 15 zł/h, 1

W tym przykładzie określa następujące ustawienia domyślne: czasy trwania w dni i nie są stałe, są jednostki pracy w godzinach, istnieje osiem godzin w pracy i 40 godzin w tygodnia roboczego, stawka płacy standardowych wynosi 10 zł za godzinę, stawka płacy za pracę w nadgodzinach wynosi 15 zł za godzinę , a zaznaczono pole wyboru Aktualizacja stanu zadania aktualizuje zasób stan.

Format MPX 1.0: tylko liczby całkowite są dozwolone dla domyślnych godzin na dobę i domyślnych godzin w tygodniu w programie Microsoft Project version 1.0, podczas tworzenia pliku w formacie MPX 1.0 wartość niebędąca dla obu opcji jest zaokrąglana do najbliższej liczby całkowitej. Opcje nie w programie Microsoft Project version 1.0 nie są zapisywane podczas tworzenia pliku w formacie MPX 1.0.

Ustawienia daty i godziny - 12   Ten rekord określa ustawienia daty i czasu opcje w oknie dialogowym Opcje oraz opcję pasek formatu daty tekst w oknie dialogowym Układ. Jeżeli nie dołączono tego rekordu, są używane bieżące ustawienia w oknie dialogowym Opcje. Dla informacji na temat ustawienia daty i godziny Przeszukaj Pomoc dla dat i przejdź do tematu daty.

Pola zawarte w tym rekordzie są:
-Data zamówienia (0 = miesiąc/dzień/rok, 1 = dzień/miesiąc/rok, 2 = dzień/miesiąc/rok)
-Format czasu (0 = 12 godzin, 1 = 24 godziny)
-Domyślny czas (liczba minut po północy)
-Separator daty
-Separator godziny
-0:00 do 11:59 tekstu
-12:00 do 23:59 tekstu
-Format daty (0 -14) *
-Format daty tekst paska (0-194) *

* Brak dostępnych 20 różnych formatów dat. Aby wyświetlić datę formaty dostępne w menu Narzędzia wybierz polecenie Opcje, kliknij kartę Widok i wybierz żądaną opcję daty z listy Format daty. Aby uzyskać więcej informacji Wyszukaj w Pomocy temat dat, a przejdź do tematu daty.

Przykład: 12,0,0,480 /,:, am, pm

Ten przykład określa, że dzień, miesiąc i rok są oddzielone kreską ułamkową, godziny i minuty rozdzielone dwukropkiem, że daty są w kolejności miesiąc/dzień/rok, że czasy są w formacie 12-godzinnym, to domyślna godzina 8:00 A.M. (lub 480 minut po północy) , i że "am" i "pm" są używane do wskazywania rano i wieczorem.

Kalendarz bazowy definicji - 20   Te rekordy zdefiniować kalendarze bazowe i ich pracy i czas wolny dni tygodnia. Scalając plik MPX, informacje kalendarza są scalane z aktywnym projektem i zastępowane są kalendarze o tej samej nazwie. Ustawienia domyślne są używane, jeśli nie ma wpisu na dzień. Ustawienia domyślne są od poniedziałku do piątku w dniu roboczym i sobota i w niedziele dla dni wolnych od pracy. W tym rekordzie pole nazwy jest wymagane. Dla każdego z dni zapis o wartości 0 wskazuje, że ten dzień jest dniem wolnym i wpis 1 wskazuje, że ten dzień jest dniem roboczym.

Pola zawarte w tym rekordzie są:
-Nazwa
-Niedziela
-Poniedziałek
-Wtorek
-Środa
-Czwartek
-Piątek
-Sobota

Przykład: 20, pisarzy, 0, 1, 1, 1, 1, 1, 0

W tym przykładzie określa, że od poniedziałku do piątku są dni roboczych i sobota i niedziela są dni wolne kalendarza podstawowego o nazwie modułów zapisujących.

Kalendarz bazowy godzin - 25   Te rekordy określić godzin pracy dla dni tygodnia, jeżeli różnią się od ustawień domyślnych. Domyślne godziny robocze są godzinę 13:00 do 17:00 a 8:00 do 12:00. Każdy rekord godzin kalendarz Base odwołuje się do w poprzednim rekordzie definicji kalendarza bazy. Do siedmiu tych rekordów można śledzić każdego rekordu definicji kalendarza bazy.

-Dzień tygodnia (1-7, gdzie 1 = niedziela i 7 = sobota)
-Od godziny 1
-Do godziny 1
-Od godziny 2
-Do godziny 2
-Od godziny 3
-Do godziny 3

Przykład: 25,2, 7:00 11:00, 12:00, 4:00

W tym przykładzie określa, że w poniedziałki, godziny pracy są od 7:00 do 11:00 do 12:00:00 do 4:00.

Wyjątek kalendarza bazowego - 26   Te rekordy zdefiniuj wyjątki do dni i godzin, określonego w poprzednich dwóch typów rekordów. Do 250 tych rekordów można śledzić każdy rekord Base definicji kalendarza. Te rekordy muszą być wymienione w porządku chronologicznym. Jeśli wyjątek jest jeden dzień, do chwili pole może pozostać puste. Jeśli nie są pokazywane, używane są czasy domyślne o godzinie 8:00 do 12:00 i godzinę 13:00 do 17:00.

Pola zawarte w tym rekordzie są:
-Od daty
— Do daty
-Wolny/Praca (0 = wolny od pracy, 1 = praca)
-Od godziny 1
-Do godziny 1
-Od godziny 2
-Do godziny 2
-Od godziny 3
-Do godziny 3

Przykład 1: 26,12/24/95,12/25/95,0
Przykład 2: 26,10/4/95,, 1, 8:00 12:30

Przykład 1 dzięki 24 grudnia i 25, 1995, dni wolne od pracy.
Przykład 2 sprawia, że niedziela, 4 października, 1995, dzień roboczy od godziny 8:00 do 12:30 P.M.
Przykład 2 wymaga dodatkowych przecinek do przechowywania miejsce polu do dnia.

Format MPX 1.0: ponieważ tylko 50 wyjątki są dozwolone w programie Microsoft Project w wersji 1.0, wszystkie wyjątki po pierwszych 50 zostaną zignorowane podczas tworzenia pliku w formacie MPX 1.0.

Nagłówek projektu - 30   Ten rekord ustawia pól projektu globalnego, takie jak Data rozpoczęcia projektu i project Data zakończenia. Pola w tym rekordzie odpowiadają informacjom zawartym w oknach dialogowych informacje o projekcie i statystyki.

Pola i karty zawarte w tym rekordzie są:
-Karty Projekt
-Firma
-Manager
-Kalendarz (Standard używany, jeśli nie ma wpisu)
-Data rozpoczęcia (to pole lub pola next jest obliczana dla importowanego pliku, w zależności od ustawienia harmonogramu z)
-Data zakończenia
-Harmonogram od (0 = start, 1 = Zakończ)
-Bieżąca data *
-Komentarze
- Cost*
-Koszt według planu bazowego *
-Rzeczywisty koszt *
- Work*
-Praca według planu bazowego *
-Rzeczywistej pracy *
- Work*
- Duration*
-Według planu bazowego długość *
-Rzeczywisty czas trwania *
-Wykonano % *
-Rozpoczęcie według planu bazowego *
-Zakończenie według planu bazowego *
— Start wartości rzeczywiste *
-Rzeczywiste zakończenie *
-Start odchylenie *
-Zakończenie odchylenie *
-Temat
-Autora
-Słowa kluczowe

* Te pola są obliczane przez program Microsoft Project, więc importowane wartości są ignorowane.

Przykład: 30, zegary wystawy, muzeum narodowego, Michael Edwards, Standard, 1/2/95

W tym przykładzie wykazują zegary projektu Muzeum Narodowego zarządza Dyszkiewicz Michael, wykorzystuje standardowy kalendarz i rozpoczyna się od dnia 2 stycznia 1995 r..

MPX 1.0 i 3.0 formaty: pola nie w programie Microsoft Project version 1.0 lub 3.0 nie są zapisywane podczas tworzenia pliku w formacie 3.0 lub MPX 1.0.

Tekst zasobu definicji tabeli - 40   Ten rekord zawiera listę pól zasobu, w kolejności, które są przywożone lub wywożone. Importowane pliki nazwy musi odpowiadać nazwy pól używane w programie Microsoft Project. Dla eksportowanych plików ten rekord pochodzi z tabeli eksportu zasobów. Należy użyć tego rekordu lub rekord liczbowe definicji tabeli zasobów opisane w dalszej części. Podczas eksportowania z programu Microsoft Project, obie te rekordy są uwzględniane. Pełny opis dostępnych pól wyszukiwania Microsoft Project-Pomoc dla tabeli eksportu i przejdź do podsumowanie Eksportowanie tabeli (zasób) lub temat podsumowanie Eksportowanie tabeli (zadania).

Dla tego rekordu listy nazw pól zasobu, który chcesz, oddzielając je znakiem separatora listy.

Przykład: 40, nazwa, max jednostek, Stawka zasadnicza

W tym przykładzie określa, że każdy rekord zasobu w pliku zawiera nazwę zasobu, maksymalną liczbę jednostek i standardowej stawki.

UWAGA:
Dla importowanych plików Jeśli nie scalaj nowy plik, otwórz projekt i identyfikator jest pierwszego pola wymienionego po numer rekordu w rekordzie tekstowe lub liczbowe definicji tabeli Zasób, rekordy zasobów są importowane z tym samym numerem ID jak wskazano w rekordzie. Na przykład jeśli importowane pierwszy rekord zasobu ma numer identyfikacyjny 1 i drugi rekord importowanego zasobu ma numer identyfikacyjny 3, rekordy są importowane do programu Microsoft Project jako zasoby 1 i 3, pozostawienie pustego zasobu 2. Jeśli korespondencji seryjnej i pola Unikatowy identyfikator jest pierwszego pola lub drugiego pola następującego pola Identyfikator programu Microsoft Project będzie Wyszukaj rekord z tym samym Identyfikatorem unikatowy i zastąpić istniejące informacje o nowe informacje. Jeśli nie znaleziono, nowy rekord jest dodawany na końcu listy.

MPX 1.0 i 3.0 formaty: pól programu Microsoft Project w wersji 1.0 lub 3.0 nie są zapisywane podczas tworzenia pliku w formacie MPX 1.0.

Plik MPX musi mieć co najmniej dwa zadania i dwa pola zasobów.

Definicja tabeli Zasób liczbowe - 41   Za pomocą numerów, a nie nazwy, ten rekord zawiera listę pól zasobu, w kolejności, które są przywożone lub wywożone. To jest alternatywna metoda identyfikacji pola zasobów zawarte w każdym rekordzie zasobu i przydaje się podczas definiowania pliku MPX stworzone przez produkt języka obcego.

Poniższa tabela pokazuje numery pól dla wszystkich pól zasobu w programie Microsoft Project. Pełny opis dostępnych pól wyszukiwania Microsoft Project-Pomoc dla tabeli eksportu i przejdź do tematu podsumowanie Eksportowanie tabeli (zasób).

Dla tego rekordu listy Numery pól zasobu, który chcesz, oddzielając je znakiem separatora listy.

Field Number
------------------------------
% Work Complete 26
Accrue At 45
Actual Cost 32
Actual Work 22
Base Calendar 48
Baseline Cost* 31
Baseline Work* 21
Code 4
Cost* 30
Cost Per Use 44
Cost Variance* 34
Email Address 11
Group 3
ID 40
Initials 2
Linked Fields* 51
Max Units 41
Name 1
Notes 10
Objects* 50
Overallocated* 46
Overtime Rate 43
Overtime Work* 24
Peak* 47
Remaining Cost* 33
Remaining Work* 23
Standard Rate 42
Text1 5
Text2 6
Text3 7
Text4 8
Text5 9
Unique ID 49
Work* 20
Work Variance* 25

* When creating a file to be imported into Microsoft Project, you do not have to
include this field as it will be ignored.
Przykład: 41,1,41,42

W tym przykładzie wyświetla listę numerów pola, które odpowiadają polom pokazano w poprzednim przykładzie (nazwa, maksymalna liczba jednostek i standardowej stawki).

MPX 1.0 i 3.0 formaty: pola nie w programie Microsoft Project version 1.0 lub 3.0 nie są zapisywane podczas tworzenia pliku w formacie 3.0 lub MPX 1.0.

Zasób - 50   Te rekordy zawierają informacje o poszczególnych zasobach, importowane lub eksportowane. Każdy rekord zasobu opisuje jeden zasób. Po zaimportowaniu informacji pola, które są uwzględniane są definiowane przez rekordu definicji tabeli Zasób tekstu lub rekord liczbowe definicji tabeli zasobów. Podczas eksportowania informacji, pola, które są uwzględniane są wymienione w tabeli eksportu zasobów.

Dla tego rekordu listy wartości pola dla danego zasobu, oddzielając je znakiem separatora listy.

Przykład: 50, stolarz, 4, 10 zł/h

W tym przykładzie wyświetlane informacje o stolarz zasobu, który odpowiada definicji tabeli zasobów określonych w poprzednim przykładzie. Maksymalna liczba jednostek wynosi cztery a Standardowa stawka wynosi 10 zł za godzinę.

Format MPX 1.0: pola tekstowe, które są zbyt długie są obcinane podczas tworzenia pliku w formacie MPX 1.0. Tylko 2000 zasoby zostaną zapisane w formacie MPX 1.0.

Uwagi o zasobie - 51   Te rekordy zawierają uwagi dotyczące bezpośrednio poprzedzającego rekordu zasobu. Umożliwia wskazanie nowy wiersz w obrębie notatki 127 znaków ASCII. Jeśli notatka zawiera znak separatora listy, notatki należy ująć w znaki cudzysłowu.

Format MPX 1.0: Jeżeli notatka jest zbyt długa, jest obcinana podczas tworzenia pliku w formacie MPX 1.0.

Definiowanie kalendarz zasobu - 55   Te rekordy zdefiniować dni roboczych dla zasobu określonego w rekordzie zasobu bezpośrednio poprzedzającego. Dla importowanych plików Jeśli nie ma żadnego wpisu w polu Nazwa kalendarza Base standardowy jest używany. Brak wpisu dla konkretnego dnia wskazuje, że dzień jest ustawiona na wartość domyślna (2). Jeśli nie ma żadnych rekordów definicji kalendarza zasobu, Standard jest używany jako kalendarz bazowy zasobu, z domyślne używane przez dni. Dla każdego z dni zapis o wartości 0 wskazuje, że ten dzień jest dniem wolnym, 1 wskazuje, że ten dzień jest dniem roboczym i 2 określa, że używana jest wartość domyślna. Informacje o kalendarzach zasobów wyszukiwania Microsoft Project-Pomoc dla kalendarza zasobu i przejdź do tematu polecenia Change pracy czas.

Pola zawarte w tym rekordzie są:
-Nazwa kalend.
-Niedziela
-Poniedziałek
-Wtorek
-Środa
-Czwartek
-Piątek
-Sobota

Przykład: 55, standardowy, 2, 2, 2, 2, 2, 0, 2

W tym przykładzie określa, że zasób zdefiniowany bezpośrednio poprzedzających ten rekord (w tym przypadku stolarz) ma taką samą dni roboczych i godzin jako standardowy kalendarz bazowy dla od niedzieli do soboty i czwartek, ale nie działa w piątki.

Godzin kalendarza zasobu - 56   Te rekordy Definiowanie godzin pracy dla zasobu, które różnią się od kalendarza bazowego używanego przez zasób. Zapisy te dotyczą rekordu definicji kalendarza zasobu bezpośrednio poprzedzających ten rekord. Do siedmiu tych rekordów można śledzić każdego rekordu definicji kalendarza zasobu.

Pola zawarte w tym rekordzie są:
-Dzień tygodnia (1-7, gdzie 1 = niedziela i 7 = sobota)
-Od godziny 1
-Do godziny 1
-Od godziny 2
-Do godziny 2
-Od godziny 3
-Do godziny 3

Przykład: 56,3, 7:00 11:00, 12:00, 4:00

W tym przykładzie określa, że we wtorki bezpośrednio poprzedzającego zasobów (w tym przypadku stolarz) działa od 7:00 do 4:00 z godzinną od 11:00 do 12:00

Wyjątek kalendarza zasobów - 57   Te rekordy zdefiniuj wyjątki do dni i godzin, określonego w poprzednich dwóch typów rekordów. Do 250 tych rekordów można śledzić każdego rekordu definicji kalendarza zasobu. Te rekordy muszą być wymienione w porządku chronologicznym. Jeśli wyjątek jest tylko jeden dzień, do chwili pole może pozostać puste. Jeśli nie są pokazywane, używane są czasy domyślne o godzinie 8:00 do 12:00 i godzinę 13:00 do 17:00.

Pola zawarte w tym rekordzie są:
-Od daty
— Do daty
-Wolny/Praca (0 = wolny od pracy, 1 = Praca, 2 = domyślnie)
-Od godziny 1
-Do godziny 1
-Od godziny 2
-Do godziny 2
-Od godziny 3
-Do godziny 3

Przykład: 57,11/9/95,11/13/95,0

W tym przykładzie określa, że ten zasób (w tym przypadku stolarz) nie działa z dnia 9 listopada 1995 r. do dnia 13 listopada 1995 r.

Format MPX 1.0: ponieważ tylko 50 wyjątki są dozwolone w programie Microsoft Project w wersji 1.0, wszystkie wyjątki po pierwszych 50 zostaną zignorowane podczas tworzenia pliku w formacie MPX 1.0.

Definicja tabeli zadań tekstu - 60   Ten rekord zawiera listę zadań pól, w kolejności, które są przywożone lub wywożone. Importowane pliki nazwy musi odpowiadać nazwy pól używane w programie Microsoft Project. Jeśli jest eksportowany plik, ten rekord pochodzi z tabeli eksportu zadania. Można użyć tego rekordu lub rekord liczbowe definicji tabeli Zadanie opisane w dalszej części, ale jednego lub drugiego jest wymagane. Podczas eksportowania z programu Microsoft Project, obie te rekordy są uwzględniane. Pełny opis dostępnych pól wyszukiwania Microsoft Project-Pomoc dla tabeli eksportu i przejdź do podsumowanie Eksportowanie tabeli (zasób) lub temat podsumowanie Eksportowanie tabeli (zadania).

Pola, które są obliczane przez program Microsoft Project, takich jak Zaplanowane rozpoczęcie i Zakończenie według harmonogramu, są ignorowane, jeśli importowane. Jeśli masz zadania rozpoczęcie lub zakończenie dat, które są rozwiązywane, należy użyć pola Typ ograniczenia i datą ograniczenia.

Dla tego rekordu listę nazw pól zadań, których potrzebujesz, oddzielając je znakiem separatora listy.

Przykład: 60, nazwa, czas trwania, poprzedniki

W tym przykładzie określa, że każdy rekord zadania w pliku zawiera nazwę zadania, czas trwania i poprzedników.

UWAGA:
Dla importowanych plików Jeśli nie scalaj nowy plik, otwórz projekt i identyfikator zadania jest pierwszego pola wymienionego po numer rekordu w rekordzie tekstowe lub liczbowe definicji tabeli zadanie rekordy zadania są importowane z tym samym numerem ID zadania jak wskazano w rekordzie. Na przykład jeśli pierwszy rekord importowanego zadania ma numer Identyfikatora zadania 1 i drugi rekord importowanego zadania ma numer Identyfikatora zadania 3, rekordy są importowane do programu Microsoft Project jako zadanie 1 i zadanie 3, pozostawiając puste zadanie 2. Jeśli korespondencji seryjnej i pola Unikatowy identyfikator jest pierwszego pola lub drugiego następującego pola pole Identyfikator zadania programu Microsoft Project będzie Wyszukaj rekord z tym samym Identyfikatorem unikatowy i zastąpić istniejące informacje o nowe informacje. Jeśli nie znaleziono, nowy rekord jest dodawany na końcu listy. Jeśli scalanie na unikatowe identyfikatory i chcesz zachować odpowiednie relacje, zawierają unikatowe Identyfikatory poprzedników jako pole ma zostać zaimportowany, a następnie usuń poprzedniki.

W przypadku scalania w nowym pliku, jeśli chcesz zachować przydziały zasobów musi zawierać rekord 75. Jeśli nie, przydziały zasobów zostaną usunięte.

MPX 1.0 i 3.0 formaty: pola nie w programie Microsoft Project version 1.0 lub 3.0 nie są zapisywane podczas tworzenia pliku w formacie 3.0 lub MPX 1.0. Pole priorytety w wersji 4.0 i 4.1 mapy do wersji 1.0 i 3.0 w następujący sposób: nie bilansuj i najwyższa stają się najwyższa; Bardzo wysoki, wyższego i wysoko stają się wysoki; Nośnik jest Medium; Niski, małe i bardzo niska stają się niska; a najniższy jest najmniejszy.

Plik MPX musi mieć co najmniej dwa zadania i dwa pola zasobów.

Definicja tabeli zadanie numeryczne - 61   Za pomocą numerów, a nie nazwy, ten rekord zawiera listę zadań pola w kolejności, które są przywożone lub wywożone. To jest alternatywna metoda identyfikacji pola zadania włączone do każdego zapisu zadania i przydaje się podczas definiowania pliku MPX stworzone przez produkt języka obcego.

Poniższa tabela pokazuje numery pól dla wszystkich pól zadań w programie Microsoft Project. Pełny opis dostępnych pól Wyszukaj w Pomocy temat tabeli eksportu i przejdź do tematu podsumowanie Eksportowanie tabeli (zadania).

Dla tego rekordu wykaz numerów pól zadań, które mają być oddzielone znakiem separatora listy.


Field Number
------------------------------
% Complete 44
% Work Complete 25
Actual Cost 32
Actual Duration 42
Actual Finish 59
Actual Start 58
Actual Work 22
Baseline Cost 31
Baseline Duration 41
Baseline Finish 57
Baseline Start 56
Baseline Work 21
BCWP 86
BCWS 85
Confirmed 135
Constraint Date 68
Constraint Type 91
Contact 15
Cost 30
Cost1 36
Cost2 37
Cost3 38
Cost Variance* 34
Created* 125
Critical* 82
CV* 88
Delay 92
Duration 40
Duration1 46
Duration2 47
Duration3 48
Duration Variance* 45
Early Finish* 53
Early Start* 52
Finish 51
Finish1 61
Finish2 63
Finish3 65
Finish4 127
Finish5 129
Finish Variance* 67
Fixed 80
Fixed Cost 35
Flag1 110
Flag2 111
Flag3 112
Flag4 113
Flag5 114
Flag6 115
Flag7 116
Flag8 117
Flag9 118
Flag10 119
Free Slack* 93
Hide Bar 123
ID 90
Late Finish* 55
Late Start* 54
Linked Fields* 122
Marked 83
Milestone 81
Name 1
Notes 14
Number1 140
Number2 141
Number3 142
Number4 143
Number5 144
Objects* 121
Outline Level 3
Outline Number 99
Predecessors 70
Priority 95
Project 97
Remaining Cost 33
Remaining Duration 43
Remaining Work 23
Resource Group* 16
Resource Initials 73
Resource Names 72
Resume 151
Resume No Earlier Than 152
Rollup 84
Start 50
Start1 60
Start2 62
Start3 64
Start4 126
Start5 128
Start Variance* 66
Stop 150
Subproject File 96
Successors 71
Summary* 120
SV* 87
Text1 4
Text2 5
Text3 6
Text4 7
Text5 8
Text6 9
Text7 10
Text8 11
Text9 12
Text10 13
Total Slack* 94
Unique ID 98
Unique ID Predecessors 74
Unique ID Successors 75
Update Needed 136
WBS 2
Work 20
Work Variance* 24

* When creating a file to be imported into Microsoft Project, you do not have to
include this field as it will be ignored. If you have start or finish dates that are
fixed, use the Constraint Type and Constraint Date fields.
Przykład: 61,1,40,70

W tym przykładzie wyświetla listę numerów pola, które odpowiadają polom w poprzednim przykładzie (nazwa, czas trwania i poprzedników).

MPX 1.0 i formacie 3.0: pola nie w programie Microsoft Project version 1.0 lub 3.0 nie są zapisywane podczas tworzenia pliku w formacie 3.0 lub MPX 1.0.

Zadanie - 70   Rejestry te zawierają informacje dla każdego zadania importowane lub eksportowane. Rekord każdego zadania opisuje jedno zadanie. Po zaimportowaniu informacji pola, które są uwzględniane są definiowane przez rekord tekstu definicji tabeli zadań lub rekord liczbowe definicji tabeli zadań. Podczas eksportowania informacji, pola, które są uwzględniane są wymienione w tabeli eksportu zadania.

Dla tego rekordu listy wartości pola zadania, oddzielając je znakiem separatora listy.

Przykład: 70, wlać cementu, 6d

W tym przykładzie pokazuje informacje o zadaniu "Pour cementu", który odpowiada definicji tabeli zadań określonych w poprzednim przykładzie. Czas trwania zadania wynosi 6 dni.

Format MPX 1.0: większa niż pięć są zapisywane jako poziom pięć poziomów konspektu. Pola tekstowe, które są zbyt długie, są obcinane. Tylko 2000 zadania są zapisywane.

Uwagi o zadaniu - 71   Te rekordy zawierają uwagi dotyczące bezpośrednio poprzedzającego rekord zadania. Umożliwia wskazanie nowy wiersz w obrębie notatki 127 znaków ASCII. Jeśli notatka zawiera znak separatora listy, notatki należy ująć w znaki cudzysłowu.

Format MPX 1.0: Jeżeli notatka jest zbyt długa, jest obcinana podczas tworzenia pliku w formacie MPX 1.0.

Cykliczne zadanie - 72   Informacje te wskazują, czy zadanie jest zadaniem cyklicznym.

Pola zawarte w tym rekordzie, jeśli zadanie jest cykliczne zadanie nadrzędne są:
-Start wystąpień wprowadzoną w oknie dialogowym informacje powtarzające się zadania.
-Datę wprowadzoną w oknie dialogowym informacje powtarzające się zadanie zakończenia.
-Czas trwania każdego wystąpienia.
-Typ czas trwania (dzień, miesiąc, itp.).
-Liczba wystąpień.
-Wybrany typ. (1 - CODZIENNIE, 4 - TYGODNIOWY, 8 - MIESIĘCZNYCH, 16 - co rok) w oknie dialogowym informacje powtarzające się zadania.
— Indeks kombi w oknie dialogowym codziennie (1 dla każdego, 2 dla każdego innego itp.).
-Combo indeks w polu co tydzień.
— Indeks kombi (pierwszy, drugi, trzeci...) w polu miesięcznych.
-Combo indeks (poniedziałek, wtorek...) w polu miesięcznych.
-Combo indeksu (co, co inne), jeśli dolny przycisk opcji jest zaznaczony w polu miesięcznych.
-Wartość dni w polu miesięcznych.
-Combo indeksu (co, co inne...), po zaznaczeniu przycisku opcji top w polu miesięcznych.
— Indeks kombi (pierwszy, drugi...) w polu roczny.
-Combo indeks (poniedziałek,...) w polu roczny.
-Combo indeksu (styczeń, luty..) w polu roczny.
— Data podana w polu roczny.

Jeśli zadanie jest cykliczne zadanie podrzędne, pole zawarte w tym rekordzie jest:
-Unikatowy identyfikator obiektu nadrzędnego

Przykład: 72,1

W tym przykładzie określa, że zadanie jest podrzędnego zadania cyklicznego i że nadrzędnego zadania cyklicznego ma unikatowy ID 1.

Przydział zasobu - 75   Te rekordy listy informacji dotyczących zasobów przydzielonych do zadania, który został zdefiniowany w poprzednim rekordzie zadania. Jeśli scalasz pliki, i chcesz zachowane informacje o przydziałach zasobów, konieczne jest uwzględnienie informacji w pliku MPX. W przypadku scalania wszystkich istniejących przydziałów zadań scalone zostaną usunięte. Jeśli scalasz pliki oparte na unikatowych identyfikatorów zasobów są przypisywane przy użyciu unikatowych identyfikatorów zasobów, a nie identyfikatorów.

Pola zawarte w tym rekordzie są:
-ID
-Jednostki
-Praca
-Planowanej pracy
-Rzeczywista praca
-Praca w nadgodzinach
-Koszt
-Planowany koszt
— Koszt rzeczywisty
- Start*
- Finish*
-Opóźnienia
-Unikatowy identyfikator zasobu

* Ponieważ te pola są obliczane przez program Microsoft Project, importowane wartości są ignorowane.

Przykład: 75,3,0.5, 40h

W tym przykładzie określa przypisania zasobów z numerem Identyfikacyjnym 3 bezpośrednio poprzedzającego zadania. Jeśli przychodzące zasobów nie mają numerów ID, trzeci zasobów przychodzących jest przypisany. W tym przykładzie zasób jest przydzielony do zadania "Wylewanie cementu" dla 40 godzin pracy z 0,5 jednostki.

Format MPX 1.0: pole Opóźnienie jest ignorowana, jeśli tworzysz plik w formacie MPX 1.0.

Pola grupy roboczej przydziału zasobu - 76   Te rekordy listy informacji, który jest przechowywany z każdego przydziału dla funkcji grup roboczych programu Microsoft Project 4.0 i 4.1. Jeśli używasz funkcji grupy roboczej, konieczne jest uwzględnienie tego rekordu, aby mieć pewność, że żadne informacje zostaną utracone.

Pola zawarte w tym rekordzie są:
-Unikatowy identyfikator wiadomości
-Potwierdzone (0 = False, 1 = True)
-Oczekiwanie na odpowiedź (0 = False, 1 = True)
-Update rozpoczęcie (Data)
-Update zakończenie (Data)
-ID programu Schedule+

Przykład: 76,1,0,1,6/1/95,6/2/95

W tym przykładzie określa, że przydział zasobu określonego w rekordzie powyżej przydziału (75) ma unikatowy ID 1 wiadomość, nie potwierdził przypisania nie odpowiedział do ostatniej wiadomości wysłane i została notyfikowana że zadanie daty rozpoczęcia i zakończenia są 1-6/95 i 6/2/95.

Nazwy projektów - 80   Te rekordy listę wszystkich nazw łącza DDE, które są przechowywane w projekcie.

Pola zawarte w tym rekordzie są:
-Nazwa
-Opis

Przykład: 80,DDE_Link_T1,"T((1,3,5),(Name,Duration))"

W tym przykładzie wyświetla listę łączy DDE, o nazwie DDE_Link_T1 i jego opis. Aby uzyskać więcej informacji na temat mechanizmu DDE Wyszukaj w Pomocy temat DDE i przejdź do definicji tematu dynamicznej wymiany danych (DDE, Dynamic Data Exchange). Ponieważ znak separatora listy jest uwzględniony w opisie, pole jest ujęte w znaki cudzysłowu.

Format MPX 1.0: Jeśli są zapisywane w formacie MPX 1.0, ten rekord nie jest zapisywany.

Mechanizm DDE i łącza klienta OLE - 81   Te rekordy listę wszystkich łączy DDE do projektu.

-Źródła
-Łącze do

Przykład: 81,Winword|d:\winword\MPX.doc! DDE_Link1,"T(1,Name)"

W tym przykładzie Winword|d:\winword\MPX.doc! Argument łącze z DDE_Link1, i T(1,Name) jest argumentem łącze do. Ponieważ znak separatora listy jest uwzględniony w łącze do, pole jest ujęte w znaki cudzysłowu. OLE łącza klienta różnią się od łącza DDE klienta przez ustawienie pierwszego znaku ":". Na przykład: 81,:\LINK_1,"T(2,1)", ":" na początku łącze z argument wskazuje łącze OLE.

Format MPX 1.0: Jeśli są zapisywane w formacie MPX 1.0, ten rekord nie jest zapisywany.

Komentarze - 0   Te rekordy można dodawać komentarze do pliku i mogą pojawiać się w dowolnym miejscu w pliku. Każdy rekord komentarze musi zaczynać się od "0".

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów firmy Microsoft

Czy te informacje były pomocne?

Jak zadowalająca jest jakość tłumaczenia?

Co wpłynęło na Twoje wrażenia?

Czy chcesz przekazać jakieś inne uwagi? (Opcjonalnie)

Dziękujemy za opinię!

×