Reguły biznesowe (przenośna logika biznesowa) mogą nie działać poprawnie lub tworzyć błędy, gdy użytkownik uruchamia przepływy procesów biznesowych bez wystarczających uprawnień w jednostce Proces

Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że reguły biznesowe (przenośna logika biznesowa) mogą nie działać zgodnie z oczekiwaniami lub występują błędy, gdy użytkownik uruchamia przepływy procesów biznesowych bez wystarczających uprawnień w jednostce Proces.

Dotyczy: Microsoft Dynamics CRM
Oryginalny numer KB: 4025533

Symptomy

Nie można wykonać reguł biznesowych lub przepływy procesów biznesowych wyświetlają komunikat o błędzie, który rozpoczyna się od niepowodzenia wtyczki usługi sieci Web w pliku SdkMessageProcessingStepId: (...).

Przyczyna

Jeśli rola zabezpieczeń użytkownika nie ma wystarczających uprawnień w jednostce Proces , która odwołuje się do wewnętrznej tabeli przepływów pracy, reguły biznesowe i przepływy procesów biznesowych nie będą mogły generować, ładować i wykonywać poprawnie przy pierwszym obciążeniu, powodując nieoczekiwane zachowanie lub sporadyczne błędy. W takim przypadku stan jest buforowany, a kolejny użytkownik, którego rola zabezpieczeń ma wystarczające uprawnienia, próbuje załadować i wykonać te same reguły biznesowe i przepływy procesów biznesowych, wystąpi błąd.

Aby sprawdzić poziomy dostępu, przejdź do pozycji Ustawienia>Role>zabezpieczeń> zabezpieczeń wybierz kartę Dostosowywanie> roli > zabezpieczeńJednostka procesu. Kolumna Odczyt powinna być w pełni zielona (dostęp na poziomie organizacji).

Rozwiązanie

Aby rozwiązać ten problem, wykonaj następujące czynności:

  1. Upewnij się, że wszystkie role zabezpieczeń mają pełne uprawnienia do odczytu na poziomie organizacji dla jednostki Proces.
  2. Opublikuj dostosowania, przechodząc do pozycji Dostosowywanie ustawień>>Dostosuj system.