Usługa routera poczty e-mail nie może uruchomić głównego błędu wątku w tle usługi podczas uruchamiania usługi routera poczty e-mail Microsoft Dynamics CRM

Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że po uruchomieniu Microsoft Dynamics CRM usługi routera poczty e-mail może zostać wyświetlony komunikat Usługa routera poczty e-mail nie może uruchomić głównego błędu wątku w tle usługi.

Dotyczy: Microsoft Dynamics CRM 2011 r.
Oryginalny numer KB: 954522

Symptomy

Podczas próby uruchomienia usługi routera Microsoft Dynamics CRM poczty e-mail w Microsoft Dynamics CRM w dzienniku aplikacji jest rejestrowane następujące zdarzenie błędu:

Usługa routera poczty e-mail nie może uruchomić głównego wątku tła usługi

Przyczyna

Ten problem występuje, ponieważ plik Microsoft.Crm.Tools.EmailAgent.SystemState.xml jest uszkodzony.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj następujące czynności:

  1. Usuń plik Microsoft.Crm.Tools.EmailAgent.SystemState.xml.

    Uwaga

    • Domyślnie plik Microsoft.Crm.Tools.EmailAgent.SystemState.xml znajduje się w następującym folderze: C:\Program Files\Microsoft CRM Email\Service.
    • Domyślnie folder Usługi jest ukrytym folderem. Aby wyświetlić ten folder, musisz zmienić ustawienia Eksploratora Windows, aby wyświetlać ukryte pliki i ukryte foldery.
  2. Uruchom ponownie usługę routera poczty e-mail Microsoft Dynamics CRM.

    Plik Microsoft.Crm.Tools.EmailAgent.SystemState.xml zostanie ponownie utworzony.

Jeśli Microsoft Dynamics CRM użytkownicy mają korzystać z routera Email, a nie skrzynki pocztowej do przesyłania dalej, dla przychodzącej poczty e-mail istnieje możliwość powrotu usuniętych wiadomości e-mail do Microsoft Dynamics CRM po zaimplementowaniu tej rozwiązania. Jeśli wiadomość e-mail nie została usunięta ze skrzynki pocztowej użytkownika, router Email może znaleźć wiadomość e-mail użytkownika w skrzynce odbiorczej, nie odnaleźć jej w Microsoft Dynamics CRM i ponownie utworzyć wiadomość e-mail w Microsoft Dynamics CRM. Aby tego uniknąć, należy również usunąć wiadomość e-mail ze skrzynki pocztowej użytkownika wraz z Microsoft Dynamics CRM.

Aby uniknąć tej sytuacji, regularnie wykonaj kopię zapasową następujących plików i zapisz je na pulpicie tego samego serwera.

  • Microsoft.Crm.Tools.EmailAgent.Configuration.bin
  • Microsoft.Crm.Tools.EmailAgent.SystemState.Xml

Jeśli Configuration Manager routera Microsoft Dynamics CRM Email kończy się niepowodzeniem po uruchomieniu lub nie można uruchomić usługi routera Microsoft Dynamics CRM Email, zastąp dwa powyższe pliki w pliku C:\Program Files\ Microsoft CRM Email\Service. Uruchom ponownie usługę routera Microsoft Dynamics CRM Email, a następnie uruchom Configuration Manager routera Microsoft Dynamics CRM Email. Jeśli kopia zapasowa tych plików jest najnowsza, będzie mieć pełną konfigurację routera Email.

Informacje

Aby uzyskać więcej informacji, zobacz Error Email configuration manager was not able to read configuration information occurs when you launch the Microsoft Dynamics CRM Email Router Configuration Manager ..