Um programa do Office é lento ou pode parar de responder (trava) quando você abre um arquivo de um local da rede

Sintomas

Quando você tenta abrir um arquivo de um local da rede em um dos programas do Microsoft Office, como PowerPoint 2003, Excel 2003, Publisher 2003 ou uma versão posterior deles, o programa do Office pode ser executado muito lentamente ou pode parecer parar de responder (trava).

Motivo

Esse comportamento pode ocorrer se a conexão com o local da rede for perdida durante o tempo em que o programa do Office estiver abrindo o arquivo.

Solução alternativa

Importante

Esta seção, método ou tarefa contém etapas que descrevem como modificar o Registro. Entretanto, sérios problemas poderão ocorrer caso você modifique o Registro incorretamente. Portanto, siga essas etapas cuidadosamente. Para mais proteção, faça o backup do registro antes de modificá-lo. Em seguida, você poderá restaurar o registro se ocorrer um problema. Para saber mais sobre como fazer o backup e restaurar o registro, consulte Como fazer o backup e restaurar o registro no Windows.

Para resolver esse comportamento, adicione o valor EnableShellDataCaching ao Registro do Microsoft Windows. Para fazer isso, siga estas etapas:

  1. Feche seus programas do Office.

  2. Clique em Iniciar e em Executar.

  3. Na caixa Abrir, digite regedit e, em seguida, clique em OK.

  4. Localize e clique para selecionar uma das seguintes chaves do Registro apropriada:

    • Microsoft 365 Apps, Office LTSC 2021, Office 2019 e Office 2016:

      HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Open Find

    • Office 2013:

      HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Open Find

    • Office 2010:

      HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Open Find

    • Office 2007:

      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Open Find

    • Office 2003:

      HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\Open Find

  5. Depois de selecionar a chave especificada na etapa 4, aponte para Novo no menu Editar e clique em Valor DWORD.

  6. Digite EnableShellDataCaching e pressione Enter.

  7. Clique com o botão direito do mouse em EnableShellDataCaching e clique em Modificar.

  8. Na caixa Dados do valor, digite 1 e clique em OK.

    Observação

    Qualquer número que não seja zero na caixa Dados do valor ativará o cache. Um número zero ou em branco (padrão) desativará o cache.

  9. No menu Arquivo, clique em Sair para encerrar o Editor do Registro.

O problema foi corrigido?

Verifique se o problema foi corrigido. Se o problema tiver sido corrigido, você terá concluído esta seção. Se o problema não tiver sido corrigido, você poderá contatar o suporte.

Mais informações

Essa situação pode ocorrer depois que você clicar em Abrir na caixa de diálogo Abrir (no menu Arquivo, clique em Abrir) para abrir um arquivo de um local de rede (por exemplo, um servidor de rede). Durante o processo de abertura do arquivo, você perde a conexão de rede ou o local da rede que contém o arquivo, e o arquivo que você está tentando abrir fica perdido. Durante o processo de abertura do arquivo, seu programa do Office tenta adicionar o nome do arquivo e as informações de caminho do arquivo que você está tentando abrir para a lista de arquivos recentes do Windows. Como o local da rede (caminho) agora não existe, o programa do Office pode ser executado lentamente e pode parecer parar de responder (trava).

Observação

Essa situação também poderá ocorrer se sua conexão com a rede estiver lenta porque o programa do Office precisa fazer várias consultas à rede para obter as informações corretas do arquivo.