How to create a custom fill pattern by using a bitmap image in Visio

Summary

This article explains how to create a custom fill pattern by using a bitmap image in Microsoft Office Visio. The custom fill pattern can then be applied to shapes in a Visio drawing.

More Information

Create a custom fill pattern by using a bitmap file

Visio includes 41 fill and shadow patterns: 0 is no pattern; 1 is a solid, one-color pattern; 2 through 24 are bitmap patterns; and 25 through 40 are gradient patterns. Additional custom fill patterns can be created with a bitmap image. To do this, follow these steps:

  1. Start by using one of the following methods, as appropriate:
    • To make the pattern available only in the current drawing, look for the Drawing Explorer window. If the Drawing Explorer window is not open, click Drawing Explorer Window on the View menu.
    • To save the pattern with an existing stencil so that you can open it in any drawing, open the stencil (on the File menu, point to Stencils, click Open Stencil, locate the stencil that you want to open, and then double-click it). Click the icon on the title bar of the stencil, and then click Edit. Click the title bar icon again, and then click Drawing Explorer Window.
    • To create a new stencil with which to save the pattern (to make it available in any drawing), point to Stencils on the File menu, and then click New Stencil. (A new stencil opens in edit mode, so it's not necessary to click Edit when you create a new stencil.) Click the title bar icon, and then click Drawing Explorer Window.
  2. In the Drawing Explorer window, right-click the Fill Patterns folder, and then click New Pattern.
  3. In the New Pattern dialog box, type a name for the pattern (in the Name box under Details), and then click the fill pattern for Type.

    Note You can also create patterns for lines and line ends under Type. Doing so changes the options under Behavior (see step 4).
  4. Under Behavior, select the type of fill behavior that you want for the bitmap:
    • Create multiple copies of the image to fill a shape (tile the image).
    • Use a single centered image.
    • Stretch a single image to fill the shape.
    To adjust the pattern as the drawing page scale changes, click to select the Scaled check box. When you are finished in the New Pattern dialog box, click OK.

    This creates a new fill pattern in the Drawing Explorer window in the Fill Patterns folder.
  5. In the Drawing Explorer window, right-click the new pattern, and then click Edit Pattern.

    This opens the blank Edit Pattern window.
  6. On the Insert menu, point to Picture, and then click From File.
  7. In the Insert Picture dialog box, navigate to the bitmap (.bmp) file for your custom fill, and then click Open.

    This inserts your .bmp file into the Edit Pattern window.
  8. Click the Close Window button (X) to close the Edit Pattern window. Do not quit Visio itself.
  9. When prompted to update your pattern and all the shapes that use it, click Yes.
A new custom fill pattern that uses your bitmap file is now ready to be applied to shapes.

Apply the custom fill pattern

To apply the custom fill pattern, follow these steps:

  1. Select the shape to which you want to apply the custom pattern.
  2. On the Format menu, click Fill. Under Fill, click the custom pattern from the bottom of the Pattern list, and then click OK.

    Note Alternatively, right-click the shape, point to Format, and then click Fill.
Propriedades

ID do Artigo: 295411 - Última Revisão: 11 de ago de 2008 - Revisão: 1

Comentários