Error message when you try to open a Works database file in Works 8.0: "There was a serious error loading the data"

Symptoms

When you try to open a Microsoft Works database file in Microsoft Works 8.0, you receive an error message that is similar to the following:
There was a serious error loading the data. Your document appears to be damaged. Works will stop loading the document with what has been read so far. Please try loading a recent backup copy of this document.
Note This issue occurs when you try to open a Microsoft Works 2000 database file or a database file from a version of Works that is earlier than Works 2000 in Works 8.0.

Cause

This issue occurs when form labels are corrupted in the Works database. A change that was made to the Works 8.0 update will detect any corrupted form labels in a database file.

Workaround

Use an earlier version of Works to modify the database file

  1. Open the database file in an earlier version of Works. For example, open the database file in Microsoft Works 6.0.
  2. Add a label in the Form Design view. To do this, follow these steps:
    1. On the View menu, click Form Design.
    2. Click an empty area in the form.
    3. On the Insert menu, click Label.
    4. In the Type the text for the label below box, type the text, and then click Insert.
    5. On the File menu, click Save to save the database file.
    6. Close Microsoft Works.
  3. Open the database file in Works 8.0.
  4. Delete the label that you added in the Form Design view. To do this, follow these steps:
    1. On the View menu, click Form Design.
    2. Click the label that you added, and then click Delete Selection on the Edit menu.
    3. On the File menu, click Save to save the database file.
You can now open the Works database file in Works 8.0 without performing any additional steps.

Use the Mail Merge Helper feature in Microsoft Word

You can use the Mail Merge Helper feature in Word to change the data source. To do this, follow these steps:
  1. Start Word.
  2. On the Tools menu, click Customize.
  3. Click the Commands tab, and then click All Commands in the Categories list.
  4. In the Commands list, drag MailMergeHelper to the toolbar that you want, and then click Close.
  5. Click the Mail Merge Helper icon on the toolbar, click Create, and then click Form Letters.
  6. Click Get Data, and then click Open Data Source.
  7. In the Look in list, locate and then double-click the Works database file.
  8. Under Data source, click Edit, and then click the path of the database file.
  9. Click Break the Link to import the data records.

    Note After the import is completed successfully, you will be prompted to save the document.
  10. In the Save in list, locate and then click the location where you want to save the document.
  11. Type the file name in the File name box, and then click Save.

    Note After you save the document, the database file opens in Word as a table. Make a note of the number of columns in the table.
  12. On the Edit menu, click Select All.
  13. On the Edit menu, click Copy.
  14. On the Edit menu, click Office Clipboard.
  15. Start Works 8.0.
  16. Open a new database file, and then add the same number of columns that you noted in step 11.
  17. On the Edit menu, click Paste.
  18. Save the new database file.

Use Quick View Plus to copy the contents of the database file

You can use the Quick View Plus program to open the database file. Then, copy the contents of the database file to a new database file in the Works database. To do this, follow these steps:
  1. Download Quick View Plus. To do this, visit the following Avantstar Web site:Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

    Note Follow the instructions that appear on the Web site to obtain an evaluation copy of the Quick View Plus program.
  2. Start the Quick View Plus program.
  3. Open the database file in the Quick View Plus program.
  4. Start Works 8.0.
  5. Create a new database file in the Works database.
  6. Copy the contents of the database file in step 3 to the new database file.
  7. Save the new database file.

More Information

This problem no longer occurs in Microsoft Works 9.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Propriedades

ID do Artigo: 914347 - Última Revisão: 20 de jun de 2014 - Revisão: 1

Comentários