Mensagem de erro: Não há Processadores de Impressão... Criando uma Impressora

Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Sintomas
Ao tentar instalar uma impressora no Windows NT, você poderá receber uma das seguintes mensagens de erro:

  • Não há processadores de impressão
  • Processador de Impressão é desconhecido
Causa
Esse comportamento pode ocorrer se todas as seguintes condições existirem:

  • Nenhum processador de impressão é especificado no registro do Windows NT.
  • O arquivo do processador de impressão (Winprint.dll) está ausente ou corrompido.
Resolução
Para resolver o problema, execute estas etapas:

  1. Verifique se o arquivo Winprint.dll existe na seguinte pasta:

    %SystemRoot%\system32\spool\prtprocs\w32x86

    Se o arquivo Winprint.dll estiver ausente, use o comando a seguir para expandir o arquivo Winprint.dl_ no seu CD-ROM de instalação do Windows NT ou nos discos de instalação para o Winprint.dll na pasta acima:

    expand x:\i386\winprint.dl_ c:\winnt\system32\spool\prtprocs\w32x86\winprint.dll

    onde x: é a letra da unidade da sua unidade de CD-ROM.
  2. Verifique se o processador de impressão está configurado corretamente no Registro do Windows NT. Para fazer isto, execute as etapas a seguir:

    AVISO: Ao usar o Editor do Registro incorretamente pode causar problemas sérios no sistema inteiro que podem necessitar da reinstalação do Windows NT para corrigi-los. A Microsoft não garante que qualquer problema resultante do uso do Editor de Registro possa ser resolvido. O uso dessa ferramenta é de sua responsabilidade.

    a. Localize a seguinte chave no Registro do Windows NT:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print \Environments\Windows NT x86\Print Processors\winprint

    Se a chave Winprint não estiver presente, crie-a clicando em Adicionar chave no menu Editar. Se o Winprint.dll não for especificado como o valor do Driver na chave Winprint, clique em Adicionar valor no menu Editar para criar o valor do Driver usando as seguintes configurações:

    Driver:REG_SZ:winprint.dll

    OBSERVAÇÃO: Talvez seja necessário reiniciar o computador após fazer essas alterações.
3.10 installed
Observação: este é um artigo de “PUBLICAÇÃO RÁPIDA” criado diretamente pela organização de suporte da Microsoft. As informações aqui contidas são fornecidas no presente estado, em resposta a questões emergentes. Como resultado da velocidade de disponibilização, os materiais podem incluir erros tipográficos e poderão ser revisados a qualquer momento, sem aviso prévio. Consulte os Termos de Uso para ver outras informações.
Propriedades

ID do Artigo: 105247 - Última Revisão: 12/04/2015 09:46:20 - Revisão: 1.0

Microsoft Windows NT Workstation 3.1, Microsoft Windows NT Workstation 3.5, Microsoft Windows NT Workstation 3.51, Microsoft Windows NT Workstation 4.0 Developer Edition, Microsoft Windows NT Server 3.51, Microsoft Windows NT Server 4.0 Standard Edition

  • kbnosurvey kbarchive kbprint KB105247
Comentários