As Fontes TrueType Estão Faltando na Pasta de Fontes ou de Programas

Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
IMPORTANTE: Este artigo contém informações sobre como editar o registro. Antes de editar o registro, primeiro você deve fazer uma cópia de backup dos arquivos do registro (System.dat e User.dat). Ambos são arquivos ocultos na pasta Windows.
Sintomas
É possível observar um ou mais dos seguintes sintomas:
  • As fontes TrueType podem não estar presentes na pasta de Fontes.
  • Você pode receber a seguinte mensagem de erro se tentar adicionar uma fonte TrueType:
    A fonte TrueType <nomedafonte> já está instalada. Para instalar uma nova versão, primeiro remova a versão antiga.
  • As fontes TrueType não são listadas em nenhum programa.
  • Documentos criados anteriormente são impressos de maneira diferente ou a formatação é alterada ao visualizar o documento.
  • Ao imprimir um documento, o texto pode parecer menor do que o esperado.
  • As configurações personalizadas da área de trabalho têm fontes alteradas.
Causa
A chave de registro que lista as fontes TrueType pode estar danificada ou estar faltando.
Resolução
Para resolver esse problema, use o método adequado:

Use a ferramenta Fontreg

Executar Fontreg.exe adiciona uma chave de registro que permite a instalação de fontes TrueType. Para executar Fontreg.exe e instalar as fontes, siga estes passos:

NOTA: A ferramenta Fontreg (Fontreg.exe) não está inclusa no Windows NT 4.0. Para usar essa ferramenta no Windows NT 4.0, copie o arquivo Fontreg.exe de um computador com base em Windows 95/98.
  1. Clique no botão Iniciar, e então clique em Executar.
  2. Digite fontreg na caixa Abrir e clique em OK.
  3. No Painel de controle, clique duas vezes em Fontes.
  4. No menu Arquivo, clique em Instalar nova fonte.
  5. Na caixa Pastas, selecione a pasta que contiver as fontes TrueType (geralmente Windows\Fontes).
  6. Clique em Selecionar todas e depois clique em OK.
  7. Se seus documentos não forem impressos da maneira esperada, remova e reinstale o driver adequado para a impressora.

Edite a Chave de Registro de Fontes

AVISO: O uso incorreto do Editor de registro pode causar problemas sérios que podem fazer com que você precise reinstalar o Windows 95/98 ou o Windows NT. A Microsoft não pode garantir que os problemas resultantes da utilização incorreta do Editor de registro possam ser solucionados. Use o Editor de registro por sua própria conta e risco.

NOTA: Para obter informações sobre como editar o registro, consulte o tópico Como Alterar Chaves e Valores da Ajuda on-line do Editor de Registro (Regedit.exe). Observe que primeiro você deve fazer uma cópia dos arquivos do registro (System.dat e User.dat) antes de editar o registro.

Para substirtuir uma chave de Fontes danificada ou que está faltando no registro, siga estes passos:
  1. Mova o conteúdo da pasta Fontes para uma pasta vazia.
  2. Se a chave de Fontes existir na seguinte configuração do regsitro, exclua a chave de Fontes e adicione-a novamente:

    Windows 95/98:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion

    Windows NT:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion


    Se a chave de Fontes não existir na configuração do registro listada acima, adicione a seguinte chave:
    Fontes
  3. No Painel de controle, clique duas vezes em Fontes.
  4. No menu Fontes, clique em Instalar nova fonte.
  5. Na caixa Pastas, selecione a pasta para a qual você moveu as fontes no passo 1.
  6. Clique em Selecionar todas e depois clique em OK.
  7. Se seus documentos não forem impressos da maneira esperada, remova e reinstale o driver adequado para a impressora.
Mais Informações
Observe que o Windows 95/98 tem um limite de aproximadamente 1000 fontes.

Para obter mais informações sobre esse problema, consulte o seguinte artigo na Base de Dados de Conhecimento da Microsoft:
ARTIGO: 131943
TÍTULO : TrueType Font Limits in Windows 95/98/Me
98 ttf winnt
Propriedades

ID do Artigo: 133732 - Última Revisão: 12/04/2015 11:45:17 - Revisão: 1.2

Microsoft Windows 95, Microsoft Windows 98 Standard Edition, Microsoft Windows NT Server 4.0 Standard Edition, Microsoft Windows NT Workstation 4.0 Developer Edition, Microsoft Windows 98 Second Edition, Microsoft Windows Millennium Edition

  • kbnosurvey kbarchive kberrmsg kbprint kbprb KB133732
Comentários